(help!) New Member from GA with a WJ - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Site Information > New Members - Welcome!

Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-25-2014, 07:32 PM
ymaqousi24's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Nov 2014
Location: Georgia
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 970
ymaqousi24 is on a distinguished road
Garage
Exclamation (help!) New Member from GA with a WJ

Hello! I just purchased a 2000 Grand Cherokee Limited 4.7 and I am having some trouble. I have gotten a lot of great information from this site already and used it to work on my new baby, but now I'm stuck. My jeep runs great and will take off, but once it has warmed up it shuts off. When I say shut off I mean its like I just turned the key. It has happened more while idling but it has happened twice while driving. I'm getting a P0505 engine code, so I replaced the IAC and the CPS. I was certain it was the CPS as once I changed that the airbag light went off (it has been on since i purchased the jeep). Once it shuts off I can't crank it again until it has cooled off.

I would really appreciate any help anyone has to offer!
Thanks in advance.

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 11-25-2014, 07:46 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,614
Thanks: 23
Thanked 423 Times in 408 Posts
Rep Power: 529934
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: (help!) New Member from GA with a WJ

Welcome to the garage.
With CPS you mean the crank sensor, right? I only couldnīt find the relation between the CPS and the airbag light.
Your problem of the engine shutting off could be a crank or cam sensor.
But the IAC fault code (P0505) could mean a shorted or open wire to the IAC stepper motor. I would check the wire bundles well for any shaving or sharp bends.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
The Following User Says Thank You to Frango100 For This Useful Post:
  #3  
Old 11-25-2014, 07:52 PM
ymaqousi24's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Nov 2014
Location: Georgia
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 970
ymaqousi24 is on a distinguished road
Garage
Re: (help!) New Member from GA with a WJ

i do mean crankshaft position sensor. i read on the forums that it would cause your gauges to malfunction and the airbag light went out the second i turned the car on after replacing the CPS. As for the wiring to the IAC it all seems intact and in good condition.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 11-25-2014, 08:10 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,614
Thanks: 23
Thanked 423 Times in 408 Posts
Rep Power: 529934
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: (help!) New Member from GA with a WJ

Did all the gauges fail as well?
I would measure all four wires between PCM and IAC for continuity and short to ground, while messing a bit with the bundle. This can be a PCM problem as well.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 11-25-2014, 08:16 PM
ymaqousi24's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Nov 2014
Location: Georgia
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 970
ymaqousi24 is on a distinguished road
Garage
Re: (help!) New Member from GA with a WJ

Yes all gauges fail when it shuts off and it wont crank until its cooled. Do you happen to have a wiring diagram so i can check with my multimeter for resistance to ground. (like which pins are which on male plugs.)
Reply With Quote
  #6  
Old 11-25-2014, 08:22 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,614
Thanks: 23
Thanked 423 Times in 408 Posts
Rep Power: 529934
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: (help!) New Member from GA with a WJ

All gauges fail seems to be related to the PCI data bus. The PCM sends all the data via this bus to the instrument panel, but also communicates with other modules, like the SKIM (sentry key immobilizer module). When there is no key ok signal from the SKIM to the PCM, the engine will start, but shut off after 3 seconds. Does this happen on your jeep? Is the SKIS key symbol lit on the instrument panel when it doesnīt want to start?
In attachment the IAC stepper motor wiring.
Attached Files
File Type: pdf IAC.pdf (186.9 KB, 3 views)
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 11-25-2014, 08:27 PM
ymaqousi24's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Nov 2014
Location: Georgia
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 970
ymaqousi24 is on a distinguished road
Garage
Re: (help!) New Member from GA with a WJ

yes that light illuminates but I'm usually able to drive for around 5 minutes (sometimes more sometimes less)
Reply With Quote
  #8  
Old 11-25-2014, 08:27 PM
ymaqousi24's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Nov 2014
Location: Georgia
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 970
ymaqousi24 is on a distinguished road
Garage
Re: (help!) New Member from GA with a WJ

oh if it helps since ive replaced the IAC the idle started out normal (somewhere around 800rpm) but then after putting some miles on her the idle shot up to 2000 rpm even while not idling. i dint even have to press the gas to drive if i didn't need to go over 25MPH.
Reply With Quote
  #9  
Old 11-25-2014, 08:29 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,614
Thanks: 23
Thanked 423 Times in 408 Posts
Rep Power: 529934
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: (help!) New Member from GA with a WJ

That looks as a faulty TPS, but it still can be a problem in the PCM as well.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #10  
Old 11-25-2014, 08:38 PM
ymaqousi24's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Nov 2014
Location: Georgia
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 970
ymaqousi24 is on a distinguished road
Garage
Re: (help!) New Member from GA with a WJ

would the TPS cause it die and crank but not start? I'm thinking there's some kind of problem with the CPU or corresponding system? what exactly is the PCM?
Reply With Quote
  #11  
Old 11-25-2014, 08:50 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,614
Thanks: 23
Thanked 423 Times in 408 Posts
Rep Power: 529934
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: (help!) New Member from GA with a WJ

PCM = powertrain control module = ECU = engine control unit.
I have never tried to start with the CPS disconnected, so canīt confirm this.
If you have a scanner with live data, then you could check the TPS %.
But the failing gauges and the no start condition indeed points towards the PCM.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #12  
Old 11-25-2014, 09:00 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,614
Thanks: 23
Thanked 423 Times in 408 Posts
Rep Power: 529934
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: (help!) New Member from GA with a WJ

To rule out any of the PCI bus connected components to be the culprit, you could split the bus. There is a diagnostic junction port more or less left of the brake pedal (so not the data link connector). There is a shorting cap, connecting all the components together. When you remove the shorting cap, you will separate the PCM, TCM and SKIM from the rest of the components. If it then runs normally, then you are sure that the PCM is ok. If it doesnīt, then most probably the PCM is faulty. You will only loose all gauges, many instrument panel lights will be lit and several other systems wonīt work, but you can confirm the fault.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help help help!! Anyone pleae help! ashenmorality Trouble Shooting/Problems/Service 35 07-17-2014 03:35 PM
Not a New Member .. but I feel like a new member 07JGC New Members - Welcome! 4 06-19-2014 01:25 PM
new member in need of urgent help luisjg Grand Cherokee - WK2 - 4 03-07-2011 10:39 PM
New Member - Help needed on buying 08-09 SRT8 dcsrt8 Grand Cherokee SRT8 - WK 7 03-03-2011 10:50 AM
New member. Ordering my Overland TONIGHT! What color? help!!! JTS97Z28 Grand Cherokee - WK2 - 44 02-02-2011 06:39 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:09 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.