Jeep from Oz - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Site Information > New Members - Welcome!

Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-26-2014, 10:14 PM
New Member
 
Join Date: Dec 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Pickers is on a distinguished road
Jeep from Oz

Hi Jeep people, I am a new member from Australia and my beloved Jeep Cherokee CRD (2007 diesel model) has developed an intermittent fault where it suddenly loses all acceleration whilst driving and engine shudders like it is going to stall, but engine doesn't actually shut off. Once I turn ignition off, wait a few seconds and then start up again, all is fine until the next episode, which could be anything from 14 days later to 2 days later. It happens at random speed, random temperature, random distances and there is no warning prior to it happening and no warning lights on dash. Jeep's computer unable to detect an error code, thinking maybe a loose connection somewhere, but WHERE to start looking?
If anyone has experienced anything like this or any thoughts on what direction to take, I would love to hear from you - am not ready to scrap it yet but is frustrating everybody who has to deal with it. Thank you.

Reply With Quote
Sponsored Links
Advertisement
 
Reply

Tags
jeep

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:05 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.