Jeep Missing - Page 2 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Site Information > New Members - Welcome!

Reply
 
Thread Tools Display Modes
 
  #13  
Old 05-11-2016, 12:26 PM
Member
 
Join Date: Apr 2016
Posts: 8
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 438
Turkey Tom is on a distinguished road
Re: Jeep Missing

Removed the #5 spark plug yesterday...it was actually clean...maybe too clean...laid the connected coil with the plug on the block & started the motor...there was a 3" arc coming off the coil but no spark showing on the plug electrode...noticed the plug was a Champion...never had much luck with those...but my manual recommends them...haven't removed the #8 plug as of yet...as it looks like a bear to get to...

Reply With Quote
Sponsored Links
Advertisement
 
  #14  
Old 05-12-2016, 11:11 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,613
Thanks: 23
Thanked 423 Times in 408 Posts
Rep Power: 529932
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Jeep Missing

You can use any brand copper core plug, but our engines donīt seem to like the fancy irridium or other types. I never had any problems with Champions though.
I would first try an other coil with the same plug and check if the same thing happens. Or an other plug on the same coil. If the plugs are old, i would just change them all out.
The #8 plug is a bit more difficult, but with an extension and maybe a hinge it is not too bad to do. Donīt forget the ground strap on the #8 coil when mounting it back again.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Tags
jeep

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
missing my jeep woodslasher Grand Cherokee - ZJ 2 08-22-2013 05:26 PM
1999 Jeep 4.0 Overheated, then started ticking and missing 1999xj Cherokee-SJ and XJ 3 04-23-2013 08:48 PM
Jeep.com Owners site. Incomplete service history and missing service contract info the1jake Trouble Shooting/Problems/Service 4 02-24-2011 05:14 PM
Hmmmm....Am I missing something here? Redsand Grand Cherokee - WK 3 08-12-2009 03:53 AM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:08 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.