New member and have a problem - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Site Information > New Members - Welcome!

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-31-2016, 10:16 AM
New Member
My Jeep: 2007 3.6L
 
Join Date: Aug 2016
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
pbagstad is on a distinguished road
Question New member and have a problem

Hello all,
Im a new to me Jeep owner. It's a 07 Grand Cherokee. Hoping someone can tell me where to start. Have a new alternator put on about 3 weeks ago, everything was going great but now vehicle won't start. After it gets a jump start it runs. Should I check battery 1st? Have the alternator checked.
Any help is greatly appreciated

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 08-31-2016, 10:22 AM
bill_de's Avatar
Premium Member
My Jeep: 2017 5.7L WK2
 
Join Date: Sep 2012
Posts: 8,552
Thanks: 725
Thanked 1,048 Times in 815 Posts
Rep Power: 1805860
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: New member and have a problem

Quote:
Originally Posted by pbagstad View Post
Hello all,
Should I check battery 1st? Have the alternator checked.
Yes and Yes. Sounds like you know what you are doing. Good luck and Welcome to the Garage.

--
__________________
If you need a shoulder to cry on ...
... pull over to the side of the road!

Reply With Quote
  #3  
Old 09-09-2016, 08:38 PM
Governor's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Apr 2016
Location: Alabama
Posts: 1,790
Thanks: 730
Thanked 314 Times in 294 Posts
Rep Power: 79632
Governor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond repute
Re: New member and have a problem

Welcome and good luck sorting the problem. If you run into further difficulty, post in the electrical section of the main menu, you will get many more responses. Best of luck.
Reply With Quote
  #4  
Old 09-10-2016, 04:53 PM
UKJeeper's Avatar
Member
My Jeep: 2000 4.0L WJ
 
Join Date: May 2016
Location: Waterlooville, Hampshire, U.K.
Posts: 424
Thanks: 2
Thanked 33 Times in 32 Posts
Rep Power: 702
UKJeeper is on a distinguished road
Garage
Re: New member and have a problem

Welcome aboard!
__________________
2000 WJ Grand Cherokee Limited 4.0 petrol, only 68,150 Miles and counting!.....Got some catching up to do!
Reply With Quote
  #5  
Old 09-10-2016, 05:11 PM
tomk's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2012
Location: Amherst, MA
Posts: 769
Thanks: 15
Thanked 97 Times in 82 Posts
Rep Power: 1566085
tomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond reputetomk has a reputation beyond repute
Re: New member and have a problem

Yeah, I'd look at the battery .. how old is it? (there should be a date-code sticker on it if you don't know) ..

If a failed alternator caused the battery to fully discharge several times, the battery is probably shot. with the engine running, you should see 14-ish volts at the battery terminals if the alternator is working OK.
__________________
2007 WK Limited 5.7L
2014 WK2 Overland 5.7L
And a few past Durangos
de W1PF
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Do you have to have UConnect to have GPS Dave E 2014+ Cherokee-KL 17 11-09-2015 10:29 PM
new to the jeep thang and have an oil problem shawn89 Troubleshooting/Problems 9 07-16-2012 08:11 PM
NEW member: i have an 08 JGC Laredo and i want HIDs mtlongisland2 New Members - Welcome! 4 12-19-2011 05:28 PM
Hi I'm a new member and i have a question tropick New Members - Welcome! 6 04-13-2011 09:02 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:57 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.