New to Forum and in a mess - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Site Information > New Members - Welcome!

Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-24-2013, 08:38 AM
New Member
My Jeep: 2005 5.7L WK
 
Join Date: Aug 2013
Location: Alabama
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jeepforever is on a distinguished road
New to Forum and in a mess

It's a long story. Had plugs and ignition cables replaced by an Auto shop and had problems ever since. They put the ignition cables in backwards then I just found the CAI not attached. Much needed help. Searching the sub-forums!

Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Classic Oil Change Mess Up GroupW Grand Cherokee - WK2 - 17 12-05-2011 01:07 PM
ATTENTION: Pardon our mess---PLEASE READ! Scottina06 Grand Cherokee - WK 0 09-26-2011 11:07 PM
Excuse our mess here PLEASE! Scottina06 Grand Cherokee SRT - WK2 26 07-04-2011 10:24 AM
Need Help W/ Mess. on Info Center SRTDZGN Grand Cherokee - WK 10 05-27-2010 10:04 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:53 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.