Uconnect problems - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Site Information > New Members - Welcome!

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-29-2013, 12:12 AM
New Member
 
Join Date: May 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
corkery is on a distinguished road
Uconnect problems

We have experienced some problems with the Uconnect in the Jeep grand Cherokee limited. Within the first week the screen went black. The Jeep ran but nothing in the electronics worked. The Quadra-Tac was inoperable, This has happened twice in various forms.

Wednesday while driving in "D" the backup camera displayed. Above about 10 mph we had a blue screen then when I applied the brakes and slowed to about 10 mph the backup camera would display the same as if I was in reverse. When I drove the Jeep later in the day Uconnect seemed to work. Is this a software problem or do we need to order a new module?

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 05-29-2013, 06:14 AM
Willx's Avatar
Premium Member

My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,989
Thanks: 536
Thanked 953 Times in 512 Posts
Rep Power: 1928220
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: Uconnect problems

Welcome to JeepGarage

Sounds like more than just software. That is pretty severe.
__________________
Reply With Quote
  #3  
Old 05-29-2013, 06:21 PM
SnoFire's Avatar
The Negotiator
 
Join Date: Jun 2011
Location: Wisconsin
Posts: 5,155
Thanks: 71
Thanked 189 Times in 146 Posts
Rep Power: 391210
SnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond repute
Garage
Welcome to JeepGarage!! What version of the software are you running?
__________________
2017 Grand Cherokee Limited Lux II Granite Metallic

2014 Jeep Grand Cherokee Limited Max Steel V6
2001 Jeep Grand Cherokee Laredo Black 4.0 I6
1997 Jeep Grand Cherokee Laredo Silver I6
Reply With Quote
  #4  
Old 06-02-2013, 10:13 AM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,891
Thanks: 5
Thanked 31 Times in 31 Posts
Rep Power: 27135
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: Uconnect problems

Welcome to JeepGarage|
__________________
Silver 2004 Jeep Grand Cherokee Special Edition I6 4.0
stock 'cept for
Pioneer Primere Deh-P840 headunit XMD-1000 (xm receiver) Audionbahn Bandpass Box with 2 Audiobahn 12" subs powered by Audiobahn Amp|
Escort 8500 X50 radar detector hardwired to auto dim rearview mirror|V3 projector headlights with 6K HIDs in Lows, 3K HIDs in Fogs|black brush guard & black nerf bars|Hyper White LEDs in interior lights, and Rear License Plate|16" JK unlimited wheels

Custom 2001 Mitsubishi Galant pics can be seen here
Reply With Quote
  #5  
Old 06-04-2013, 04:25 PM
Gus9890's Avatar
Premium Member
My Jeep: 2001 4.0L WJ
 
Join Date: Apr 2011
Location: Northeast FL
Posts: 4,756
Thanks: 38
Thanked 73 Times in 72 Posts
Rep Power: 409302
Gus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond repute
Re: Uconnect problems

Welcome to Jeep Garage!!
__________________
2001 Silverstone Metallic WJ Limited
2005 Black Chevy Tahoe Z71 4x4
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
UConnect problems with Samsung Galaxy Parrot Trouble Shooting/Problems/Service 13 02-08-2015 09:05 AM
problems with Uconnect Debhal Trouble Shooting/Problems/Service 45 07-25-2013 12:34 AM
Did your Uconnect 8.4N problems start after registering? not_too_shabby Audio/Visual/Navigation 28 06-02-2013 04:56 PM
Uconnect/Nav screen problems wstrick17 Trouble Shooting/Problems/Service 6 01-15-2013 07:16 PM
Iphone 3gs and uconnect problems rammunitiondb9 Troubleshooting/Problems 9 11-02-2011 08:20 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:12 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.