Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-20-2013, 11:46 PM
Crashtown's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: Durango, CO
Posts: 390
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1727
Crashtown is on a distinguished road
2005 5.7 Hemi Jumpy Transmission While Accelerating

Not sure how to diagnose this. At least once a day, while moderate or heavy acceleration, it feels like the transmission will jump in/out gear momentarily, sometimes 2-4 times in row. I'll lay off the throttle or give it more & it will go away, most of the time. It doesn't feel engine related to me, but not ruling it out. No CEL or any EVIC notices, just an anti-climatic feeling when I mash on the skinny pedal & my WK spazzes out in traffic. Any takers?
__________________

__________________

2005 Inferno Red 5.7 Hemi Limited QDII - Rock Krawler X-Factor - OME N190 Rear Shocks - BF Goodrich All-Terrain 265/70/17E - 08-10 Front Fascia Conversion - Saguaro 4XComponents Boulder Grill Insert - AEM Brute Force CAI - Billet Technology Catch Can
Reply With Quote
  #2  
Old 10-21-2013, 10:35 PM
Combat's Avatar
Member
My Jeep: 2006 5.7L WK
 
Join Date: May 2012
Location: Rancho Cucamonga, CA
Posts: 182
Thanks: 1
Thanked 3 Times in 2 Posts
Rep Power: 993
Combat has a reputation beyond reputeCombat has a reputation beyond repute
Garage
Re: 2005 5.7 Hemi Jumpy Transmission While Accelerating

Quote:
Originally Posted by Crashtown View Post
Not sure how to diagnose this. At least once a day, while moderate or heavy acceleration, it feels like the transmission will jump in/out gear momentarily, sometimes 2-4 times in row. I'll lay off the throttle or give it more & it will go away, most of the time. It doesn't feel engine related to me, but not ruling it out. No CEL or any EVIC notices, just an anti-climatic feeling when I mash on the skinny pedal & my WK spazzes out in traffic. Any takers?
Throwing any codes?

Have you had a recent trans service lately? if so, is it possible they under filled or overfilled? You will be surprised how much an Overfilled or under filled Automatic transmission can affect the 545rfe.

Also, have you checked your Vss sensors? Cheap and easy replacement on our transmissions. Potentially bad Vss sensors can cause a number of issues too.

But just don't throw money at it, check for codes. You wouldn't want it to be something potentially bad that could have been an easy fix and end up buying a whole new trans like me.
__________________

__________________
(06' Black JGC Limited with FULL SRT8 Body Kit, SRT8 Roof Rails and Mopar Spoiler, Mopar Front Bumper Grill Badge, Hemi345 BADGE, Diablo Trinity Programmer W/91 Performance Tune from ST Motorsports,SheraDon Stage 3 Performance Transmission + 2800 Stall, Inertia Performance Heads, Inertia Spartan Plus Cam, Srt8 Headers/Exhasut Manifolds, Full SRT8 Corsa Exhaust System W/ Reso Delete, Brian Quick 5" tips, 20% UD Pulley, 85mm Ported TB, K&N 77 Series CAI, Jet Flow 180* T-Stat, Billet Catch Can, 22 Inch Flat Black Factory Reproduction SRT 8 Replicas, Eibach Lowering Springs, Power Stop Rotors, Painted Red Calipers, Bosh Iridium Plugs, Shorty Billet Antennae, Limo Tint All Around with Mopar Matte Black Front Window Decal) and Jeep Black Ops Paramedic Hood
[SIGPIC][/SIGPIC]
Diablo Trinity Tuner(Best 1/4 13.29 @ 103mph,-Best 1/8 8.45 @ 84mph -Best 0-60 4.79sec
Reply With Quote
  #3  
Old 10-22-2013, 06:12 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,644
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525441
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2005 5.7 Hemi Jumpy Transmission While Accelerating

Vss sensors on a 5-45RFE. Is a Vss not a vehicle speed sensor?
Did you mean the input and output speed sensors maybe?
With jumpy transmission do you mean that it seems to be slipping? Does the engine rpm rev higher then it used to?
Checking the fluid level and quality would indeed be the first step to be taken.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 10-24-2013, 07:08 PM
Crashtown's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: Durango, CO
Posts: 390
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1727
Crashtown is on a distinguished road
Re: 2005 5.7 Hemi Jumpy Transmission While Accelerating

Nope, no codes. Trans fluid level was the first thing I checked. Did my own service 2 years/20K ago. everything looked good. By jumpy, I mean that it feels like its trying to shift to an upper gear when I want it to stay in the same gear so I can dust some traffic. It seems to happen around the 3,000RPM range 2nd gear. It's only for a split second. My dad thought it was the engine cutting out. Feels like it jumps up to 3rd or even 4th, then back down to 2nd. Sometimes it's once, sometimes 2-4 times before straitening out & allowing me to accelerate. I haven't paid attention to see what the RPMs are doing when it happens. It just surprises me & does it at random.
__________________
Reply With Quote
  #5  
Old 10-25-2013, 12:52 AM
Combat's Avatar
Member
My Jeep: 2006 5.7L WK
 
Join Date: May 2012
Location: Rancho Cucamonga, CA
Posts: 182
Thanks: 1
Thanked 3 Times in 2 Posts
Rep Power: 993
Combat has a reputation beyond reputeCombat has a reputation beyond repute
Garage
Re: 2005 5.7 Hemi Jumpy Transmission While Accelerating

How many miles? Could it be MDS kickin in and out?
__________________
(06' Black JGC Limited with FULL SRT8 Body Kit, SRT8 Roof Rails and Mopar Spoiler, Mopar Front Bumper Grill Badge, Hemi345 BADGE, Diablo Trinity Programmer W/91 Performance Tune from ST Motorsports,SheraDon Stage 3 Performance Transmission + 2800 Stall, Inertia Performance Heads, Inertia Spartan Plus Cam, Srt8 Headers/Exhasut Manifolds, Full SRT8 Corsa Exhaust System W/ Reso Delete, Brian Quick 5" tips, 20% UD Pulley, 85mm Ported TB, K&N 77 Series CAI, Jet Flow 180* T-Stat, Billet Catch Can, 22 Inch Flat Black Factory Reproduction SRT 8 Replicas, Eibach Lowering Springs, Power Stop Rotors, Painted Red Calipers, Bosh Iridium Plugs, Shorty Billet Antennae, Limo Tint All Around with Mopar Matte Black Front Window Decal) and Jeep Black Ops Paramedic Hood
[SIGPIC][/SIGPIC]
Diablo Trinity Tuner(Best 1/4 13.29 @ 103mph,-Best 1/8 8.45 @ 84mph -Best 0-60 4.79sec
Reply With Quote
  #6  
Old 10-25-2013, 03:35 AM
EtherealPonx's Avatar
Member
My Jeep: 2009 5.7L WK
 
Join Date: Mar 2013
Location: Dubai, UAE
Posts: 264
Thanks: 0
Thanked 8 Times in 8 Posts
Rep Power: 735
EtherealPonx is on a distinguished road
Garage
Hey there, I had a similar 'concern' , noticed a strange shift in and out of 3rd going up in gears. This was from brand new and thought at first it was the gearbox design. After months of not feeling this is normal I took it to the dealer who initially claimed this is down to driving conditions! However, what I noticed was a very slight change in rpm when changing into third, which led me to believe it was changing up in gears (too late). The dealer finally accepted my claim. They said they flashed the TCM and it should now be 'ok'. I feel the shift points to be slightly better. The jumpy feeling you describes sounds similar as the shift point felt forced and not a very smooth transmission. This issue might not be relevant but worth checking, try to measure the rpm changes when shifting to third from second and note down the difference.
__________________
2009 5.7 Overland: Borla CB | BMC CAI | SC 93Oct tune |2" RC | Bilsteins | Stillen | DOT5 | ProComp Rims | 265/65/17 Toyo A/T | JBA UCA | BWoody Links | BT Catch Can | Rock Super Sliders & front/rear skid | Hertz Amps/Speakers/12" Sub | Interior/Exterior LEDs | CAF | p/w | SRT Pedals | Black pillars | Black trim | Black Jeep Emblems | Black Callipers | Stillen Accents | SunGuard Tint | Carbon Fiber Interior trim | Gorilla Lug nuts | Tinted tails | Debadged
Reply With Quote
  #7  
Old 10-30-2013, 11:30 PM
Crashtown's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: Durango, CO
Posts: 390
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1727
Crashtown is on a distinguished road
Re: 2005 5.7 Hemi Jumpy Transmission While Accelerating

I'm close to 105K. It feels more "violent" than the MDS twitching. Trying to avoid the dealer on anything. I have only experienced it a couple times over the last two weeks. I'll keep checking in.
__________________
Reply With Quote
  #8  
Old 10-31-2013, 05:22 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,894
Thanks: 8
Thanked 26 Times in 25 Posts
Rep Power: 11193
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: 2005 5.7 Hemi Jumpy Transmission While Accelerating

I have the same problem but never under heavy acceleration
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #9  
Old 12-03-2013, 07:12 PM
Crashtown's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: Durango, CO
Posts: 390
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1727
Crashtown is on a distinguished road
Re: 2005 5.7 Hemi Jumpy Transmission While Accelerating

Sooooo... I stalled out in traffic, while decelerating to make a right turn. I coasted out of the way to a complete stop. Shifted into park, got restarted, & my CEL popped up. Retrieved a P0335 diagnostic code, which is a crankshaft positioning sensor. Picked one up @ Auto Zone, over half the price of the dealer, changed out in 5 minutes. It seems to have solved my janky acceleration issues.
__________________
Reply With Quote
  #10  
Old 12-04-2013, 07:18 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,894
Thanks: 8
Thanked 26 Times in 25 Posts
Rep Power: 11193
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: 2005 5.7 Hemi Jumpy Transmission While Accelerating

Quote:
Originally Posted by Crashtown View Post
Sooooo... I stalled out in traffic, while decelerating to make a right turn. I coasted out of the way to a complete stop. Shifted into park, got restarted, & my CEL popped up. Retrieved a P0335 diagnostic code, which is a crankshaft positioning sensor. Picked one up @ Auto Zone, over half the price of the dealer, changed out in 5 minutes. It seems to have solved my janky acceleration issues.
Glad you could resolve your problem. Mine is still happening! For years.
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #11  
Old 12-06-2013, 10:17 PM
Strongjeff's Avatar
Project Six Shooter
My Jeep: 2008 3.7L WK
 
Join Date: Sep 2012
Location: Songwon, South Korea
Posts: 4,008
Thanks: 86
Thanked 136 Times in 131 Posts
Rep Power: 10591
Strongjeff has a reputation beyond reputeStrongjeff has a reputation beyond reputeStrongjeff has a reputation beyond reputeStrongjeff has a reputation beyond reputeStrongjeff has a reputation beyond reputeStrongjeff has a reputation beyond reputeStrongjeff has a reputation beyond reputeStrongjeff has a reputation beyond reputeStrongjeff has a reputation beyond reputeStrongjeff has a reputation beyond reputeStrongjeff has a reputation beyond repute
Garage
Re: 2005 5.7 Hemi Jumpy Transmission While Accelerating

Quote:
Originally Posted by Madanio24 View Post
Glad you could resolve your problem. Mine is still happening! For years.
mine don't do that, and you have the same issue as the 5-54? we both have the W5A580/NAG1. does yours have the dipstick, all I have is a sealed tube..
__________________
2008 JGC, Grey Stone Metallic SRT-6
MODS-http://www.jeepgarage.org/f5/project-six-shooter-build-thread-68955.html
Reply With Quote
  #12  
Old 12-07-2013, 11:51 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,894
Thanks: 8
Thanked 26 Times in 25 Posts
Rep Power: 11193
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: 2005 5.7 Hemi Jumpy Transmission While Accelerating

I have the dipstick.
__________________

__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
Reply

Tags
hemi

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission/Diff slipping after stopping and then accelerating Hard2reed Trouble Shooting/Problems/Service 4 05-27-2014 11:18 AM
Transmission 2005 grand cherokee jenabaker Troubleshooting/Problems 2 09-18-2013 07:31 AM
2005 gc limited v8 5.7l transmission over temp Esp1221 Troubleshooting/Problems Discussion 1 09-15-2013 01:21 PM
WK Hemi 2005: Transmission problems asuricat Troubleshooting/Problems 13 09-08-2013 12:44 PM
2005 Renegade Transmission Cooling lines lucidsoul5 Liberty-KJ and KK 0 01-17-2013 07:04 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:06 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community