Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-21-2011, 03:41 AM
4.whoa's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: ks
Posts: 1,732
Thanks: 46
Thanked 14 Times in 12 Posts
Rep Power: 1141576
4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute
Garage
Does this sound right to you?

Well, my '05 is giving me "service 4wd system" along with "service elec brake system" and both ABS & ESP dash lights. sometimes its just the chime and lights, sometimes nothing at all, sometimes the brake pedal is very hard to push-then drops to the floor, and sometimes (only when its just started and in the 1st 50') it grinds and clunks something terrible and it rocks the whole thing side to side!
I took it in on fri and the dealer said it shows problems with a wheel sensor, the diffs and the transfer case, but the wheel sensor will probibaly fix it. they just got the sensor so im taking it in @ 10. What gets me is that its not always the same symptom. What do you think?

I did ask him about the flash up front and he said they'd check, but didnt say anything else about it.
__________________

__________________

Build thread:http://www.jeepgarage.org/f14/whoas-...ead-33075.html
Quote:
You think that's quick................heh...wait till I hit 5th! -Sir Mix-A-Lot
Reply With Quote
  #2  
Old 07-21-2011, 06:24 AM
JETLIFE's Avatar
This Ain't No Mixtape
My Jeep: 2005 5.7L WK
 
Join Date: May 2009
Location: Barrie, Ontario, Canada
Posts: 1,546
Thanks: 41
Thanked 14 Times in 12 Posts
Rep Power: 12314
JETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond repute
Re: Does this sound right to you?

Ya, could be a wheel sensor, make sure your brake lights are lighting up. I had "service electric brake system" and had no tail lights whatsoever. It was a fuse, replaced it and was good to go. The grinding and clunking doesn't sound good though. When's the last time you've serviced your diffs, transfer case, and brakes?

Sounds like you'll be getting a hefty bill!
__________________

__________________
2005 Jeep Grand Cherokee Limited 5.7L
PEL / Khaki-Black

22" x 9.5" Diablo G-Force Paint Matched Inserts / 17" x 9" Eagle 63 / Toyo Proxes 265/40/22 / BFG M/T 255/75/17 / SRT8 Rear Bumper / SRT8 Grille / SRT8 Black Leather Seats F+R / Magnaflow / 5" Tips / Mopar Lip / Mopar Running Boards / Weathertechs / Commander Shift Knob / K&N / Alpine Type R / Alpine PDX 4.100 / Debadge / Bilsteins / H&R 1.5" Down / Daystar 2" Up / Diablo Predator 93 PCM Tune - Performance TCM Tune / Morimoto Mini H1 Retrofit 6000k
Reply With Quote
  #3  
Old 07-21-2011, 09:53 AM
4.whoa's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: ks
Posts: 1,732
Thanks: 46
Thanked 14 Times in 12 Posts
Rep Power: 1141576
4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute
Garage
Re: Does this sound right to you?

transfer case ,diffs and brakes were done about 2 months ago. dealer changed (spilled actually) a qt from the front diff when doing the mounts,i couldnt see dumping the $30 qt to get the other .8 so the front was about a 60% change.

hope it's not o much $$ to fix -I need that $ for mods
__________________

Build thread:http://www.jeepgarage.org/f14/whoas-...ead-33075.html
Quote:
You think that's quick................heh...wait till I hit 5th! -Sir Mix-A-Lot
Reply With Quote
  #4  
Old 07-21-2011, 11:35 AM
4.whoa's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: ks
Posts: 1,732
Thanks: 46
Thanked 14 Times in 12 Posts
Rep Power: 1141576
4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute
Garage
Re: Does this sound right to you?

Well,.................the tech decided to take the left front wheel sensor out, when he was supposed to change the right one and ,OF COURSE.... he broke it! So now I have to wait till tomorrow to see if that was the problem.
__________________

Build thread:http://www.jeepgarage.org/f14/whoas-...ead-33075.html
Quote:
You think that's quick................heh...wait till I hit 5th! -Sir Mix-A-Lot
Reply With Quote
  #5  
Old 07-21-2011, 12:10 PM
Kreso's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2009
Location: Zagreb(Croatia),Vienna(Austria)
Posts: 173
Thanks: 2
Thanked 1 Time in 1 Post
Rep Power: 1912
Kreso is on a distinguished road
Garage
Send a message via Skype™ to Kreso
Re: Does this sound right to you?

I had the same symptoms. It was a wheel sensor (right sensor I think). Sensor replaced. All is OK ever since
__________________
Reply With Quote
  #6  
Old 07-21-2011, 12:25 PM
JETLIFE's Avatar
This Ain't No Mixtape
My Jeep: 2005 5.7L WK
 
Join Date: May 2009
Location: Barrie, Ontario, Canada
Posts: 1,546
Thanks: 41
Thanked 14 Times in 12 Posts
Rep Power: 12314
JETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond reputeJETLIFE has a reputation beyond repute
Re: Does this sound right to you?

Glad you got it figured out!
__________________
2005 Jeep Grand Cherokee Limited 5.7L
PEL / Khaki-Black

22" x 9.5" Diablo G-Force Paint Matched Inserts / 17" x 9" Eagle 63 / Toyo Proxes 265/40/22 / BFG M/T 255/75/17 / SRT8 Rear Bumper / SRT8 Grille / SRT8 Black Leather Seats F+R / Magnaflow / 5" Tips / Mopar Lip / Mopar Running Boards / Weathertechs / Commander Shift Knob / K&N / Alpine Type R / Alpine PDX 4.100 / Debadge / Bilsteins / H&R 1.5" Down / Daystar 2" Up / Diablo Predator 93 PCM Tune - Performance TCM Tune / Morimoto Mini H1 Retrofit 6000k
Reply With Quote
  #7  
Old 07-22-2011, 01:13 PM
4.whoa's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: ks
Posts: 1,732
Thanks: 46
Thanked 14 Times in 12 Posts
Rep Power: 1141576
4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute
Garage
Re: Does this sound right to you?

It's Fixed It's funny though, the original bad sensor made it do all that weird crap, but with it replaced, and the one HE broke scraping as I drove, all it did was ping and the dash lights were on. it ran totally fine. Oh well, its good to have her back on track
__________________

__________________

Build thread:http://www.jeepgarage.org/f14/whoas-...ead-33075.html
Quote:
You think that's quick................heh...wait till I hit 5th! -Sir Mix-A-Lot
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird sound??!? Msouza91 Troubleshooting/Problems 5 05-16-2011 11:02 PM
is that sound normal? eortizr Grand Cherokee - WK 9 04-05-2011 02:19 PM
How does this sound? ONEbadHEEPtruck Visual Modifications 14 02-07-2011 08:13 PM
More V8 sound Frango100 Engine Performance/Intake/Exhaust 11 01-24-2011 08:19 PM
D/S rotor sound? Relwarc Performance Modifications 11 04-09-2010 10:24 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community