Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-10-2011, 02:46 PM
wkthursty's Avatar
Member
My Jeep: 2005 3.7L WK
 
Join Date: Sep 2010
Location: High Ridge, MO
Posts: 451
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 84317
wkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond repute
Garage
Electrical issues

So over the winter i noticed my blowers would go from all blower setting powers to just only high. thought it was a nothing and just cold weather because it kept coming back. Now that it is warmer in MO i only get high. nothing else. Is this a relay or fuse problem? tried disconnecting battery and sit but didnt work.
also ive been experiencing rear brake problems. Drivers rear brake seems to drag on left turns at slow speeds. and brakes are squeaky yet i changed my pads all over before winter hit. I know someone can help me.
__________________

__________________
6cylinder ownerJG 3.7L squad midwestjeep owner
'05 3.7L ORT 4X4
Bilstein HD shock 'n struts w/ 2" Daystar Lift,
1.5" wheel spacers and Sahara wheels w/ Falken Wild Peak A/T 265/70-18,Plasti dip grille-custom shorty antennae-badges, K&N drop in filter w/air box mod,
[SIGPIC][/SIGPIC]
Reply With Quote
  #2  
Old 04-10-2011, 03:17 PM
08Hemi's Avatar
Senior Member
My Jeep: 2008 5.7L WK
 
Join Date: Jun 2009
Location: Santa Barbara, CA
Posts: 4,296
Thanks: 0
Thanked 25 Times in 30 Posts
Rep Power: 330361
08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute
Re: Electrical issues

are you referring to your a/c? I know that others have had issues with their a/c not shutting off (including me) and the dealer replaced the "recirculation gear" on my ride now I dont have that issue anymore...

and the squeaky brakes is def something on the wk's...I know others have switched out their rotors/pads to aftermarket ones to get rid of the squeaking and reduce brake dust. I have 23k miles on my jeep and will be doing my pads/rotors in 6 months or less...
__________________

__________________
Reply With Quote
  #3  
Old 04-10-2011, 10:47 PM
wkthursty's Avatar
Member
My Jeep: 2005 3.7L WK
 
Join Date: Sep 2010
Location: High Ridge, MO
Posts: 451
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 84317
wkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond repute
Garage
Re: Electrical issues

yes the blower settings on my a/c only work on high. they shut off in every setting but high. my thinking is a batch of faulty calipers went out with production run. failing calipers can cause pads to rub randomly. its getting warmer out and it is embarresing. but whatever it is what it is.
__________________
6cylinder ownerJG 3.7L squad midwestjeep owner
'05 3.7L ORT 4X4
Bilstein HD shock 'n struts w/ 2" Daystar Lift,
1.5" wheel spacers and Sahara wheels w/ Falken Wild Peak A/T 265/70-18,Plasti dip grille-custom shorty antennae-badges, K&N drop in filter w/air box mod,
[SIGPIC][/SIGPIC]
Reply With Quote
  #4  
Old 04-10-2011, 11:04 PM
tri0829's Avatar
Member
My Jeep: 2006 3.7L WK
 
Join Date: Jun 2010
Location: Buffalo, New York
Posts: 521
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 2036
tri0829 is on a distinguished road
Re: Electrical issues

my sisters 05 liberty had the same problem with her blower it would only work on the highest setting and shut off at every other one. the dealer fixed it for not too much money i think it was something with the motor or something like that.

also my brakes squeak like crazy at low speeds, asked the dealer a couple times why and they gave me some dumb explanation that cold in the mornings does it or something stupid. I figured out if you just let them squeak for awhile and try not hitting the brake they stop or if you go past like 20mph it stops too. Its so embarrassing though to drive through a parking lot with your car screaming like that
__________________
Reply With Quote
  #5  
Old 04-11-2011, 09:50 AM
wkthursty's Avatar
Member
My Jeep: 2005 3.7L WK
 
Join Date: Sep 2010
Location: High Ridge, MO
Posts: 451
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 84317
wkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond reputewkthursty has a reputation beyond repute
Garage
Re: Electrical issues

it only does it when its warm out. and constant too. ill try taking them apart this weekend and clean them.
__________________
6cylinder ownerJG 3.7L squad midwestjeep owner
'05 3.7L ORT 4X4
Bilstein HD shock 'n struts w/ 2" Daystar Lift,
1.5" wheel spacers and Sahara wheels w/ Falken Wild Peak A/T 265/70-18,Plasti dip grille-custom shorty antennae-badges, K&N drop in filter w/air box mod,
[SIGPIC][/SIGPIC]
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical and lights Arctic Fox Grand Cherokee - WK 8 09-12-2013 08:21 PM
=== Electrical problem Hac_PTR Troubleshooting/Problems Discussion 4 10-12-2010 11:26 AM
Electrical Questions 00wj Troubleshooting/Problems Discussion 0 09-22-2010 08:36 PM
electrical issues... smack82 Troubleshooting/Problems Discussion 6 01-21-2010 01:20 PM
i have an electrical issue!!!!!!!!!! BUDAKANE Troubleshooting/Problems 5 11-25-2009 08:42 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:01 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community