Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-22-2009, 11:08 AM
mikskillz's Avatar
Member
 
Join Date: Jun 2009
Location: Long Island, NY
Posts: 304
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2074
mikskillz is on a distinguished road
having some issues - like to get some thoughts

ok - i'll make this as short as i can.

went wheelin back in April - no problems. After i got home i noticed when i armed the alarm the sound was low and the rear lights did not flash. Been like that for a while - never got a chance to bring it in.

So this Saturday i was driving from NYC to Long Island in that insane snow storm and i got hung up on a huge snow bank getting on the LIE. I dropped into 4LO and managed to shimmy my way out.

Right after that my Malfunction Indicator Light went on and by the time i got home i was over heating.

My guess is i was overheating due to all the snow pack around the radiator not allowing air flow to the engine.

It has not over heated since BUT the light is still on and now the alarm barely makes any noise at all when i lock the doors and the remote start doesn't work.

I'm planning on calling my dealer today as i only have 29k on it so its all under warranty. I just wanted to see if anyone had any thoughts on this issue.

Any ideas greatly appreciated.

thanks
__________________

__________________
08WK Mojave
Reply With Quote
  #2  
Old 12-22-2009, 11:28 AM
1 GRAND's Avatar
Member
 
Join Date: Jul 2009
Location: Elkhorn City, Kentucky
Posts: 748
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2519
1 GRAND has a reputation beyond repute1 GRAND has a reputation beyond repute
Re: having some issues - like to get some thoughts

I am with you on the snow pack and overheating.

I would think you have moisture in your connections on everything else.

Unhook the battery for a few minutes to get rid of the light.




My old ZJs horn sounds like a power wheels horn on crack cocaine because I have had it in so much water and mud.
__________________

__________________


2007 Jeep Grand Cherokee Overland Hemi QD II

2006 Jeep Commander 65th Anniversary 3.7 4x4

1998 Jeep Grand Cherokee 5.9 Limited 4x4

1994 Jeep Grand Cherokee Limited V8 4x4 Lifted
Reply With Quote
  #3  
Old 12-22-2009, 11:44 AM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12218
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: having some issues - like to get some thoughts

don't know sounds like a bad battery to me
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #4  
Old 12-22-2009, 11:47 AM
Matt's Avatar
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: May 2009
Location: 34.076513,-118.429573
Posts: 9,269
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 11492
Matt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond repute
Re: having some issues - like to get some thoughts

Quote:
Originally Posted by 1 GRAND View Post
I am with you on the snow pack and overheating.
x2.

Quote:
Originally Posted by boniomario View Post
don't know sounds like a bad battery to me
x2.
__________________
Reply With Quote
  #5  
Old 12-22-2009, 11:52 AM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12218
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: having some issues - like to get some thoughts

my wk had 40k on it when it did the same thing with the horn, swapped out the battery and it was fine, you can also try grinding the battery connections (polish) so it can have a better connection in harsh conditions those tips can have poor conduction due to the rust build up or any other crap that gets in there ... try that first and if it doesn't work then ...

that's outside my pay grade
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #6  
Old 12-22-2009, 12:57 PM
Member
 
Join Date: Jun 2009
Location: Columbus,NJ
Posts: 222
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2028
saleen032 has a reputation beyond reputesaleen032 has a reputation beyond repute
Send a message via AIM to saleen032
Re: having some issues - like to get some thoughts

Take the horns out and drain the water out of them..I went through a big puddle and the same thing happened..After I got the water out, they were fine...
__________________
Reply With Quote
  #7  
Old 12-22-2009, 06:54 PM
mikskillz's Avatar
Member
 
Join Date: Jun 2009
Location: Long Island, NY
Posts: 304
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2074
mikskillz is on a distinguished road
Re: having some issues - like to get some thoughts

hmm - all makes sense - thanks
__________________
08WK Mojave
Reply With Quote
  #8  
Old 12-22-2009, 07:12 PM
mikskillz's Avatar
Member
 
Join Date: Jun 2009
Location: Long Island, NY
Posts: 304
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2074
mikskillz is on a distinguished road
Re: having some issues - like to get some thoughts

so now the remote starter is working but it is only staying running for like 15 seconds. I'll try some suggested things form here and see what happens
__________________

__________________
08WK Mojave
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anybody have any issues with their parking sensors? CougarCruiser Grand Cherokee - WK 10 12-21-2009 09:34 PM
Insane Ligthing Issues - Please Help!! SuperPug Troubleshooting/Problems Discussion 6 10-28-2009 02:54 PM
having some strange issues chefalan23 Grand Cherokee - WK 15 09-19-2009 12:19 AM
Battery/Charging issues AGAIN!! Harrison@Stage6 Trouble Shooting/Problems/Service 19 07-16-2009 12:00 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community