Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 08-18-2011, 07:53 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,786
Thanks: 831
Thanked 815 Times in 627 Posts
Rep Power: 7717362
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Help Me! Please Read! Video Included!

po339 is the crankshaft position sensor circuit intermittent and that can cause misfires. Did he unplug the sensor?
__________________

__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #26  
Old 08-18-2011, 07:55 PM
Relwarc's Avatar
Super Moderator

My Jeep: 2009 6.1L WK
 
Join Date: Jul 2009
Location: Baltimore, MD
Posts: 2,507
Thanks: 12
Thanked 23 Times in 22 Posts
Rep Power: 614245
Relwarc has a reputation beyond reputeRelwarc has a reputation beyond reputeRelwarc has a reputation beyond reputeRelwarc has a reputation beyond reputeRelwarc has a reputation beyond reputeRelwarc has a reputation beyond reputeRelwarc has a reputation beyond reputeRelwarc has a reputation beyond reputeRelwarc has a reputation beyond reputeRelwarc has a reputation beyond reputeRelwarc has a reputation beyond repute
Garage
Re: Help Me! Please Read! Video Included!

did you go out there and check the wiring like i said up top? Voltage issues will throw another type of code...
__________________

__________________
-Doug




'09 Modern Blue STR8, fully loaded, 5% tint all around 40% windshield, 4" Bwoody, 5" Tips, 6K HID Reverse,lows,fogs and switchbacks. Blacked out LED tails. PX8 rear step. Body matched ANTIVENOM hood. Lots of BT goodies, tuned by FRP. Best 1/4 ET so far: 12.65

'07 WK 4.7L Laredo. 28X package. RK 3.5" lift, 18" Sahara brushed rims, SOLD
'94 ZJ 4.0. 4.5" lift, 33" swampers, body armor, lots of mods. SOLD
Reply With Quote
The Following User Says Thank You to Relwarc For This Useful Post:
  #27  
Old 08-18-2011, 07:57 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,327
Thanks: 486
Thanked 60 Times in 58 Posts
Rep Power: 469702
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Help Me! Please Read! Video Included!

Quote:
Originally Posted by Scottina06 View Post
po339 is the crankshaft position sensor circuit intermittent and that can cause misfires. Did he unplug the sensor?
Not sure. But I do know that he unplugged a vacuum line. A picture of what he unplugged coming soon.

Quote:
Originally Posted by Relwarc View Post
did you go out there and check the wiring like i said up top? Voltage issues will throw another type of code...
I checked everything. Hoses and all.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #28  
Old 08-18-2011, 07:59 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,786
Thanks: 831
Thanked 815 Times in 627 Posts
Rep Power: 7717362
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Help Me! Please Read! Video Included!

maybe a vent hose and he blew the crankshaft sensor
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
The Following User Says Thank You to Scottina06 For This Useful Post:
  #29  
Old 08-18-2011, 08:02 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,327
Thanks: 486
Thanked 60 Times in 58 Posts
Rep Power: 469702
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Help Me! Please Read! Video Included!

He unplugged one of these hoses and the engine bogged and went kinda crazy for a second.

__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #30  
Old 08-18-2011, 08:06 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,327
Thanks: 486
Thanked 60 Times in 58 Posts
Rep Power: 469702
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Help Me! Please Read! Video Included!

Quote:
Originally Posted by Scottina06 View Post
maybe a vent hose and he blew the crankshaft sensor
But it currently not having an issue. I'm trying to figure out what caused it and worried if it will return.

If the sensor is blown, will it still operate normally?

By the way, thanks for all your help people.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #31  
Old 08-18-2011, 08:14 PM
viking757's Avatar
Member
My Jeep: 2008 6.1L SRT8
 
Join Date: May 2010
Location: NOVA
Posts: 792
Thanks: 0
Thanked 23 Times in 23 Posts
Rep Power: 19861
viking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond repute
Garage
Re: Help Me! Please Read! Video Included!

Quote:
Originally Posted by Relwarc View Post
P0339 is the crankshaft position, so look for that sensor and make sure it's secure.

P0300 is multiple cylander misfire.

Sounds to me like your mechanic can't keep his hands off wires. betchya he was tugging. Go make sure every wire on the coil packs is secure, and all your wire connectors are secure.

The intermittent issue is probably because they are loose but not completely un done.... so they might be working one minute, then after a bump, not.

x2

The crankshaft position sensor is used by the PCM to determine proper timing. So my guess is if the connection keeps going in and out the PCM will have trouble getting the timing right hence the misfires. If the sensor itself is bad it can cause those issues too. When the sensor went out on my BMW it wouldn't even start.
Attached Images
File Type: jpg ckp.jpg (89.8 KB, 14 views)
__________________
Reply With Quote
The Following User Says Thank You to viking757 For This Useful Post:
  #32  
Old 08-18-2011, 08:36 PM
TJXJWJ's Avatar
The "pre" SRT 8
My Jeep: 2004 4.7 HO WJ
 
Join Date: Jun 2010
Location: Aurora, OH
Posts: 3,435
Thanks: 195
Thanked 72 Times in 61 Posts
Rep Power: 286733
TJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond repute
Garage
Re: Help Me! Please Read! Video Included!

My wife's 3.7L Laredo was bucking like that...running like crap. I changed the plugs and it cleared it right up. Good luck figuring it out man. My XJ did that once too and I believe it was bad gas. I know a lot of people don't believe in not running the tank dry, but it can't hurt to fill it up and see if the problem goes away. There could be sediment at the bottom of the tank, or you could have gotten moisture in the tank and with it almost empty, any moisture would be now getting sucked in by the fuel pump. Water floats on gas...
__________________
Tony-04 Limited HO, DkKhaki w/tan leather int. All LED lighting, 5000k Xtreme HID projs. (deambered)&fogs w/CCFL rings, tinted tails&3rd LED brake lt, fnt glass tinted to match, shawty antenna, 6 Polk speakers, K&N FIPK, FR 70mm TB, TCM#10 snip, Flashpaq'ed on 91 tune, Bilstien HD's, Addcos, polished 20" SRT reps, Hankook Ventus Evos (255-45), Weathertech mats, EBC USR rotors, EBC Greenstuff pads, Magnaflow muffler, RB1 Nav w/iPod kit, de-badged, roof rack delete.
09 Liberty KK Rocky Mountain Edition. Added Mopar Remote Start kit, Weathertech Mats, K&N drop-in.
PAST JEEPS : 99 TJ Sport, 98 XJ Sport, 06 WK Laredo
Reply With Quote
The Following User Says Thank You to TJXJWJ For This Useful Post:
  #33  
Old 08-18-2011, 08:45 PM
555ctsv's Avatar
Member
My Jeep: 2006 6.4L WK
 
Join Date: Nov 2009
Location: Dallas, TX
Posts: 440
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2155
555ctsv is on a distinguished road
Re: Help Me! Please Read! Video Included!

I was just looking at that pic and realized it was a 3.7L, which i know nothing about... Sorry man good luck with it
__________________
06 WK Limited 4x4 SOLD :( - Hemi w/392 Stroker Kit / Inertia Motorsports Custom Cam / 2" Daystar / 265-65-18 Hankook AT's / Ballistic Jester 18" Wheels / Crossdrilled & Slotted Rotors / SRT8 Exhaust Manifolds / Magnaflow Tube Mufflers / Pypes Hi Flow Cats / K&N Intake / HID Headlights and Fogs / Diablo Trinity / Bilstein Shocks / Rear SRT Sway / Deeza Front End Links / Billet Technologies EGR Delete Kit and Oil Catch Can
Reply With Quote
The Following User Says Thank You to 555ctsv For This Useful Post:
  #34  
Old 08-18-2011, 08:45 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,327
Thanks: 486
Thanked 60 Times in 58 Posts
Rep Power: 469702
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Help Me! Please Read! Video Included!

Believe it or not, there is about 5 gallons in the tank at the time the video was shot.

When the fuel gauge is on "E", you still have 3 gallons in the tank.

My EVIC says "20 miles till empty". 12 miles per gallon. So nearly 2 gallons + 3 gallons......
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #35  
Old 08-18-2011, 09:10 PM
viking757's Avatar
Member
My Jeep: 2008 6.1L SRT8
 
Join Date: May 2010
Location: NOVA
Posts: 792
Thanks: 0
Thanked 23 Times in 23 Posts
Rep Power: 19861
viking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond repute
Garage
Re: Help Me! Please Read! Video Included!

Did you check the crankshaft position sensor? Pull it out it's only 1 bolt see if water or anything made it past the o ring. I'm betting that's the root of the problem. The sensors are cheap if I remember
__________________
Reply With Quote
The Following User Says Thank You to viking757 For This Useful Post:
  #36  
Old 08-18-2011, 09:14 PM
NikonKiem's Avatar
Member
 
Join Date: Oct 2010
Posts: 555
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 1932
NikonKiem has a spectacular aura about
Re: Help Me! Please Read! Video Included!

I had the same issue. The stealership said that I needed the PCM upgrade, and my Mechanic said it was caused by a clogged sock filter, because jeeps have a non-return fuel system. My mechanic put in a new fuel line and pump and well the problem got alot better but didnt go away completely. At least now it only does it when it gets under half of a tank.
__________________

__________________
2007 Jeep Grand Cherokee
4.7 Brilliant Silver
STOCK FOR NOW !!!!!
Reply With Quote
The Following User Says Thank You to NikonKiem For This Useful Post:
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Picked up my 2012 LaredoX - pics included sinjin Members Rides-Showoff 40 08-09-2011 05:59 PM
'11 Stone White detail done!! Pics included!! Danni Detailing 4 05-15-2011 10:14 AM
$10, $25, or $100 Gift Certificates included in any purchase over $99 DetailedImage.com Detailed Image 3 04-28-2011 10:01 PM
cargo cover included with Overlands? jdub05 Grand Cherokee - WK2 - 4 01-03-2011 07:05 PM
What is included with Laredo X? JoeSchmoe007 Grand Cherokee - WK2 - 7 10-30-2010 04:58 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community