Help.No headlight lows. 12v present but not when connecting bulb - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-26-2017, 04:45 PM
kungpaogogo's Avatar
Member
My Jeep: 2007 5.7L WK
 
Join Date: Apr 2010
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2654
kungpaogogo is on a distinguished road
Garage
Help.No headlight lows. 12v present but not when connecting bulb

All the lights are working except for my lows. The switch stalk controls all the other lights but no headlight lows. I checked the bulbs and the wires to the bulbs and do see 12 volts with the bulb disconnected, but when connecting the bulb there is no illumination and the 12v disappears off the wires leading to the bulb connector. This happens on both sides. I looked into a possible issue with the ITPM (Integrated Total Power Module) but have not seen reports for our years WK's. Mine is an 07. Thanks in advance for any input.

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-26-2017, 04:58 PM
kungpaogogo's Avatar
Member
My Jeep: 2007 5.7L WK
 
Join Date: Apr 2010
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2654
kungpaogogo is on a distinguished road
Garage
Re: Help.No headlight lows. 12v present but not when connecting bulb

Also wanted to mention that I did try to reset any possible faults. Couldn't find my Superchips Tuner but disconnected the battery long enough and putting it back did not yield any results.
Reply With Quote
  #3  
Old 01-28-2017, 06:35 AM
Member
 
Join Date: Jun 2016
Posts: 122
Thanks: 0
Thanked 24 Times in 18 Posts
Rep Power: 16294
Kryton has a reputation beyond reputeKryton has a reputation beyond reputeKryton has a reputation beyond reputeKryton has a reputation beyond reputeKryton has a reputation beyond reputeKryton has a reputation beyond reputeKryton has a reputation beyond reputeKryton has a reputation beyond reputeKryton has a reputation beyond reputeKryton has a reputation beyond reputeKryton has a reputation beyond repute
That's a weird issue. Although it won't help with the cause of the issue, for the sake of $5, it might be worth trying a relay harness like used for hid's to see if you can at least get them working & useable until you get to the bottom of it
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 02-24-2017, 07:26 PM
Member
My Jeep: 2005 3.7L WK
 
Join Date: Feb 2017
Location: Delisle SK
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 98
kiwi is on a distinguished road
Re: Help.No headlight lows. 12v present but not when connecting bulb

are the earths all clean and solid ? no corrosion on the bulb holder or the pins etc ....
__________________
You are never out of the fight.....
Reply With Quote
Reply

Tags
headlight

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:42 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.