Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-09-2011, 04:43 AM
CMSKenny's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: London, UK
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 1419
CMSKenny is on a distinguished road
Smile Help please - WK 5.7 Hemi stalling

Guys

GC owner from the UK needs your help.

I have been suffering problems for the last 3 months with my GC 5.7 Hemi which when cold, the revs wander from about 600 - 800rpm, surges and sometimes stalls when I pull up at a junction or traffic lights etc. It only happens whilst cold and whilst the car is in 'Drive' (if I knock it into Neutral it is fine). I have read much of the advice on here and subsequently changed the EGR valve - but alas the problem still remains. Can anyone please help me with a possible resolution. I am inclined towards the automatic choke but am not really sure and do not particularly want to go to be skinned at a dealer or have to change every component in the chain without some sound advice.

Can anyone please give me some advice or guidance as to what to do please?

Thanks
Chris
__________________

__________________
Reply With Quote
  #2  
Old 03-09-2011, 03:32 PM
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 1,006
Thanks: 0
Thanked 20 Times in 18 Posts
Rep Power: 154937
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: Help please - WK 5.7 Hemi stalling

Chris, there are a number of things that could be causing your problem. What year, how many miles and maintenance background on the vehicle...when last tuned (plugs, PCV valve, wires (if an 05), etc.)? I am assuming this is when in gear? If so, how about when it's out of gear? Has the transmission ever been serviced? Does the problem completely go away once completely warmed up? How about when partially (not completely to operating temp.)warmed up? Any MIL's or DTC's?

The "choke" and idle speed is controlled by an idle air motor which is incorporated into the throttle body. The PCM controls this using inputs from multiple engine sensors. Bogus indications by any one of them can cause various symptoms.
__________________

__________________
05 LX/RT & 06 WK/GCO, modded similarly, MDS "ON" Light, Vortex Gens, Debadged, DashHawk, BT Catch Can, SRT CAI W/Add Air Inlet, K&N Filter, Sonnax Trans Press Booster, SC Tuner W/Adv Trans Tuning App, DS Tuner, Cust tube headers w/3 in. catback, Bilsteins, SRT frt/rear bumpers, Eibach SRT Lwr Sprgs & Sways, FRI Sidewinder Cam Adv 2*, 6.1 valvetrain, SLP 25% UD Pulley, BBK 90mm TB, SOS Coils/.060 plug gaps. 20 in. SRT Reps.
Reply With Quote
  #3  
Old 03-10-2011, 05:06 AM
CMSKenny's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: London, UK
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 1419
CMSKenny is on a distinguished road
Re: Help please - WK 5.7 Hemi stalling

Hi Jeepgcoman

Thanks for taking the time to reply.

It is an '05 with 69k miles - regularly serviced although the last time not by a main dealer but by an independant so the exact detail of work I do not know (I would assume the minimum - oils, filters etc. & know the gearbox oils were done)

The problem only manifests when in gear (so under some sort of load) and just idles normally in neutral, perhaps with a bit of 'wandering' but notthing substantial. The problem mostly goes away once up to running temperature and is also less prevalent when ambient air-temp is warmer. We have had a cold winter and the problems have been a constant problem however the last couple of days have warmed up and I could almost say it has gone away - although I know it has not. When completely cold, it is fine - RPM approx 750-800. But is is during the process of warming up when the problem persists (which is why I thought maybe the choke coming off too soon) Once warm it appears to be fine - or at least does not stall at embarrassing moments.

I had the MIL illuminate a few times so I did the 'key-dance' and received P0406 which is what led me to change the EGR valve originally. I Have not had the MIL light since changing that and there are no fault codes showing in the DTC report.

I am no mechanic - my technical knowledge is at a fundamental level which is fine for my '58 Bugeye in the garage but this is a different kettle of fish.

Your help, assistance and guidance is very much appreciated.

Many Thanks
Chris
__________________
Reply With Quote
  #4  
Old 03-10-2011, 04:52 PM
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 1,006
Thanks: 0
Thanked 20 Times in 18 Posts
Rep Power: 154937
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: Help please - WK 5.7 Hemi stalling

Chris, a couple things to start with...when is the last time the spark plugs were changed? What kind were installed? Have the spark plug wires ever been checked/changed? When the engine is stone cold your fuel injection system is in open loop status (oxygen sensors not in operational or monitoring mixture) and the motor should run at ~800-900 RPM. As the engine warms up (after only about 30 seconds to one minute fifteen seconds) the oxygen sensors should start working (heated up now) and the fuel system should shift to closed loop status, and the fuel mixture is then being monitored by the PCM via input from the O2 and other sensors. If the oxygen sensors are becoming "lazy" and not cycling properly, which comes with age....like me), you are going to more than likely be running on the rich side. This may cause hunting, rough, erratic idle. Once warmed up, the problem probably wouldn't go away, but would be less noticeable. You would also probably notice a decrease in fuel economy with any of these items being at fault. Other items to check as a matter of routine are, the PCV Valve, oil contamination in the intake and behind the throttle body butterfly, and the MAP Sensor and IAT Sensor. Any one of these items could contribute to idle issues without setting a DTC. I would recommend starting with the easy stuff first and in order, I would:

Check/change the spark plugs (must be copper core) if not done within the last 30K.
Check the ignition wires for high resistance and/or arcing.
Check the MAP Sensor...visual with a magnifying light. New one ~$25.
Check the IAT Sensor connection. These usually don't go bad but may accumulate contamination over time.
Check the PCV Valve, intake and throttle body butterfly. New PCV Valve ~$25-35.

Once all those items have been reconciled, I'd have the O2 sensors checked, only if they'll do it for free, or if bad give credit toward replacement. Personally, with your mileage, I'd just replace them. I just did mine at 60K and am trying to resolve issues related to the change. On mine the 1/1 sensor was getting lazy (not cycling properly) and the 2/1 sensor was not cycling at all. I am now having a problem (DTC's P1128/P1129) with the new Bosch sensors. There is quite a history, on most DCX forums, of replacement O2 sensor problems on DCX vehicles. I have now ordered NTK (made by NGK) sensors. They are the same folks that made the original ones that came out of it. The problem appears to be that the Bosch ones do not heat up fast enough (takes up to 2 minutes) causing the fuel system to not switch to closed loop quick enough, thereby triggering the codes.

Let us know how things go and what you find out.
__________________
05 LX/RT & 06 WK/GCO, modded similarly, MDS "ON" Light, Vortex Gens, Debadged, DashHawk, BT Catch Can, SRT CAI W/Add Air Inlet, K&N Filter, Sonnax Trans Press Booster, SC Tuner W/Adv Trans Tuning App, DS Tuner, Cust tube headers w/3 in. catback, Bilsteins, SRT frt/rear bumpers, Eibach SRT Lwr Sprgs & Sways, FRI Sidewinder Cam Adv 2*, 6.1 valvetrain, SLP 25% UD Pulley, BBK 90mm TB, SOS Coils/.060 plug gaps. 20 in. SRT Reps.
Reply With Quote
  #5  
Old 03-11-2011, 03:47 AM
CMSKenny's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: London, UK
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 1419
CMSKenny is on a distinguished road
Re: Help please - WK 5.7 Hemi stalling

Thanks Jeepgcoman

I will give these all a go and let you all know the results. You are right about the fuel economy too - I am getting on average about 12 - 14 mpg and I drive it like a Granny.

Your time in trying to help me out is very much appreciated.

Chris
__________________
Reply With Quote
  #6  
Old 03-11-2011, 08:56 AM
brent's Avatar
Member
 
Join Date: Sep 2009
Posts: 182
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2017
brent is on a distinguished road
Re: Help please - WK 5.7 Hemi stalling

There was a software update that resolved this in my 2007. I'm not sure if there was an official TSB on it but I posted about it somewhere on this forum.
__________________
2007 Jeep Grand Cherokee Overland. Airaid CAI. Magnaflow catback exhaust system. Billet style antenna. Michelin Latitude Tour tires.
Reply With Quote
  #7  
Old 03-11-2011, 12:22 PM
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 1,006
Thanks: 0
Thanked 20 Times in 18 Posts
Rep Power: 154937
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: Help please - WK 5.7 Hemi stalling

Good call, Brent. I took a quick look, but didn't see one for his 05. CMSKenny, you may want to check all the TSB's that may be applicable to your specific vehicle. http://www.wkjeeps.com/wk_tsb.htm Even if you do find one, still check all the other stuff that may need attention.
__________________
05 LX/RT & 06 WK/GCO, modded similarly, MDS "ON" Light, Vortex Gens, Debadged, DashHawk, BT Catch Can, SRT CAI W/Add Air Inlet, K&N Filter, Sonnax Trans Press Booster, SC Tuner W/Adv Trans Tuning App, DS Tuner, Cust tube headers w/3 in. catback, Bilsteins, SRT frt/rear bumpers, Eibach SRT Lwr Sprgs & Sways, FRI Sidewinder Cam Adv 2*, 6.1 valvetrain, SLP 25% UD Pulley, BBK 90mm TB, SOS Coils/.060 plug gaps. 20 in. SRT Reps.
Reply With Quote
  #8  
Old 03-15-2011, 07:01 AM
CMSKenny's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: London, UK
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 1419
CMSKenny is on a distinguished road
Re: Help please - WK 5.7 Hemi stalling

Thanks again Guys - I checked the TSB's but there was nothing I could pin my hat on with regard to this particular problem.

I am going to go through the list of jeepgcoman in cronological order and will let you know the results.

In trying to find some OEM spark plugs (Champion 570) there is nothing that I can find available except direct from a dealer at nearly $5 a go. I can get them from USA at $1.20 but then it will cost another arm and a leg to get them shipped!

It appears in reading on here that GC's (and particularly Hemi's) are sensitive to plug types - can you confirm or can you make any other recommendations as to brand etc. NGK?

Thanks
Chris
__________________
2005 WK 5700cc :thumbsup:
1958 948cc "Frogeye" Sprite :cool:
Reply With Quote
  #9  
Old 03-15-2011, 07:04 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2010
Location: Kingston, Ontario
Posts: 801
Thanks: 0
Thanked 15 Times in 14 Posts
Rep Power: 276899
dr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond repute
Re: Help please - WK 5.7 Hemi stalling

I would recommend sticking with the stock plugs. A lot of people have had problems when running other types, and I have not heard of anyone finding plugs that perform better than stock.
__________________
Reply With Quote
  #10  
Old 03-15-2011, 10:50 AM
xj31's Avatar
Member
 
Join Date: Dec 2010
Posts: 118
Thanks: 0
Thanked 5 Times in 4 Posts
Rep Power: 1507
xj31 has a reputation beyond reputexj31 has a reputation beyond repute
Re: Help please - WK 5.7 Hemi stalling

You might want to check the transmission fluid.If its slightly low,the torque converter clutch stays applied when you come to a stop.Then it shudders and or stalls.Its usually worse when cold,so from your description,thats what it sounds like.
__________________
Reply With Quote
  #11  
Old 03-15-2011, 07:49 PM
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 1,006
Thanks: 0
Thanked 20 Times in 18 Posts
Rep Power: 154937
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: Help please - WK 5.7 Hemi stalling

Chris, I use NGK LZTR4A-11, Stock No. 5306 spark plugs. They're copper core and work great. Again, since yours is an 05, be sure to check the plug wires. Also do not use anti-seize on the plugs, as they come with it from the factory. Be sure to properly torque them and use a little dielectric compound on the plug boots.

Xj31 has a good idea also. Sometimes if the fluid level is not at full when hot, the trans. will do wierd things.

On the EGR DTC....the EGR Valve should not be working when the engine is warming up, but it probably did need changing since you got the code. You're at about the right mileage for many of them to fail, so that was probably not a waste of time or money.
__________________
05 LX/RT & 06 WK/GCO, modded similarly, MDS "ON" Light, Vortex Gens, Debadged, DashHawk, BT Catch Can, SRT CAI W/Add Air Inlet, K&N Filter, Sonnax Trans Press Booster, SC Tuner W/Adv Trans Tuning App, DS Tuner, Cust tube headers w/3 in. catback, Bilsteins, SRT frt/rear bumpers, Eibach SRT Lwr Sprgs & Sways, FRI Sidewinder Cam Adv 2*, 6.1 valvetrain, SLP 25% UD Pulley, BBK 90mm TB, SOS Coils/.060 plug gaps. 20 in. SRT Reps.
Reply With Quote
  #12  
Old 03-21-2011, 04:21 AM
CMSKenny's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: London, UK
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 1419
CMSKenny is on a distinguished road
Re: Help please - WK 5.7 Hemi stalling

To give you an update...

I did some further digging around into xj31's suggestion and found a lot of other issues relating to this so this weekend checked the transmission oil and - even when hot - it did not even register on the dipstick!!

So put in 2+ pints of ATF+4 which has bought the level up to just over the 'low' mark and - behold!! First run this morning and no problems. Interestingly (although maybe not related) the 'Service 4WD system' warning has not come on in 6 or 7 starts too!!

Am still going to do the plugs as these have not been done for 40k miles so are probably shot and may well look at the PCV valve too, just for good measure.

I will monitor over the next couple of weeks and update things - always good to have a solution to another problem.

...and will be having a word with my service engineer

Thanks for all your help guys
__________________

__________________
2005 WK 5700cc :thumbsup:
1958 948cc "Frogeye" Sprite :cool:
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
low idle and stalling issue SvenskaJeepGuy Troubleshooting/Problems Discussion 11 05-26-2014 05:44 PM
Strange Stalling Problem 05WKinPA Troubleshooting/Problems Discussion 5 03-09-2013 12:25 PM
Stalling on Cold Start alretired Trouble Shooting/Problems/Service 2 02-04-2011 10:08 AM
Idle/Stalling problem citizinsoldier11B Engine Performance/Intake/Exhaust 8 04-22-2010 10:05 AM
Brake Stalling Robert Palmer At The Track 10 06-27-2009 09:24 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community