Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-17-2011, 10:47 AM
lewi3069's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Apr 2010
Location: Jones, OK
Posts: 538
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1999
lewi3069 is on a distinguished road
Exclamation Help, battery bad?

So last night I got my hardwired kit for my escort 9500 in. So I figure I would install it. So here I am installing everything and get everything back together. Wired it into the acc power plug on the drivers side. Get everything back together and about to go return some movies and I get click click click... No problem but push my jeep out and put the other jeep and jump it starts like a champ. So I drive it in to town no problems voltage seems a little low but holding around 13.7. So this morning about to leave for work and go to start the jeep and same click so push back the jeep and jump drive to work voltage hold around 14.1 the way to work. when I get here i turn it off and back to on to read the voltage sitting at 12.4 turn it off. Then I noticed the back windows are about half way down roll them back up voltage is about 11.7 now didn't think the voltage should stay lower after the load of the windows in off of it. So my thought is with the past few days of the Oklahoma heat the battery is starting to show its age. (looks like stock battery, didn't buy new so cant be sure) I know most are going to think I don't know how to wire the radar correctly, but this is my third one and I'm pretty confident when it comes to hooking things up considering I have hooked up everything in my jeeps which includes 3 viper security/remote start, cb, winch, sub, inverter, ect. I check for shorts and that when I close things up in fear of having a fire one day from wiring something up wrong.

Here is what is hooked up:
Radar (hardwired to acc outlet, so turns off with the car)
CB (usually on 24/7, but turned it off last night)
Remote start (always on, installed for 4-5mo now, no problems)
Sub and inverter are disconnected and fuse for the main wire is pulled.
Winch is disconnected

With all of this said I'm pretty sure once I jump it the alt is carrying the car along and the battery has a bad cell which would be draining it.
__________________
[SIGPIC][/SIGPIC]
2007 Jeep Grand Cherokee 4.7L, 4x4

Done: Tow Hooks, Amsoil Severe Gear 75w-140, Amsoil Air Filter, Amsoil 0w-20, Amsoil T-Case, NGK V-Power, Skid Plate Front and Front Engine, Front Hitch, Hypergrounding, Shorty Antenna, 2" Old Man Emu Lift, Nitto Terra Graplers, Rola Rack
Need to be Done:Magnaflow Muffler, Fuel & Tcase Skid Plate,
The Electronics:Escort 9500ix, 400 Watt Inverter, Rockford Fosgate P2, Viper 5901, CB Radio, DB Drive 6.5, SuperChips, Rigid Dually Flood (Front), Rigid Dually Diffused (Backup)
Future Electronics: Mopar/Kicker 6x9 and dash, Scanner
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Crestwood1001 Grand Cherokee - WK 0 05-22-2011 08:13 AM
Battery JeepCoop Grand Cherokee - WK 8 04-07-2011 08:17 PM
Battery jeepnjeep Grand Cherokee - WK 3 10-04-2010 01:13 PM
Bad Battery? kyle.jg Troubleshooting/Problems Discussion 5 08-19-2010 05:42 PM
Best WK battery? AcidCold Visual Modifications 37 06-25-2009 06:24 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:26 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community