Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 03-08-2011, 05:35 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Dec 2010
Location: Wisconsin
Posts: 123
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1425
ech0sh4y is on a distinguished road
Re: HIDs Cause Poor Radio output??!

It has static with either ground, factory or my own. That's what makes me think it's not the ground.
__________________

__________________
~ Brian
'08 Jeep WK - Overland - Ya... it's got a hemi!
'96 Bronco 5.8 - Work in progress.
Reply With Quote
  #14  
Old 03-08-2011, 06:09 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,319
Thanks: 486
Thanked 57 Times in 55 Posts
Rep Power: 469683
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: HIDs Cause Poor Radio output??!

All the grounds travel throughout the WK right?
__________________

__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #15  
Old 03-08-2011, 11:10 PM
BlackedOutWK's Avatar
Senior Member
My Jeep: 2007 3.7L WK
 
Join Date: Mar 2010
Location: Pittsburgh, PA
Posts: 1,544
Thanks: 0
Thanked 27 Times in 27 Posts
Rep Power: 393978
BlackedOutWK has a reputation beyond reputeBlackedOutWK has a reputation beyond reputeBlackedOutWK has a reputation beyond reputeBlackedOutWK has a reputation beyond reputeBlackedOutWK has a reputation beyond reputeBlackedOutWK has a reputation beyond reputeBlackedOutWK has a reputation beyond reputeBlackedOutWK has a reputation beyond reputeBlackedOutWK has a reputation beyond reputeBlackedOutWK has a reputation beyond reputeBlackedOutWK has a reputation beyond repute
Re: HIDs Cause Poor Radio output??!

my buddy had the same problem with his silverado 2500hd...i notice it on mine from time to time, and ive heard other people say they have had the same problem. not sure why it does it though. just thought id let you know so you're aware you're not the only one.
__________________
Rob | 2007 Grand Cherokee Laredo ORT
OME HD Lift | RRO UCA's | JKS Front Discos | Daystar Spacers Stacked in Rear | Rusty's Extended Rear Sway Links | Rusty's Adjustable Rear Tackbar | 32" BFG MTs | Black 17" Moab Wheels | 1.25" Spacers | 30% Front Window Tint | SRT Pedals | JR's Custom Shorty Billet Antenna/Locks/Bezels | Front Recovery Hooks | Rear Recovery Shackle | Painted Headlights | 6k HID Lows | 3k HID Fogs | Painted Tails | Tinted 3rd Brake Light | 7w LED Cree Reverse Bulbs | LED Interior & License Plate Lights | Power Wire | Fastman TB | K&N CAI | Hypertech Max Power Programmer | Solid Rear Diff Cover | R1 Concepts Drilled/Slotted Rotors | 4xG Front Guard | Aspen Creek Boulder Grille
Reply With Quote
  #16  
Old 03-09-2011, 10:01 AM
Member
My Jeep: 2009 3.7L WK
 
Join Date: Oct 2010
Location: Bellevue, Ne
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1440
SportRanger06 is just really nice
Re: HIDs Cause Poor Radio output??!

Where did you mount your ballast? The radio antenna wire should be shielded, but the shield may not have a good ground on the antenna end or radio end. If it does not the frequencies that the ballast creates to sustain the arc in the bulb will bleed onto the antenna line and cause a 500-600 hz static. Try moving the ballast as far away from the antenna and passenger finder as possible and see if this attenuates the static.
__________________
[SIGPIC][/SIGPIC]"Believe in me, 'Cause I was made for chasing dreams" - Staind : Believe

2009 WK Laredo 4X4 w/Sun & Sound Group :D | 3.7 V6 | OEM Fog Light Install | 35% Front Tint | Mopar Kicker Upgrade | OEM HID Conversion w/4300K Lows | Custom Painted Wheels | OEM Style LED Tail Lights :cool:

On The Way: Katzkin Custom Leather | Heated Seats | Mopar Kicker Sub Upgrade | RER Navi Radio | Debadge | Rear Seat DVD | Chrome Door Trim | Overland Painted Air Dam & Mirrors | "Beefy" Tires
Reply With Quote
  #17  
Old 03-09-2011, 04:19 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Dec 2010
Location: Wisconsin
Posts: 123
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1425
ech0sh4y is on a distinguished road
Re: HIDs Cause Poor Radio output??!

I have the ballast mounted in front of the air box on the fender (i have the afe intake so there is room). I woudn't know where else to mount it securly? The passenger one I mounted on top of the PDC (fuse box) cover. I wonder if this would still happen if i were to upgrade my head unit, I've been playing on doing so, but I might have to think about it twice is my radio is crap. I don't listen to MP3 players and very rarely cd's. Hmmmm
__________________
~ Brian
'08 Jeep WK - Overland - Ya... it's got a hemi!
'96 Bronco 5.8 - Work in progress.
Reply With Quote
  #18  
Old 03-09-2011, 05:47 PM
Member
My Jeep: 2009 3.7L WK
 
Join Date: Oct 2010
Location: Bellevue, Ne
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1440
SportRanger06 is just really nice
Re: HIDs Cause Poor Radio output??!

Chances are that it would still happen with an aftermarket head unit, only the static would sound cleaner and more powerful! My guess is that the ballast on the fuse box is close enough to the antenna that the signal is picked up and the radio demodulator can't filter it out. If I remember correctly the fuse box (in my '09) is about a 9" away from the antenna mast. You said that it's worse with certain stations? If that's the case, I would try moving the ballast to the front bumper. There is a decent spot below the grille on the back of the actual steel piece that supports the bumper. You have to remove the grille to get to it though.
__________________
[SIGPIC][/SIGPIC]"Believe in me, 'Cause I was made for chasing dreams" - Staind : Believe

2009 WK Laredo 4X4 w/Sun & Sound Group :D | 3.7 V6 | OEM Fog Light Install | 35% Front Tint | Mopar Kicker Upgrade | OEM HID Conversion w/4300K Lows | Custom Painted Wheels | OEM Style LED Tail Lights :cool:

On The Way: Katzkin Custom Leather | Heated Seats | Mopar Kicker Sub Upgrade | RER Navi Radio | Debadge | Rear Seat DVD | Chrome Door Trim | Overland Painted Air Dam & Mirrors | "Beefy" Tires
Reply With Quote
  #19  
Old 03-09-2011, 05:47 PM
White Chocolate's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2009
Location: Saskatoon, Saskatchewan, Canada
Posts: 8,336
Thanks: 8
Thanked 8 Times in 8 Posts
Rep Power: 0
White Chocolate is an unknown quantity at this point
Re: HIDs Cause Poor Radio output??!

You should keep your connections all together, and move your ballasts FAR away from where you have them now.....see if the static goes away
__________________
Reply With Quote
  #20  
Old 03-09-2011, 05:50 PM
White Chocolate's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2009
Location: Saskatoon, Saskatchewan, Canada
Posts: 8,336
Thanks: 8
Thanked 8 Times in 8 Posts
Rep Power: 0
White Chocolate is an unknown quantity at this point
Re: HIDs Cause Poor Radio output??!

Try installing your ballasts near the front bumper, maybe it will help.

Here is where I installed mine, its an easy access, and you DONT need to remove the bumper.



__________________
Reply With Quote
  #21  
Old 03-09-2011, 07:57 PM
Member
My Jeep: 2009 3.7L WK
 
Join Date: Oct 2010
Location: Bellevue, Ne
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1440
SportRanger06 is just really nice
Wink Re: HIDs Cause Poor Radio output??!

Quote:
Originally Posted by White Chocolate View Post
Try installing your ballasts near the front bumper, maybe it will help.

Here is where I installed mine, its an easy access, and you DONT need to remove the bumper.



Good installation location!
__________________
[SIGPIC][/SIGPIC]"Believe in me, 'Cause I was made for chasing dreams" - Staind : Believe

2009 WK Laredo 4X4 w/Sun & Sound Group :D | 3.7 V6 | OEM Fog Light Install | 35% Front Tint | Mopar Kicker Upgrade | OEM HID Conversion w/4300K Lows | Custom Painted Wheels | OEM Style LED Tail Lights :cool:

On The Way: Katzkin Custom Leather | Heated Seats | Mopar Kicker Sub Upgrade | RER Navi Radio | Debadge | Rear Seat DVD | Chrome Door Trim | Overland Painted Air Dam & Mirrors | "Beefy" Tires
Reply With Quote
  #22  
Old 03-09-2011, 08:14 PM
CPT2010's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: New Orleans
Posts: 1,198
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2771
CPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond repute
Re: HIDs Cause Poor Radio output??!

Check your ground on your radio... Does it do it when playing a CD?
__________________
Reply With Quote
  #23  
Old 03-10-2011, 11:34 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Dec 2010
Location: Wisconsin
Posts: 123
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1425
ech0sh4y is on a distinguished road
Re: HIDs Cause Poor Radio output??!

Ok thanks for the ideas guys, I'll try to move the ballasts to the bumper location. Any issues with water/snow getting at that area?

Also it does not affect the CD sound, just the radio. What would I be looking for with the anntena ground?

I meant the PDC fuse box on the driver side, my antenna is on the passenger side. Maybe I should snap a few pictures!
__________________
~ Brian
'08 Jeep WK - Overland - Ya... it's got a hemi!
'96 Bronco 5.8 - Work in progress.
Reply With Quote
  #24  
Old 03-10-2011, 11:41 AM
CPT2010's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: New Orleans
Posts: 1,198
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2771
CPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond repute
Re: HIDs Cause Poor Radio output??!

either on the back of the radio... and/or trace back the ground on the attena to the jeep.. make sure its tight and maybe scrub it with a wire brush
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to increase power output on a stock 3.7 V6 Nick.Nevada Grand Cherokee - WK 58 06-29-2014 10:51 PM
Location for Transmission Output/input Sensors t2arrington Troubleshooting/Problems Discussion 4 02-12-2011 05:40 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community