Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-01-2010, 09:28 AM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Apr 2010
Location: Baltimore, MD
Posts: 429
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 1986
swing4terps is on a distinguished road
Instrument Cluster Problems

About 5 or so times in the past couple weeks, I will be driving and ALL of the lights on my instrument cluster will light up for a few seconds then turn back off. No real commonalities between occurences that I've seen. Anyone have any guesses? Ignition switch maybe?
__________________

__________________
Reply With Quote
  #2  
Old 12-01-2010, 11:02 PM
mjl2610's Avatar
Senior Member
My Jeep: 2006 4.7L WK
 
Join Date: May 2009
Location: Chicago, IL
Posts: 1,524
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 3477
mjl2610 has a reputation beyond reputemjl2610 has a reputation beyond reputemjl2610 has a reputation beyond reputemjl2610 has a reputation beyond repute
Re: Instrument Cluster Problems

I had a similar issue where it would appear as if i took the key and turned the Jeep off then on repeatedly. The Jeep still drove fine and acted normal fir the exception of the cluster going crazy. After explaining to the forum what It might be looking for an answer before i took it to the dealer, it was suggested an ignition switch. Turned out the codes that were pulled pointed to a faulty ignition switch. It was replaced under warranty so i don't know the cost of something like that. Hope this helps.
__________________

__________________
-Mike

Mike, 26, have a 2006 Dark Khaki WK Limited 4.7L; SICK stock 17" 5 Spoke Ronins :/ , Walker QuietFlow muffler, 7500K headlamp and fog Halogens, LED license plate lighting, Interior LED lighting, Champion Platinum Power spark plugs.

Reply With Quote
  #3  
Old 12-02-2010, 09:17 AM
Member
My Jeep: 2005 4.7L WK
 
Join Date: May 2010
Location: Richmond, VA
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1566
Eaglelope is on a distinguished road
Re: Instrument Cluster Problems

I had the same issue on my 05 4.7L WK. There are a couple of large multi-pin connector blocks under the dash on the drivers side inside the cabin. I disconnected the battery then took those apart and cleaned them with a good electrical contact cleaning spray.
That fixed the issue for me.
__________________
Reply With Quote
  #4  
Old 12-03-2010, 05:11 PM
Member
 
Join Date: Oct 2009
Posts: 86
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 9315
harricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond repute
Re: Instrument Cluster Problems

You have alot of Keys? have you recently powerwashed the motor. I had the same problem....I went down to 1-3keys and now power wash the motor (low pressure) with a bag over the ignition unit and the problem has gone away...
__________________
Reply With Quote
  #5  
Old 12-03-2010, 06:16 PM
chicago_jeepster_'s Avatar
Member
 
Join Date: Dec 2009
Location: Chicago
Posts: 85
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1771
chicago_jeepster_ is on a distinguished road
Re: Instrument Cluster Problems

I had the same problem, but it would only do it when it was really cold out.
__________________
Reply With Quote
  #6  
Old 12-22-2010, 04:35 PM
jcostri09's Avatar
Member
 
Join Date: Oct 2009
Location: Rhode Island
Posts: 328
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2117
jcostri09 has a reputation beyond reputejcostri09 has a reputation beyond repute
Re: Instrument Cluster Problems

has anyone changed out the ignition, not under warranty? Is it expensive, or difficult to do on your own?
__________________
2006 Jeep SRT8
Reply With Quote
  #7  
Old 12-23-2010, 11:59 AM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Apr 2010
Location: Baltimore, MD
Posts: 429
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 1986
swing4terps is on a distinguished road
Re: Instrument Cluster Problems

I think a new ignition switch is around $50 or so. Probably something you can do yourself. This may help.

Help replacing Ignition Switch
__________________
Reply With Quote
  #8  
Old 12-24-2010, 08:53 AM
GratefulDeadWK's Avatar
Member
 
Join Date: Nov 2010
Posts: 274
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1607
GratefulDeadWK is on a distinguished road
Re: Instrument Cluster Problems

Quote:
Originally Posted by swing4terps View Post
I think a new ignition switch is around $50 or so. Probably something you can do yourself. This may help.

Help replacing Ignition Switch
I actually saw one for thirty, but do you have to re learn the key or anything when you put a new switch in?

I as well have the same problem and it happens at the weirdest times, sometimes not for months and then it will come back to haunt me. My switch seems loose where you stick the key in, has a lot of play so I'm thinking that is prob the case. I do want to try what a guy said a few posts up by cleaning out the wires under the dash, might help as well.

Also one more thing and this is just a theory. I have a broken off ground strap under my car, its the one that goes from the exhaust to the body. I've never got around to fixing it but could be part of the problem.
__________________

Reply With Quote
  #9  
Old 12-24-2010, 02:27 PM
gudman's Avatar
New Member
My Jeep: 2005 4.7L WK
 
Join Date: Dec 2009
Location: Russia
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
gudman is on a distinguished road
Send a message via Skype™ to gudman
Re: Instrument Cluster Problems

Hello all friends!
Sorry for my English, a translator Google.
We are witnessing in Russia is often the same problem!
This problem occurs most often in damp cold weather.
Found the solution! Need to change the contact group, the ignition switch.
Problem was solved TriA service in Moscow. I thank them for it ...
I would be glad if it is useful to you!
Discussion topic: http://jeepgarage.ru/forum/topic.php?forum=63&topic=16
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument cluster cover in leather cain45 Grand Cherokee - WK 16 04-13-2013 02:36 AM
Instrument panel noise Joejeep Troubleshooting/Problems Discussion 1 11-21-2010 01:10 PM
Hissing sound behind the instrument panel magradze Troubleshooting/Problems 2 03-30-2010 04:47 PM
instrument cluster SvenskaJeepGuy Grand Cherokee - WK 18 12-31-2009 11:36 AM
srt8 cluster gauge copley2596 Grand Cherokee - WK 15 08-18-2009 04:51 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:12 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community