Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-14-2011, 11:49 AM
New Member
 
Join Date: Feb 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jimbybee is on a distinguished road
Lag problem at 45

Have an '05 with the 5.7 Hemi V-8. At 45 the engine seems to cut out. If I speed up to 50, the lag goes away. If I slow down to 40, it goes away. Somewhere between the two speeds, around 45, it will start to lag again. The dealer put it on the computer and could identify no problems. Replacing the plugs and wiring harness hasn't changed it either. Any thought from the group would be appreciated.
__________________

__________________
Reply With Quote
  #2  
Old 03-14-2011, 12:02 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,425
Thanks: 504
Thanked 87 Times in 81 Posts
Rep Power: 469949
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Lag problem at 45

There is a TSB for a software update. It solved my bucking/surging/lagging.
__________________

__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #3  
Old 03-14-2011, 12:07 PM
DAVY27's Avatar
Premium Member
Photobucket
 
Join Date: Jun 2009
Location: City that Never Sleeps
Posts: 9,263
Thanks: 470
Thanked 199 Times in 177 Posts
Rep Power: 1660262
DAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond repute
Garage
Send a message via AIM to DAVY27
Re: Lag problem at 45

maybe the MDS is kicking in?
__________________

2009 Jeep Grand Cherokee SRT Design
SRT Exterior,Magnaflow 14590 w/ SRT resonators,V2 CF Medic Hood,Injen Powerflow Intake,Flying Ryan Ported TB,Custom Painted Halo Headlights,HID lows/fogs,SRT Springs,Stillens,Gloss Black SRT Reps,Mopar Spoiler, Custom Painted Moldings with Snakeskin green GC letterings, Mopar Stripe,Tinted LED tails/rear fogs, TLS Harness,Switchbacks, Stage6 5" Tips,Custom Door Handle Leds,5% Tint,Altec Plate,HID Reverse,Mopar Front Emblem/ Rear Logo,Powerwire,Interior Leds,RGB LED cupholders,Mygig,Weathertech Mats,LXHarness Leds,Rear Cargo Light Mod,Lockpic V4,GlossBlack Vinyl Interior Pieces
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Might have a problem here scrivenerc Engine Performance/Intake/Exhaust 19 02-19-2011 06:49 PM
has anyone else had this problem? 99limited Audio, Video, Navigation & Electronic Modifications 14 04-01-2010 05:17 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:09 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.