Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-24-2010, 10:48 PM
NHWK05's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Hooksett, NH
Posts: 5,108
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 94543
NHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond repute
More stalling/funky idle issues.

So in the past i have discussed how my jeep will stall (4.7 v8) much like the HEMI jeeps. It did not matter if the jeep was hot or cold, out side temp, or if it was a light or hard stop. The RPMs would drop real low to the point of a stall out.

Well a very well known master technician at a dealership told me to put just a little extra ATF+4 in the trans as the problem is supposedly caused by not enough fluid/pressure. so i tried it and Bam its been fine ever since.

Recently however i have noticed that upon immediate start and cold or hot start if i dont let the jeep run for at least 30 seconds or so and then give it gas while shifting in to drive or reverse it will start to bog down and almost stall out.

Ive also noticed while driving that it did not come to the point of stalling at a stop but the RPMS do drop very low some times when stopping and the jeep almost stalls out.

What the hell would cause the RPMs to drop so low upon a stop and what would make it want to bog down when giving it throttle right after a startup?
__________________

__________________
-Kyle '05 Dark Khaki (PJT) WK Limited 4.7L V8, '08 Overland Front End, Custom Exhaust, 245/70/17 GY Silent Armors, Bilstein 4600s, K40 Calibre DL Radar Detector/Laser Diffuser, CB.
Wife's Jeep: '06 Jeep Liberty KJ 4x4 2.8L CRD Diesel
Reply With Quote
  #2  
Old 02-25-2010, 08:44 AM
brent's Avatar
Member
 
Join Date: Sep 2009
Posts: 182
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1950
brent is on a distinguished road
Re: More stalling/funky idle issues.

I noticed when my fluid levels were low it seemed to jump, but right now they're spot on. There's another thread with the same issues I started with the same problems. Our engines are different sizes but I think mostly the same theories and practices apply.
__________________

__________________
2007 Jeep Grand Cherokee Overland. Airaid CAI. Magnaflow catback exhaust system. Billet style antenna. Michelin Latitude Tour tires.
Reply With Quote
  #3  
Old 02-25-2010, 05:58 PM
Member
 
Join Date: Jan 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1639
HemiPower is on a distinguished road
Re: More stalling/funky idle issues.

Do you have the latest engine and transmission software, I have an 2005 Hemi and just last week it was updated with the latest flash now my idle is a lot better and so is all round drive ability.
__________________
Reply With Quote
  #4  
Old 02-25-2010, 07:35 PM
NHWK05's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Hooksett, NH
Posts: 5,108
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 94543
NHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond repute
Re: More stalling/funky idle issues.

I had it "reflashed" a few months ago. I can go and try it again.
__________________
-Kyle '05 Dark Khaki (PJT) WK Limited 4.7L V8, '08 Overland Front End, Custom Exhaust, 245/70/17 GY Silent Armors, Bilstein 4600s, K40 Calibre DL Radar Detector/Laser Diffuser, CB.
Wife's Jeep: '06 Jeep Liberty KJ 4x4 2.8L CRD Diesel
Reply With Quote
  #5  
Old 02-25-2010, 07:47 PM
jcostri09's Avatar
Member
 
Join Date: Oct 2009
Location: Rhode Island
Posts: 328
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2106
jcostri09 has a reputation beyond reputejcostri09 has a reputation beyond repute
Re: More stalling/funky idle issues.

A friend of mine has a 4.7 WK and had a similar problem. Turned out his air filter (stock) was clogged up. He replaced the filter and was good to go.
__________________
2006 Jeep SRT8
Reply With Quote
  #6  
Old 02-25-2010, 08:13 PM
Member
 
Join Date: Jan 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1639
HemiPower is on a distinguished road
Re: More stalling/funky idle issues.

Another thing I had a rough idle at startup, and it came up with a P0300 random misfire. Ended up replacing all 16 plugs with oem champions and unplugged the battery to reset and that solved the code and weird idle at start up. The plugs had about 40,000 on them.
__________________
Reply With Quote
  #7  
Old 02-25-2010, 08:50 PM
NHWK05's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Hooksett, NH
Posts: 5,108
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 94543
NHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond repute
Re: More stalling/funky idle issues.

Thanks guys.

I have a K&N drop in filter for now and i changed my spark plugs over the summer.
__________________
-Kyle '05 Dark Khaki (PJT) WK Limited 4.7L V8, '08 Overland Front End, Custom Exhaust, 245/70/17 GY Silent Armors, Bilstein 4600s, K40 Calibre DL Radar Detector/Laser Diffuser, CB.
Wife's Jeep: '06 Jeep Liberty KJ 4x4 2.8L CRD Diesel
Reply With Quote
  #8  
Old 02-25-2010, 09:47 PM
Metal Gear
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Houston, TX
Posts: 1,849
Thanks: 8
Thanked 7 Times in 7 Posts
Rep Power: 20919
AcidCold has a reputation beyond reputeAcidCold has a reputation beyond reputeAcidCold has a reputation beyond reputeAcidCold has a reputation beyond reputeAcidCold has a reputation beyond reputeAcidCold has a reputation beyond reputeAcidCold has a reputation beyond reputeAcidCold has a reputation beyond reputeAcidCold has a reputation beyond reputeAcidCold has a reputation beyond reputeAcidCold has a reputation beyond repute
Re: More stalling/funky idle issues.

Maybe your intake swallowed a Honda?
__________________
Reply With Quote
  #9  
Old 02-26-2010, 05:49 PM
Member
 
Join Date: Jul 2009
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1875
Nand12 is on a distinguished road
Re: More stalling/funky idle issues.

Might wanna check/clean IAC assembly because this sounds exactly like a common problem that Ford Explorers had and what was happening was that the IAC plunger was gummed up with carbon and sticking open. When you shift into drive, my guess is that the IAC plunger is not closing which means that you're getting more air and not enough gas (because the PCM assumes that the IAC plunger has closed and cuts the fuel accordingly). This could also explain why your engine dies as you come to a stop...the IAC assembly is supposed to gently open as you coast to a stop to start pumping air (you're no longer generating enough vacuum because your foot is not on the gas) and keep your engine running at idle.
__________________
Reply With Quote
  #10  
Old 02-26-2010, 06:34 PM
maxst2's Avatar
Senior Member
My Jeep: 2006 4.7L WK
 
Join Date: Feb 2010
Location: Oakland,IA
Posts: 1,475
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 198512
maxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond repute
Send a message via AIM to maxst2 Send a message via MSN to maxst2 Send a message via Yahoo to maxst2 Send a message via Skype™ to maxst2
Re: More stalling/funky idle issues.

What type of plugs did you put in?
__________________
Reply With Quote
  #11  
Old 08-14-2010, 10:57 AM
Member
 
Join Date: Dec 2009
Posts: 278
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2132
tig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond repute
Re: More stalling/funky idle issues.

what happened with this. now mine is idling wierd when im stopped with the brakes on, but if i put it in neutral it idles fine.
__________________
Reply With Quote
  #12  
Old 08-14-2010, 04:01 PM
NHWK05's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Hooksett, NH
Posts: 5,108
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 94543
NHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond repute
Re: More stalling/funky idle issues.

I originally added the 1/2 qt of trans fluid per the mechanics reccomendation. After about 8 months it started to stall again. I checked the fluid level and made sure it was nice and red and not brown or burnt smelling and it was all right where it should be. I then added some lucas trans oil fix stuff. Not sure which it was an additive oil for any modern trans. I have it in the garage if you want to know what it is. I added that a few months ago and its fine ever since. I am going to get a trans service soon and will prolly have to add more after that as it seems this problem happens after a service because of a lack of oil.
__________________

__________________
-Kyle '05 Dark Khaki (PJT) WK Limited 4.7L V8, '08 Overland Front End, Custom Exhaust, 245/70/17 GY Silent Armors, Bilstein 4600s, K40 Calibre DL Radar Detector/Laser Diffuser, CB.
Wife's Jeep: '06 Jeep Liberty KJ 4x4 2.8L CRD Diesel
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
More idle/stalling issue questions brent Grand Cherokee - WK 50 03-07-2010 01:57 AM
Long idle down time 1 GRAND Grand Cherokee - WK 18 10-12-2009 08:06 PM
Odd idle when shifting... Martyp Grand Cherokee - WK 25 08-17-2009 05:58 PM
Brake Stalling Robert Palmer At The Track 10 06-27-2009 09:24 PM
Crap Idle? 4.7 V8 NHWK05 Troubleshooting/Problems Discussion 23 06-18-2009 03:21 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:50 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community