Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 04-01-2010, 11:37 PM
copley2596's Avatar
Member
 
Join Date: Jul 2009
Location: washington
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2062
copley2596 is a splendid one to behold
Re: need help!!!!!!

does anyone think that it could be a poor ground connection between the block and the chassis?
__________________

__________________
Reply With Quote
  #26  
Old 04-01-2010, 11:38 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,650
Thanks: 896
Thanked 1,131 Times in 776 Posts
Rep Power: 7718648
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: need help!!!!!!

something electrical.....check and sand the connections
__________________

__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #27  
Old 04-01-2010, 11:45 PM
copley2596's Avatar
Member
 
Join Date: Jul 2009
Location: washington
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2062
copley2596 is a splendid one to behold
Re: need help!!!!!!

where should the ground be on the block or on the heads and i think if i remember correctly on my original 4.7 there was two grounds near the back of the block
__________________
Reply With Quote
  #28  
Old 04-01-2010, 11:58 PM
Escape's Avatar
Senior Member
 
Join Date: Jul 2009
Location: Michigan
Posts: 1,911
Thanks: 0
Thanked 26 Times in 25 Posts
Rep Power: 113334
Escape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond repute
Re: need help!!!!!!

ASD relay (auto shut down).
Pull starter and see if the apex shoots out and spins freely.
Bad starter right out of the box.
Starter solenoid is bad.
Check your wiring as your O2's heater circuit is throwing codes.
Anything electrical and it will throw a fit.

As for the Y pipe try junkyards or any "good" shop should be able to make you one.
__________________

__________________
[SIGPIC][/SIGPIC]
Forged, Stroked, Blown, Bottle Fed & More
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.