P0113 code even after new IAT sensor, won't start until car cools down a while - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-16-2015, 10:58 PM
New Member
 
Join Date: Jul 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
rmauser is on a distinguished road
P0113 code even after new IAT sensor, won't start until car cools down a while

Hey guys, so for 4-5 weeks my 2010 WK has been hesitating with light acceleration on the highway (around 2-2.5k RPM, 50-60mph) but is fine with hard acceleration (don't know if this is related but sounds like it could be). Now yesterday the car wouldn't start right after a short trip and threw a P0113 code. After about 10min of sitting the car started up again. Today I replaced the IAT sensor and I'm still getting the same issues where I have to wait for the car to cool down (seems like at least 30min now) before starting. The OBD is showing air intake temps upwards of 110-120F (ambient air about 80F) even after sitting for an hour. As far as I can tell the harness seems okay, voltage is 4.8V at the connector clip. Any ideas what could be the cause of this?????

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 09-19-2015, 10:39 AM
Senior Member
 
Join Date: Feb 2010
Posts: 1,013
Thanks: 0
Thanked 23 Times in 22 Posts
Rep Power: 8958
dmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond repute
Re: P0113 code even after new IAT sensor, won't start until car cools down a while

IF this is for a 5.7, I replaced the IAT sensor in my 2006 with a stock one for a late model 6.4 Challenger. Plugs right into the stock harness, and the new IAT sensor is longer and samples the air near the center of the intake tube rather than near the wall of the tube, where temps are hotter. Don't know if it will help your issue, but it costs 20 bucks and I do notice an improvement in throttle response in hotter temps.
__________________
2006 GC Overland QD II
5.7 Hemi, Modern Muscle 85 mm CNC ported TB, Apexi super voltage stabilizer, Billet Tech. Catch Can, Koni FSD shocks/struts, SRT8 sway bars, Cooper Discoverer SRX 255/65/17, Amsoil fluids, Diablosport Intune CMR tuned by Hemifever tuning.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 Hemi IAT sensor part number? gc4x4 Grand Cherokee - WK2 - 2 02-04-2013 04:29 PM
IAT sensor issues? HEMI57 Engine Performance/Intake/Exhaust 0 08-17-2011 07:07 AM
IAT sensor extension AcidCold Performance Modifications 6 03-13-2011 12:37 PM
IAT sensor code P0112 Mark133 Troubleshooting/Problems 4 03-03-2011 12:28 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:31 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.