Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-05-2013, 08:05 AM
Drock970's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Apr 2013
Location: Mile High Fort Collins, CO
Posts: 9
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 572
Drock970 is on a distinguished road
Garage
Service 4WD System Finally FIXED!

I replaced all 4 of my wheel speed sensor with no luck with the 4WD light. I then read a ton of threads and found it was more then likely the wire harness for the solenoid on the inside of the front or rear diff.

-Hop under your jeep to the rear or front diff.
-At the top there is one wire connection and only one disconnect it.
-Throw some test leads on the sensors 2 male pins and make sure your reading 14 ohms.
-If you read 0 then your wire harness on the inside of the diff to the solenoid actuator is busted.

My front diff solenoid read 0 ohms. Cracked the front diff cover and found the wire harness was completely broke. Replaced the harness $10 part from stealership, replace fluid with mobile1 75-140 with friction modifier from dealership and Service 4WD light went off instantly . Hope this helps The pic is the harness that sticks out the top of the diff. You can see the two wires that go into the inside of the diff an connect to the solenoid are completely cut off.
Attached Images
File Type: jpg photo.jpg (137.8 KB, 33 views)
__________________

__________________
Reply With Quote
  #2  
Old 12-05-2013, 08:31 PM
brubakes's Avatar
Premium Member
My Jeep: 2008 5.7L WK
 
Join Date: Nov 2013
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 429
brubakes is on a distinguished road
Send a message via AIM to brubakes
Re: Service 4WD System Finally FIXED!

Quote:
Originally Posted by Drock970 View Post
I replaced all 4 of my wheel speed sensor with no luck with the 4WD light. I then read a ton of threads and found it was more then likely the wire harness for the solenoid on the inside of the front or rear diff.

-Hop under your jeep to the rear or front diff.
-At the top there is one wire connection and only one disconnect it.
-Throw some test leads on the sensors 2 male pins and make sure your reading 14 ohms.
-If you read 0 then your wire harness on the inside of the diff to the solenoid actuator is busted.

My front diff solenoid read 0 ohms. Cracked the front diff cover and found the wire harness was completely broke. Replaced the harness $10 part from stealership, replace fluid with mobile1 75-140 with friction modifier from dealership and Service 4WD light went off instantly . Hope this helps The pic is the harness that sticks out the top of the diff. You can see the two wires that go into the inside of the diff an connect to the solenoid are completely cut off.
I'm jealous. Which four wheel drive system does your jeep have?
__________________

__________________
Reply With Quote
  #3  
Old 12-05-2013, 08:37 PM
Drock970's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Apr 2013
Location: Mile High Fort Collins, CO
Posts: 9
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 572
Drock970 is on a distinguished road
Garage
Qdii
__________________
Reply With Quote
  #4  
Old 12-06-2013, 03:52 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Aug 2012
Location: IOW England UK
Posts: 11
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 809
xtrail3 is on a distinguished road
Garage
Re: Service 4WD System Finally FIXED!

I will have to try that, as my service 4wd systems has been on since i bought it in may, had mot and rear diff fluid leaking into rear brakes, so 500 later got through the mot, low 4wd still works but service 4wd system still on, uk jeep said 120 to change diff oil and new sensor(26) to sort out = 146.00.
__________________
Reply With Quote
  #5  
Old 12-06-2013, 02:09 PM
brubakes's Avatar
Premium Member
My Jeep: 2008 5.7L WK
 
Join Date: Nov 2013
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 429
brubakes is on a distinguished road
Send a message via AIM to brubakes
Re: Service 4WD System Finally FIXED!

FYI, these sensors are only if you have the Qudra-Drive II system.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
service 4wd system CatMan879 Troubleshooting/Problems Discussion 33 02-13-2014 06:46 PM
SERVICE 4WD SYSTEM Notice DustyOne Troubleshooting/Problems 7 02-15-2013 03:22 AM
Service 4wd system tjones4x4 Troubleshooting/Problems 6 12-11-2012 07:32 PM
Abs light, service brake system and 4wd system chaase68 Troubleshooting/Problems 15 08-09-2012 05:49 AM
Service Light - SERVICE 4WD SYSTEM - ?? Only 30K miles.... babygorilla Grand Cherokee - WK 4 02-17-2011 08:09 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:21 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.