Service TPMS message and new 20" SRT reps - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-16-2016, 12:13 PM
Member
 
Join Date: Sep 2015
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 499
buubba429x is on a distinguished road
Service TPMS message and new 20" SRT reps

I recently purchased new 20" staggered SRT replicas with brand new Nitto NT420 285/40/20 and 255/45/20 tires and Dorman TPMS sensors for my 2006 WK Limited 5.7. The sensors are registering on my dash with the correct PSI, however, I cannot seem to get the "Service Tire Press System" message off my dash. I have searched the forum and the web and really didn't find any conclusive answers. I purposely bought the stock tire size that came with OEM SRT8s to avoid issues, so my overall diameter of my wheel is still the stock 29" (stock size was 235/65/17). I did not have this problem with my stock wheels at all. The problem only arose when I put on the new setup. I'm thinking of just biting the bullet and buying OEM sensors to replace the Dormans I have, but I wanted to see if anyone can help me out with this before I do anything. The message is driving me nuts!

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 06-16-2016, 12:27 PM
SilverBillet's Avatar
Senior Member
 
Join Date: Jan 2014
Posts: 1,947
Thanks: 2
Thanked 438 Times in 298 Posts
Rep Power: 32545
SilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond repute
Garage
Re: Service TPMS message and new 20" SRT reps

Malfunctioning sensors. I had the same thing happen on my WK2 recently.
All pressures were reading correctly except the drivers rear on the dash was physically the passenger rear and vise versa with the other rear wheel.
I had Discount Tire run a diagnostic and malfunctioning codes came back for both rear sensors. I ordered a new set and everything works fine now.
Reply With Quote
  #3  
Old 06-17-2016, 12:30 PM
Member
 
Join Date: Sep 2015
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 499
buubba429x is on a distinguished road
Re: Service TPMS message and new 20" SRT reps

My sensors are reading the wrong wheels too. Did you have Dorman sensors too? I'm hoping that going with new OEM sensors will alleviate the issue.
Reply With Quote
  #4  
Old 06-17-2016, 12:35 PM
SilverBillet's Avatar
Senior Member
 
Join Date: Jan 2014
Posts: 1,947
Thanks: 2
Thanked 438 Times in 298 Posts
Rep Power: 32545
SilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond reputeSilverBillet has a reputation beyond repute
Garage
Re: Service TPMS message and new 20" SRT reps

I don't remember but I bought both sets on eBay.
In total Ive bought 4 sets from eBay and only had issues with that one set.
Reply With Quote
  #5  
Old 06-21-2016, 07:06 PM
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 1,303
Thanks: 0
Thanked 67 Times in 57 Posts
Rep Power: 156087
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: Service TPMS message and new 20" SRT reps

A couple years ago I had the same issue when I installed SRT Reps and new Dorman Sensors on my 06 GCO. The whole story would take too long so I'll cut to the chase. What has to be done is reprogramming of the Wireless Control Module (WCM), sometimes called the Sentry Key REmote Entry Module (SKREEM) module with the ID numbers of each of the new sensors and the wheel/spare position of each one. You'll need either a StarScan (dealer diagnostic tool) or some sort of advanced computerized diagnostic tool to do this. I have an Autel DS708 which has this capability. Another option is to purchase a programmable sensor kit from Dorman. This includes a Sensor ID programming tool and 4 programmable sensors. To use this though, you'll need to have the original sensor ID numbers that were programmed into the WCM. You then program the original ID's onto the new sensors...cloning. The sensors you installed will read the pressures correctly, but because the sensor ID's in the wheels don't match those in the WCM, you'll continually get the message you're receiving.
__________________
05 LX/RT & 06 WK/GCO, modded similarly, MDS "ON" Light, Vortex Gens, Debadged, DashHawk, BT Catch Can, SRT CAI W/Add Air Inlet, K&N Filter, Sonnax Trans Press Booster, SC Tuner W/Adv Trans Tuning App, DS Tuner, Cust tube headers w/3 in. catback, Bilsteins, SRT frt/rear bumpers, Eibach SRT Lwr Sprgs & Sways, FRI Sidewinder Cam Adv 2*, 6.1 valvetrain, SLP 25% UD Pulley, BBK 90mm TB, SOS Coils/.060 plug gaps. 20 in. SRT Reps.
Reply With Quote
Reply

Tags
SRT

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
" service electric break system " and " service 4WD system " Rexie1983 Troubleshooting/Problems 0 03-18-2013 07:48 AM
Silver WK: 22" SRT-8 Comp Gray Reps or 22" Black & Machined Viper Reps? Kaczman Suspension/Brakes/Wheels/Tires 6 06-17-2012 11:03 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:38 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.