Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-12-2011, 10:26 AM
JMLoughrey's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Aug 2011
Location: Farmington, CT
Posts: 520
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 72966
JMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond repute
Sigh - 13 days and back to the dealer she went

Well, Purchased my 2007 WK 3.7L two weeks ago tuesday. Sadly, she's ALREADY going back to the dealer.

Driving home last night, the WK completely shut down, or so i thought. Gauges dropped to zero, evic died, odometer died but she was still running. After a minute everything kicked back on, check engine light came on, TCS light came on, headlights started flickering, and a few other lights came on, looked like a christmas tree. All other controls in the vehicle were unresponsive, windows, locks, sunroof, TCS, blinkers, radio ETC.

I still had power steering, brakes (dont know about the lights) and parking lights, limped her to the dealer as i was luckly driving by and went by this morning.

Currently driving a rental (on the dealers dime) until i hear from them abuot what the issue is. Not all that happy, less then 2 weeks in, i've had more problems with this jeep then i did with my old Jeep Liberty or Nissan Xterra.

I tried to pull the code but my scanner just read ERROR. And with the evic not working that was no help to me.

Anyone got any ideas on what it could be? I'm still under warrenty as i've only had it 2 weeks and i have a 90 day 5k mile warrenty.
__________________

__________________
Reply With Quote
  #2  
Old 09-12-2011, 10:29 AM
viking757's Avatar
Member
My Jeep: 2008 6.1L SRT8
 
Join Date: May 2010
Location: NOVA
Posts: 792
Thanks: 0
Thanked 23 Times in 23 Posts
Rep Power: 19890
viking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond reputeviking757 has a reputation beyond repute
Garage
Re: Sigh - 13 days and back to the dealer she went

Quote:
Originally Posted by JMLoughrey View Post
Well, Purchased my 2007 WK 3.7L two weeks ago tuesday. Sadly, she's ALREADY going back to the dealer.

Driving home last night, the WK completely shut down, or so i thought. Gauges dropped to zero, evic died, odometer died but she was still running. After a minute everything kicked back on, check engine light came on, TCS light came on, headlights started flickering, and a few other lights came on, looked like a christmas tree. All other controls in the vehicle were unresponsive, windows, locks, sunroof, TCS, blinkers, radio ETC.

I still had power steering, brakes (dont know about the lights) and parking lights, limped her to the dealer as i was luckly driving by and went by this morning.

Currently driving a rental (on the dealers dime) until i hear from them abuot what the issue is. Not all that happy, less then 2 weeks in, i've had more problems with this jeep then i did with my old Jeep Liberty or Nissan Xterra.

I tried to pull the code but my scanner just read ERROR. And with the evic not working that was no help to me.

Anyone got any ideas on what it could be? I'm still under warrenty as i've only had it 2 weeks and i have a 90 day 5k mile warrenty.
Could be your ignition switch failing. Its not uncommon

Check this thread out
http://jeepgarage.org/showthread.php?t=15736

Edit: Also check the obvious like your battery connection
__________________

__________________
Reply With Quote
  #3  
Old 09-12-2011, 03:01 PM
Member
My Jeep: 2007 3.7L WK
 
Join Date: Sep 2010
Location: South Jersey
Posts: 137
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1577
Drew is on a distinguished road
I bet Your scanner said error because it is out of date. I ran into the same issue as mine was obd2 but not obd2 "can" compliant. The can bus system changed in 05ish? I updated my scanner and all is good.

As for the issue, was the jeep ever in a flood or show signs of being under water for a long time?


Sent from my iPhone using Tapatalk
__________________
Reply With Quote
  #4  
Old 09-12-2011, 08:23 PM
JMLoughrey's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Aug 2011
Location: Farmington, CT
Posts: 520
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 72966
JMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond repute
Re: Sigh - 13 days and back to the dealer she went

Quote:
Originally Posted by Drew View Post
I bet Your scanner said error because it is out of date. I ran into the same issue as mine was obd2 but not obd2 "can" compliant. The can bus system changed in 05ish? I updated my scanner and all is good.

As for the issue, was the jeep ever in a flood or show signs of being under water for a long time?


Sent from my iPhone using Tapatalk
Scanners fully up to date, used it on numerous jeeps and can vehicles over the passed few weeks.

As far as i know, and from what i can see, no water damage to the interior, nothing on carfax to imply any flood damage, it had the headgasket and timing belt replaced by the dealer before i bought it. Aside from that, i got nothing.

On an Update: Jeep will be keeping the vehicle over night, there are 13 stored codes from the incident. Ranging from electrical, to mechanic to everything in between.
__________________
Reply With Quote
  #5  
Old 09-13-2011, 08:37 AM
Member
My Jeep: 2008 3.7L WK
 
Join Date: May 2011
Location: Milford, NH
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1233
burkey222 is on a distinguished road
Re: Sigh - 13 days and back to the dealer she went

I wonder if it's the chip. I had something similar happen years ago, and the cpu was toasted. Keep us updated, I'd be interested in hearing more.
__________________
Reply With Quote
  #6  
Old 09-13-2011, 10:44 AM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,417
Thanks: 55
Thanked 132 Times in 114 Posts
Rep Power: 542603
robpp has disabled reputation
Re: Sigh - 13 days and back to the dealer she went

what chip. i didnt see CHIP mentioned anywhere.........
__________________
Reply With Quote
  #7  
Old 09-13-2011, 11:21 AM
Member
My Jeep: 2008 3.7L WK
 
Join Date: May 2011
Location: Milford, NH
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1233
burkey222 is on a distinguished road
Re: Sigh - 13 days and back to the dealer she went

I agree it wasn't mentioned. I'm just saying I've had a similar issue to what the OP described, and a burnt ECU was my problem. I'm not saying it's his problem, I was just wondering outloud.
__________________
Reply With Quote
  #8  
Old 09-13-2011, 03:51 PM
JMLoughrey's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Aug 2011
Location: Farmington, CT
Posts: 520
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 72966
JMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond repute
Re: Sigh - 13 days and back to the dealer she went

Well, an updated, get a call this morning, they can't duplicate the problem, therefore can't fix it. Said they did however reflash the ECU.

Go return my rental, walk across the street, get my keys, start it, bang, check engine light on, gauges off, horn honked once and one headlight was on. Service writer was standing right there.

Starting to regret buying this car, may be speaking with them about buying it back. I've had it two weeks, certified Jeep, from a well known Jeep Dealer...not a happy camper.
__________________
Reply With Quote
  #9  
Old 09-14-2011, 07:30 AM
antsjeep's Avatar
Member
My Jeep: 2008 3.7L WK
 
Join Date: Feb 2010
Location: Long Island, NY
Posts: 762
Thanks: 0
Thanked 12 Times in 10 Posts
Rep Power: 8705
antsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond reputeantsjeep has a reputation beyond repute
Re: Sigh - 13 days and back to the dealer she went

if they cant fix it, i would definitely look into handing the car back to them and demanding another WK.
__________________
2008 WK Laredo 4x4
RC 2.5" Lift, Bilstein HD, Monroe LL, 265/70/17 General Grabber AT2, JK Moabs, 1.25" spacers, K&N 57 Series, PW Mod,
DDM 5k Lows, VLED 6K LED Fogs, Stillen Covers, 15% front tint, BA System, Infinity 3.5" dash, JL Audio 250/1 & StealthBox
Reply With Quote
  #10  
Old 09-14-2011, 08:23 AM
Member
My Jeep: 2008 3.7L WK
 
Join Date: May 2011
Location: Milford, NH
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1233
burkey222 is on a distinguished road
Re: Sigh - 13 days and back to the dealer she went

I don't blame you for being frustrated. Personally, electrical problems always worry me. If it were me, I would begin the conversation of a return now. Sorry man.
__________________
Reply With Quote
  #11  
Old 09-14-2011, 10:30 PM
JMLoughrey's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Aug 2011
Location: Farmington, CT
Posts: 520
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 72966
JMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond repute
Re: Sigh - 13 days and back to the dealer she went

Well, talked to them today, they basically said in a nutshell, "we dont take cars back, F*ck off" I think i'll be calling Jeep in the morning.
__________________
Reply With Quote
  #12  
Old 09-15-2011, 12:07 AM
maxst2's Avatar
Senior Member
My Jeep: 2006 4.7L WK
 
Join Date: Feb 2010
Location: Oakland,IA
Posts: 1,475
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 198553
maxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond reputemaxst2 has a reputation beyond repute
Send a message via AIM to maxst2 Send a message via MSN to maxst2 Send a message via Yahoo to maxst2 Send a message via Skype™ to maxst2
Re: Sigh - 13 days and back to the dealer she went

You have had it for 2 weeks.. there is ALWAYS a warranty that covers a car from bumper to bumper for at least a month.

IMO if they don't fix it raise hell. Really...raise hell in the middle of the day with customers all around you. You'll get taken care of right away.
__________________

__________________
2006 65th Anni. Grand Cherokee 4x4 in black w/ 4.7L V8
MODS:
Installed- HID 5000k kit in fogs, Superchips programmer,AFE stage 2 intake, Jet 180* Thermostat, De-badged, Flyin' Ryan Modified Throttle Body - Ported then bored out. Magnaflow muffler. Rola Roof basket, Stubby Antenna, bquiet sound dampening for the rear deck. Rigid led spots on rola rack.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dealer Availability - Post here when your Dealer Has One on the Lot! Russ1331 Grand Cherokee - WK2 - 87 06-25-2010 02:31 PM
In 4 days...... Knightrider03m Other Rides 23 06-13-2010 02:05 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community