Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-26-2009, 02:20 PM
Member
 
Join Date: Jun 2009
Location: Columbus,NJ
Posts: 222
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2273
saleen032 has a reputation beyond reputesaleen032 has a reputation beyond repute
Send a message via AIM to saleen032
Tranny Problem..

I was driving back from Philly this morning and went to accelerate a bit, when the truck went to downshift, I felt a clunk/bang..it happened a few times, then the check engine light came on and the tranny stayed in 4th gear. I pulled the codes and came up with p0700(Transmission Control Malfunction),P0734(incorrect 4th gear ratio),and P0735(incorrect 5th gear ratio). I dropped it at the dealers today, since I cant really look anymore into the problem, and now just have to wait til Monday to find out what the problem is. The service advisor said that Modules/Sensors are common problems on these transmissions. Hopefully that is all it will be, but with my luck It may need a new tranny...lol...
__________________

__________________
Reply With Quote
  #2  
Old 09-26-2009, 04:31 PM
06SRT8300C's Avatar
Member
 
Join Date: Jun 2009
Posts: 124
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2150
06SRT8300C is on a distinguished road
Re: Tranny Problem..

I need a new trans
__________________

__________________
Reply With Quote
  #3  
Old 09-26-2009, 05:50 PM
Robert Palmer's Avatar
Rock N' Roll's Sophisticate/JG Co-Founder


My Jeep: 2010 6.1L SRT8
 
Join Date: May 2009
Location: Downtown Manhattan
Posts: 10,309
Thanks: 10
Thanked 64 Times in 54 Posts
Rep Power: 112828
Robert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond reputeRobert Palmer has a reputation beyond repute
Re: Tranny Problem..

They are either going to reflash the tcm or a give you a new one.
__________________
-Joe-



Silver
2010 Jeep Grand Cherokee SRT-8
Reply With Quote
  #4  
Old 09-26-2009, 06:30 PM
Matt's Avatar
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: May 2009
Location: 34.076513,-118.429573
Posts: 9,269
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 11736
Matt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond repute
Re: Tranny Problem..

I must admit, the title did throw me for a sec.

Good luck with the issue Scott!
__________________
Reply With Quote
  #5  
Old 09-26-2009, 08:07 PM
BUBBADOG's Avatar
Senior Member
 
Join Date: Jun 2009
Location: VA
Posts: 1,041
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 3124
BUBBADOG has a reputation beyond reputeBUBBADOG has a reputation beyond reputeBUBBADOG has a reputation beyond reputeBUBBADOG has a reputation beyond repute
Re: Tranny Problem..

Quote:
Originally Posted by saleen032 View Post
I was driving back from Philly this morning and went to accelerate a bit, when the truck went to downshift, I felt a clunk/bang..it happened a few times, then the check engine light came on and the tranny stayed in 4th gear. I pulled the codes and came up with p0700(Transmission Control Malfunction),P0734(incorrect 4th gear ratio),and P0735(incorrect 5th gear ratio). I dropped it at the dealers today, since I cant really look anymore into the problem, and now just have to wait til Monday to find out what the problem is. The service advisor said that Modules/Sensors are common problems on these transmissions. Hopefully that is all it will be, but with my luck It may need a new tranny...lol...
Call MARTIN SAINE heres his number 951-907-0434 he is the tranny god mother bro!!! trust me
__________________
SHOULD ALWAYS CHECKS YOUR KIDS HOMEWORK!!!................
Reply With Quote
  #6  
Old 09-26-2009, 08:24 PM
Member
 
Join Date: Jun 2009
Location: Columbus,NJ
Posts: 222
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2273
saleen032 has a reputation beyond reputesaleen032 has a reputation beyond repute
Send a message via AIM to saleen032
Re: Tranny Problem..

Quote:
Originally Posted by Matt View Post
I must admit, the title did throw me for a sec.

Good luck with the issue Scott!
That story is for the garage section.....lol..
__________________
Reply With Quote
  #7  
Old 09-27-2009, 03:22 PM
HEMIBeast's Avatar
Senior Member
 
Join Date: Sep 2009
Location: MA
Posts: 3,248
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 5387
HEMIBeast has a reputation beyond reputeHEMIBeast has a reputation beyond reputeHEMIBeast has a reputation beyond reputeHEMIBeast has a reputation beyond reputeHEMIBeast has a reputation beyond reputeHEMIBeast has a reputation beyond reputeHEMIBeast has a reputation beyond reputeHEMIBeast has a reputation beyond repute
Re: Tranny Problem..

^^ lol^^ Good luck bro. Im interested in knowing what caused it.
__________________
JEEP GC Limited 5.7
[SIGPIC][/SIGPIC]
180°Tstat,Flyin Ryan ported throttle body,Bwoody CAI,MHP CMR Tune Predator 7137,Billet tech catch can,Dynomax muffler, AR Headers,5" blk tips,CF Rammedic Hood,SRT8 Exterior,SRT8 Rails,SRT8 Grille,Custom headlight covers,Tinted Tails (Red03SilSS),Tinted windows, painted mirror covers, Painted & Shaved door Molding,Mopar Rear spoiler,painted black calipers,Black housing headlights with LED Halo's & controller,8000K H.I.D,Reverse H.I.D,20" Black SRT8 rep wheels,Falken Ziex 275/45/20,Addco Front Sway bar,SRT8 Rear sway bar,H&R Springs,SRT8 shocks,Leather Armrest,SRT8 pedals,SRT8 Shift knob,Colored cupholder,2 pod A pillar w/ Gauges,etc..
Parts awaiting install Spartan Cam, 09 Intake manifold, etc.
Reply With Quote
  #8  
Old 09-27-2009, 03:30 PM
Matt's Avatar
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: May 2009
Location: 34.076513,-118.429573
Posts: 9,269
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 11736
Matt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond repute
Re: Tranny Problem..

Quote:
Originally Posted by saleen032 View Post
I was driving back from Philly this morning and went to accelerate a bit, when the truck went to downshift, I felt a clunk/bang..
I had this happen to me, but not the rest. I believe there was a TSB for a tranny filter change (or something like that).

Same thing though, I went to accelerate a bit just as the truck was downshifting and heard a clunk. It then was very hesitant to shift up and would idle higher than normal.

I took mine in to the dealership and after 2 hours of whatever the hell they were doing they said they needed more time and I couldn't that day, so they just put everything back together, cleared the CEL and on my way I went. It drove perfectly normal ever since I drove it off the lot, so I never went back.
__________________
Reply With Quote
  #9  
Old 09-28-2009, 07:09 AM
Member
 
Join Date: Jun 2009
Location: Columbus,NJ
Posts: 222
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2273
saleen032 has a reputation beyond reputesaleen032 has a reputation beyond repute
Send a message via AIM to saleen032
Re: Tranny Problem..

^ after I cleared the codes, it worked fine for a bit, leading me to believe it is electrical versus mechanical.....I just have to wait and hear from them today...
__________________
Reply With Quote
  #10  
Old 09-28-2009, 07:33 AM
Matt's Avatar
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: May 2009
Location: 34.076513,-118.429573
Posts: 9,269
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 11736
Matt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond repute
Re: Tranny Problem..

Quote:
Originally Posted by saleen032 View Post
^ after I cleared the codes, it worked fine for a bit, leading me to believe it is electrical versus mechanical.....I just have to wait and hear from them today...
That's what I think mine was as well, it was like nothing had ever happened once the codes were cleared. In my own words, I think it just got bugged up and needed a restart, lol.
__________________
Reply With Quote
  #11  
Old 09-28-2009, 09:39 AM
Member
 
Join Date: Jun 2009
Location: Columbus,NJ
Posts: 222
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2273
saleen032 has a reputation beyond reputesaleen032 has a reputation beyond repute
Send a message via AIM to saleen032
Re: Tranny Problem..

Quote:
Originally Posted by Matt View Post
That's what I think mine was as well, it was like nothing had ever happened once the codes were cleared. In my own words, I think it just got bugged up and needed a restart, lol.

^ The problem came back after a few minutes....and each clearing would fix the problem temproarily
__________________
Reply With Quote
  #12  
Old 09-28-2009, 09:44 AM
Matt's Avatar
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: May 2009
Location: 34.076513,-118.429573
Posts: 9,269
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 11736
Matt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond repute
Re: Tranny Problem..

Quote:
Originally Posted by saleen032 View Post
^ The problem came back after a few minutes....and each clearing would fix the problem temproarily
Ah, damn, that sucks man! So, any idea what the issue is?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
tranny oil jeeppro Grand Cherokee - WK 47 05-29-2010 09:47 PM
Testing new tranny set-up...{video} BUBBADOG Performance Modifications 44 09-10-2009 12:11 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.