Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-11-2011, 10:15 PM
Member
 
Join Date: Jul 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1280
TB_Jeep is on a distinguished road
Transmission problem?

I'm new to this site & I'm having a problem w/ my Jeep. Hope you can help!
I have a 06 JGC, Laredo. It has about 81k miles on it now. I purchased it back in April. Shortly after, I noticed the downshift was a little rough sometimes.
About a month ago, while trying to merge onto the freeway, I needed to speed up to merge.. well, I stepped on the gas and then realized that I wouldnt be able to speed up fast enough and took my foot off the pedal to slow back down... well, this caused a really rough downshift, and I lost all power, like the car shifted into Neutral, it just rev'd when I press the accelerator. My Check Engine light came on & I had to pull over, put the car into park & then was able to put it back into gear & get going.
I stopped at home, planning to take the car to the dealer the next day. When I went to start it up again, the light was off... so I didnt do anything. It ran normal until this weekend...
2 days ago, I was driving on the hwy about 55mph and my ABS, traction control & ESP/ BAS lights all came on at the same time. I noticed no difference in the driving or braking and nothing to indicate to me there was a problem.
Today, I was speeding up to get on the freeway just like ^^ and I lost all power and my check engine light came on. I drove directly to the dealer. It threw the code P0730 and a code about the Right Rear Wheel Speed Circuit (sorry, dont have the code #)
Dealer says they need to take out the tranny & tear it apart to find the problem. I bought a Power Train warranty w/ it back in April. The Dealer told me that they dont know if the warranty will cover it until they have it out, taken apart and pinpoint what part is bad... at that point, if its not covered, I'm looking at a rebuild of my tranny and some major $$$.
This just doesnt sound right to me... Has anyone been through this before or experienced this problem? Any suggestions on what I should do?
The car runs fine and I am able to drive it.. sometimes it does have a rough downshift but not always.
__________________

__________________
Reply With Quote
  #2  
Old 07-11-2011, 10:24 PM
05WK's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Apr 2011
Location: North Texas
Posts: 1,304
Thanks: 23
Thanked 15 Times in 14 Posts
Rep Power: 15023
05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute
Re: Transmission problem?

That's why we here call them the stealership, lol. And as far as The acceleration, then going into neutral, that's normal. I believe it's the computer preventing any harm done. I have had this happen to me a time or two. Just gotta be careful.

Before you go extreme and have them take it apart, try reseting the computers. Take both battery terminals off for about 15minutes. Then put them back on and If the warning lights come back on perminatly I would still get a second opinion from a local tranny shop.

You may just need the trans fluid and filter changed out.
__________________

__________________
05 Jeep GC WK, 3.7L, SCT programmer, K&N CAI, FASTMAN ported TB, Flowmaster Super 44 cat-back exhaust (Dumped), HD Bilstien's, 6000K HIDs, 5% Tint ALL the way around, Full Infiniti speaker system with an Alpine HU, TOBY Subwoofer(THE GREATEST), Plasti-diped Rims
Reply With Quote
  #3  
Old 07-11-2011, 10:28 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,425
Thanks: 504
Thanked 87 Times in 81 Posts
Rep Power: 469956
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Transmission problem?

Happen to me too. They say the hard downshift is normal. I haven't had a hard downshift since I installed 32" tires though. But the PCM was flashed right before that.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #4  
Old 07-11-2011, 10:33 PM
Member
 
Join Date: Jul 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1280
TB_Jeep is on a distinguished road
Re: Transmission problem?

If I reset the computers, and the lights go out, should I just not worry about it then?
I only have about 4000 miles left on my warranty. (Just drove it across country and to hell & back thanks to the Military) So, if there really is a problem, I'd like to get it fixed before then.
stealership, lol!
__________________
Reply With Quote
  #5  
Old 07-11-2011, 10:38 PM
05WK's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Apr 2011
Location: North Texas
Posts: 1,304
Thanks: 23
Thanked 15 Times in 14 Posts
Rep Power: 15023
05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute
Re: Transmission problem?

There is an aprox. 50mile reset time period after. If there is a problem, they will come back on. I still recommend the trans fluid be replaced.
__________________
05 Jeep GC WK, 3.7L, SCT programmer, K&N CAI, FASTMAN ported TB, Flowmaster Super 44 cat-back exhaust (Dumped), HD Bilstien's, 6000K HIDs, 5% Tint ALL the way around, Full Infiniti speaker system with an Alpine HU, TOBY Subwoofer(THE GREATEST), Plasti-diped Rims
Reply With Quote
  #6  
Old 07-11-2011, 10:46 PM
Member
 
Join Date: Jul 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1280
TB_Jeep is on a distinguished road
Re: Transmission problem?

Thanks! I'll look into getting the fluids replaced. So, sounds like I might have just driven it weird or something & the downshift is normal?
Is flashing the PCM the same as resetting the computer? Sorry if thats a dumb question.. If not, do I need to flash the PCM and how do I do that?
Any idea about the other lights?
__________________
Reply With Quote
  #7  
Old 07-11-2011, 10:56 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,425
Thanks: 504
Thanked 87 Times in 81 Posts
Rep Power: 469956
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Transmission problem?

The dealer flashes (update software) the PCM. I've heard different stories about the "hard downshift" Jeep transmission which leaves me at bit concerned about the product.

Has me in the state of mind, "Should I buy another Jeep?"

Bottom line is that since the PCM flashes and transmission fluid change, I haven't had any problems. I can make it downshift hard if I want (which is rare now because of the large tires) but still....does that mean I can't drive my Jeep the way I want without it trying to protect myself.

I've heard plenty of stories like yours in the first post about pulling into traffic, transmission downshift hard, drops in neutral to "protect" itself, and puts the people in danger in return causing accidents. Look it up. Plenty of complaints online.

But like I said, my wk has been good to me but will the next one..................
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #8  
Old 07-11-2011, 11:03 PM
Member
 
Join Date: Jul 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1280
TB_Jeep is on a distinguished road
Re: Transmission problem?

This is my first SUV, first Automatic, and first Jeep... ha. It has me feeling iffy too. I didnt know what to expect.

I'll look up those complaints, thanks! Glad to know I'm not alone, but its not such a good feeling.
__________________
Reply With Quote
  #9  
Old 07-11-2011, 11:06 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,425
Thanks: 504
Thanked 87 Times in 81 Posts
Rep Power: 469956
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Transmission problem?

It's not a good feeling at all. But the WK that sits outside in my driveway has been good to me for a long time now.

I had some bumps in the road but go over them. However, they did leave me with some sores which make me feel the way I feel. And also, other car enthusiasts I know personally that have owned Jeeps and the DAMN GOOD care of every thing they own and they say never again.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #10  
Old 07-12-2011, 08:08 AM
Member
 
Join Date: Jul 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1280
TB_Jeep is on a distinguished road
Re: Transmission problem?

Anyone have an idea about why my ABS, traction control & ESP/BAS light might have come on?
__________________
Reply With Quote
  #11  
Old 07-12-2011, 02:47 PM
Member
 
Join Date: Jul 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1280
TB_Jeep is on a distinguished road
Re: Transmission problem?

Update: I took the battery terminals off for about 20 min. Reconnected them, the lights turned off, then flashed and came back on & stayed on. I did not/have not driven it since.
I cannot check my Tranny fluid b/c I dont have a dipstick, its a sealed tranny.. guess I need to go to the dealer to have this done. What a pain!
I have an apt w/ the dealer tomorrow.
__________________
Reply With Quote
  #12  
Old 07-12-2011, 08:07 PM
Member
My Jeep: 2008 3.7L WK
 
Join Date: May 2011
Location: Milford, NH
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1359
burkey222 is on a distinguished road
Re: Transmission problem?

Please keep us updated. I'd love to hear how this turns out.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission problem Frango100 Troubleshooting/Problems 15 10-19-2011 01:10 PM
Transmission Shifting Problem txrancher74 Trouble Shooting/Problems/Service 12 06-05-2011 06:15 PM
transmission problem cliffhangerthird Troubleshooting/Problems 4 05-22-2011 10:04 PM
transmission problem cliffhangerthird Grand Cherokee - WK 1 05-22-2011 11:09 AM
Transmission Problem (need help!) cyprus Grand Cherokee - WK 9 03-14-2011 03:16 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.