Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-16-2010, 09:58 PM
New Member
 
Join Date: Jan 2010
Location: Bothell, WA
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Cascade159 is on a distinguished road
Uconnect issues

I have an 05 GC Limited with Uconnect. My phone is paired with the vehicle and I have placed calls with no issue until last week when it stated that my phone was low on battery. The system started acting strangely. Now, whenever I enter the vehicle and start the rig, the radio goes to phone mode. I get no "Ready" response. I cannot disconnect the phone from the radio except to disconnect via the phone or disable bluetooth on the phone.

How do I reset Uconnect to function properly. I have tried different combinations, but nothing has reset the system.
__________________

__________________
Reply With Quote
  #2  
Old 03-16-2010, 10:19 PM
SvenskaJeepGuy's Avatar
Let's Roll
My Jeep: 2005 4.7L WK
 
Join Date: Dec 2009
Location: Scranton PA
Posts: 13,083
Thanks: 139
Thanked 162 Times in 152 Posts
Rep Power: 1255319
SvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond repute
Garage
Re: Uconnect issues

just a shot in the dark here, but maybe by taking off the negative battery terminal for ten min or so? i dont have uconnect so this is just a guess.
__________________

__________________
Reply With Quote
  #3  
Old 03-16-2010, 11:13 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 988
Thanks: 0
Thanked 18 Times in 16 Posts
Rep Power: 154868
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: Uconnect issues

I've got an 05 LX (Dodge Magnum) with the U-Connect and it has never given me a day of trouble. Late last year I bought an 06 WK GCO and the U-Connect in it worked terrible. It was always very unpredictable. I finally found that there were several TSB's on the system. After upgrading the PCM/TCM (which incorportated the TSB(s)) it now works much better. It still occassionally screws up but fot the most part it is now reliable. I think one of the TSB's tells how to reset the U-Connect. As I recall, you push the two U-C buttons on the mirror at the same time and hold them on for about 10 seconds. I found that didn't help though. Updating the CALID's is the only thing that worked for me.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Uconnect Wi-fi Jpeyatt Audio, Video, Navigation & Electronic Modifications 8 01-16-2012 10:35 AM
How to add autodim and Uconnect Scottina06 Technical Tips/DIY/How-To 9 12-21-2010 08:14 PM
electrical issues... smack82 Troubleshooting/Problems Discussion 6 01-21-2010 01:20 PM
having some issues - like to get some thoughts mikskillz Grand Cherokee - WK 7 12-22-2009 07:12 PM
having some strange issues chefalan23 Grand Cherokee - WK 15 09-19-2009 12:19 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community