Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-07-2009, 08:43 PM
NHWK05's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Hooksett, NH
Posts: 5,111
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 94615
NHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond repute
Well this is weird

I noticed that some times right after a cold start my jeep will hesitate. The other day i started my jeep after an hour of sitting. I started it and put it in reverse and no matter how much i hit the gas it just kinda went slow. Then when i shifted in to 1st (driving it manually) it had little to no throttle response for about 10 seconds and then it came alive. This has happened a few times now.

BTW it still has a funky low idle and occasionally stalls out still. The reflash of the computer did nothing for that either.

2005 4.7 V8
__________________

__________________
-Kyle '05 Dark Khaki (PJT) WK Limited 4.7L V8, '08 Overland Front End, Custom Exhaust, 245/70/17 GY Silent Armors, Bilstein 4600s, K40 Calibre DL Radar Detector/Laser Diffuser, CB.
Wife's Jeep: '06 Jeep Liberty KJ 4x4 2.8L CRD Diesel
Reply With Quote
  #2  
Old 07-07-2009, 10:48 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,231
Thanks: 866
Thanked 972 Times in 687 Posts
Rep Power: 7717864
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Well this is weird

mine has done that from time to time....something about oil or something getting to the rearend. dont quote me on that though....lol
__________________

__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #3  
Old 07-07-2009, 10:59 PM
Member
 
Join Date: Jul 2009
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1944
Nand12 is on a distinguished road
Re: Well this is weird

Check your transmission fluid level because it sounds like the torque converter isn't filling fast enough on startup (low transmission fluid can also cause stalling/rough idle). There is also a TSB out on a similar condition (delayed/harsh gear engagement on cold startup) regarding the transmission filter allowing the fluid to drain out of the converter. There is an updated filter for this issue so you might want to drop the pan and do a tranny service. Check the tranny cooler lines for leaks if you determine that the fluid is low and replace if necessary.
__________________
Reply With Quote
  #4  
Old 07-07-2009, 11:04 PM
Matt's Avatar
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: May 2009
Location: 34.076513,-118.429573
Posts: 9,269
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 11645
Matt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond repute
Re: Well this is weird

I have had the same issue before... when I researched it I found the below to be the correct diagnosis.

Quote:
Originally Posted by Nand12 View Post
Check your transmission fluid level because it sounds like the torque converter isn't filling fast enough on startup (low transmission fluid can also cause stalling/rough idle). There is also a TSB out on a similar condition (delayed/harsh gear engagement on cold startup) regarding the transmission filter allowing the fluid to drain out of the converter. There is an updated filter for this issue so you might want to drop the pan and do a tranny service. Check the tranny cooler lines for leaks if you determine that the fluid is low and replace if necessary.
__________________
Reply With Quote
  #5  
Old 07-07-2009, 11:05 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,231
Thanks: 866
Thanked 972 Times in 687 Posts
Rep Power: 7717864
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Well this is weird

Nand12 is the man
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #6  
Old 07-08-2009, 08:11 AM
NHWK05's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Hooksett, NH
Posts: 5,111
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 94615
NHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond repute
Re: Well this is weird

Quote:
Originally Posted by Nand12 View Post
Check your transmission fluid level because it sounds like the torque converter isn't filling fast enough on startup (low transmission fluid can also cause stalling/rough idle). There is also a TSB out on a similar condition (delayed/harsh gear engagement on cold startup) regarding the transmission filter allowing the fluid to drain out of the converter. There is an updated filter for this issue so you might want to drop the pan and do a tranny service. Check the tranny cooler lines for leaks if you determine that the fluid is low and replace if necessary.


You are the second person to mention adding some tranny fluid. Now i feel comfortable doing it. Thanks alot.

What atf does this tranny use? My AW4 tranny in my Xj just used dexron/mercon fluid.
__________________
-Kyle '05 Dark Khaki (PJT) WK Limited 4.7L V8, '08 Overland Front End, Custom Exhaust, 245/70/17 GY Silent Armors, Bilstein 4600s, K40 Calibre DL Radar Detector/Laser Diffuser, CB.
Wife's Jeep: '06 Jeep Liberty KJ 4x4 2.8L CRD Diesel
Reply With Quote
  #7  
Old 07-08-2009, 08:53 AM
White WK Swagga's Avatar
Senior Member
My Jeep: 2009 3.7L WK
 
Join Date: May 2009
Location: East WishAN*ggaWoods, NY
Posts: 14,384
Thanks: 8
Thanked 5 Times in 5 Posts
Rep Power: 16563
White WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond repute
Re: Well this is weird

Way to go fellas. Good looking out. I hope it works out for ya Kyle...
__________________
The fallen......

09 WK Limited, 3.7 w/ Nav (MYGIG) W/ ipod, Single Kicker 12" CVX sub-ZX750 amp, 20" chrome SRT reps,front & reat SRT sway bars, V-LED interior & license plate, LED cargo light, Dual LED turn bulbs, painted headlight reflector covers, 5k HID lows, 3.5k/5k fogs, K&N Drop in filter, Shorty antenna, Tinted Tails & 3rd brake light, debadged.....
Reply With Quote
  #8  
Old 07-08-2009, 09:03 AM
NHWK05's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Hooksett, NH
Posts: 5,111
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 94615
NHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond repute
Re: Well this is weird

Me too!
__________________
-Kyle '05 Dark Khaki (PJT) WK Limited 4.7L V8, '08 Overland Front End, Custom Exhaust, 245/70/17 GY Silent Armors, Bilstein 4600s, K40 Calibre DL Radar Detector/Laser Diffuser, CB.
Wife's Jeep: '06 Jeep Liberty KJ 4x4 2.8L CRD Diesel
Reply With Quote
  #9  
Old 07-08-2009, 09:31 AM
jeepnjeep's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jul 2009
Location: Nassau, NY
Posts: 1,381
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 3292
jeepnjeep is just really nice
Re: Well this is weird

Quote:
Originally Posted by NHWK05 View Post
You are the second person to mention adding some tranny fluid. Now i feel comfortable doing it. Thanks alot.

What atf does this tranny use? My AW4 tranny in my Xj just used dexron/mercon fluid.
Use only ATF-4. Anything else and the tranny will not like it.
__________________
Hi, Im JIM
2005 Grand Cherokee Laredo
4.7 Ltr engine.
Tow pkg.
Cargo pkg.
So far K@N replacement air filter,hood scoops, 255/65/17 General Grabber AT2 tires, Magnaflow muffler and I trimmed the front valance under the bumper.
"An unarmed man can only flee from evil and evil is not overcome by fleeing from it."Col. Jeff Cooper
Reply With Quote
  #10  
Old 07-08-2009, 09:48 AM
NHWK05's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Hooksett, NH
Posts: 5,111
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 94615
NHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond repute
Re: Well this is weird

Thanks. I just found it here too in an online owners manual. (We should sticky this info)

Component Fluid, Lubricant, or Genuine Part
Engine Coolant Mopar௡ Antifreeze/Coolant 5 Year/100,000 Mile Formula HOAT (Hybrid Or-
ganic Additive Technology)
Engine Oil (3.7L/4.7L Engines) Use API Certified SAE 5W-30 Engine Oil, meeting the requirements of
DaimlerChrysler Material Standard MS-6395.
Engine Oil (5.7L Engines) Use API Certified SAE 5W-20 Engine Oil, meeting the requirements of
DaimlerChrysler Material Standard MS-6395.
Oil Filter (All Engines) Mopar௡ Oil Filter (P/N 05281090)
Spark Plugs Refer to the Vehicle Emission Control Information label in the engine com-
partment.
Fuel Selection (3.7L and 4.7L En- 87 Octane
gines)
Fuel Selection (5.7L Engines) 87 Octane Acceptable - 89 Octane Recommended

Automatic Transmission Mopar௡ ATF+4 Automatic Transmission Fluid
Transfer Case Mopar௡ ATF+4 Automatic Transmission Fluid

Axle Differential (Front-Rear) Mopar௡ Synthetic Gear & Axle Lubricant SAE 75W-140 (API-GL5) or
equivalent with friction modifier additive.
Brake Master Cylinder Mopar௡ DOT 3 Brake Fluid, SAE J1703 should be used. If DOT 3, SAE
J1703 brake fluid is not available, then DOT 4 is acceptable. Use only rec-
ommended brake fluids.
Power Steering Reservoir This system requires the use of Mopar௡ Hydraulic System Power Steering
Fluid (P/N 05142893AA) or equivalent, which meets DaimlerChrysler Ma-
terial Standard MS-10838.
__________________
-Kyle '05 Dark Khaki (PJT) WK Limited 4.7L V8, '08 Overland Front End, Custom Exhaust, 245/70/17 GY Silent Armors, Bilstein 4600s, K40 Calibre DL Radar Detector/Laser Diffuser, CB.
Wife's Jeep: '06 Jeep Liberty KJ 4x4 2.8L CRD Diesel
Reply With Quote
  #11  
Old 07-08-2009, 11:28 AM
Member
 
Join Date: Jul 2009
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1944
Nand12 is on a distinguished road
Re: Well this is weird

Yup, only use ATF+4 in these transmissions. If you just need to top off the fluid, you can pick up SuperTech ATF+4 from your local wallyworld (it is licensed by Chrysler as a genuine ATF+4 and it's cheap) for less than $3 a quart.
__________________
Reply With Quote
  #12  
Old 07-08-2009, 02:18 PM
Marlon_JB2's Avatar
Senior Member
My Jeep: 2010 3.7L KK
 
Join Date: Jun 2009
Location: Jefferson North Assembly Plant
Posts: 2,515
Thanks: 46
Thanked 146 Times in 96 Posts
Rep Power: 86922
Marlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond repute
Send a message via AIM to Marlon_JB2 Send a message via Yahoo to Marlon_JB2 Send a message via Skype™ to Marlon_JB2
Re: Well this is weird

Funny! I had this same issue in my Liberty CRD with the 545RFE, and overfilling the transmission solved the issue.
__________________

__________________
JEFFERSON NORTH Assembly Plant STATUS:
PILOT/Production Build!!!!!

The Marlon Garage Contains The Following Methods of Engine Powered Transportation:
'10 Jeep Liberty Renegade 4x4 - BACK! With new TIRES and WHEELS!
- My posts are NOT a representation of the official views of Chrysler Group LLC or any of its affiliates -
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community