Go Back   Jeep Garage - Jeep Forum > Modifications & Enhancements > Audio, Video, Navigation & Electronic Modifications

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-19-2010, 08:43 PM
Denny boy's Avatar
Member
 
Join Date: Jun 2009
Location: Shoreview, MN
Posts: 605
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2498
Denny boy is a jewel in the rough
amp problem

ok so i put a new amp in my buddies jeep. its a decent rockford and rand for two months. now when he turns it on the two thirty amp fuses on the map both blow when he turns the stereo on.

I have checked all of the wiring and re wired.
i have disconected all of the speaker wires and rca's leaving the power ground and remote hooked up.

I don't know where else to look..... any ides?
__________________

__________________
Dakota County Technical College
Entry level GM Tech
Cataclysmic Perverter
Searching for a new jeep to me, gotta get back in the jeep game.
If you don't stand behind our troops, PLEASE feel free to stand in front of them.
Reply With Quote
  #2  
Old 07-19-2010, 09:08 PM
Asativa's Avatar
Member
My Jeep: 2005 4.7L WK
 
Join Date: Aug 2009
Location: northern va
Posts: 379
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2195
Asativa has a reputation beyond repute
Re: amp problem

It's the amp, all my rockfords over the years havE died this way
__________________

__________________
Reply With Quote
  #3  
Old 07-21-2010, 09:25 PM
Denny boy's Avatar
Member
 
Join Date: Jun 2009
Location: Shoreview, MN
Posts: 605
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2498
Denny boy is a jewel in the rough
Re: amp problem

the amp was like brand new gains were set like a quarter up.
__________________
Dakota County Technical College
Entry level GM Tech
Cataclysmic Perverter
Searching for a new jeep to me, gotta get back in the jeep game.
If you don't stand behind our troops, PLEASE feel free to stand in front of them.
Reply With Quote
  #4  
Old 07-21-2010, 10:02 PM
JRsmoothee's Avatar
Premium Member
My Jeep: 2009 4.7L WK
 
Join Date: Mar 2010
Location: MT
Posts: 385
Thanks: 0
Thanked 4 Times in 2 Posts
Rep Power: 1999
JRsmoothee is on a distinguished road
Re: amp problem

what model rockford
__________________
2009 WK Limited tinted tails, MOPAR bodykit, lockpic, color matched grill, headlight stillens, debadged, color matched shorty antenna, V-leds interior, wet okole seat covers, black burlwood interior bezels, WK Eibach springs,WK Bilstein shock/struts, 22's on toyo proxes stII 265/40/22, 3000k 55w HID fogs, SRT rear sway bar, kicker audio upgrade, SRT roof rails
Reply With Quote
  #5  
Old 07-21-2010, 10:04 PM
Denny boy's Avatar
Member
 
Join Date: Jun 2009
Location: Shoreview, MN
Posts: 605
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2498
Denny boy is a jewel in the rough
Re: amp problem

its a p450.4 it's older but never was used i pulled the plastic off the box my self.
__________________
Dakota County Technical College
Entry level GM Tech
Cataclysmic Perverter
Searching for a new jeep to me, gotta get back in the jeep game.
If you don't stand behind our troops, PLEASE feel free to stand in front of them.
Reply With Quote
  #6  
Old 07-21-2010, 10:08 PM
JRsmoothee's Avatar
Premium Member
My Jeep: 2009 4.7L WK
 
Join Date: Mar 2010
Location: MT
Posts: 385
Thanks: 0
Thanked 4 Times in 2 Posts
Rep Power: 1999
JRsmoothee is on a distinguished road
Re: amp problem

hmmm....was it factory refurbished by chance
__________________
2009 WK Limited tinted tails, MOPAR bodykit, lockpic, color matched grill, headlight stillens, debadged, color matched shorty antenna, V-leds interior, wet okole seat covers, black burlwood interior bezels, WK Eibach springs,WK Bilstein shock/struts, 22's on toyo proxes stII 265/40/22, 3000k 55w HID fogs, SRT rear sway bar, kicker audio upgrade, SRT roof rails
Reply With Quote
  #7  
Old 07-22-2010, 11:18 PM
Denny boy's Avatar
Member
 
Join Date: Jun 2009
Location: Shoreview, MN
Posts: 605
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2498
Denny boy is a jewel in the rough
Re: amp problem

no i dont think so im not sure im pretty sure its not. i opened it up today there isnt anything burnt
__________________
Dakota County Technical College
Entry level GM Tech
Cataclysmic Perverter
Searching for a new jeep to me, gotta get back in the jeep game.
If you don't stand behind our troops, PLEASE feel free to stand in front of them.
Reply With Quote
  #8  
Old 07-23-2010, 04:24 PM
JRsmoothee's Avatar
Premium Member
My Jeep: 2009 4.7L WK
 
Join Date: Mar 2010
Location: MT
Posts: 385
Thanks: 0
Thanked 4 Times in 2 Posts
Rep Power: 1999
JRsmoothee is on a distinguished road
Re: amp problem

hmmmm i dunno......only thing i could think of is if you have a stray wire strand sticking out on the speaker outputs on the amp that is thouching the other polarity.....ya know what im sayin (+ touching - at the speaker output source on the amp)
__________________
2009 WK Limited tinted tails, MOPAR bodykit, lockpic, color matched grill, headlight stillens, debadged, color matched shorty antenna, V-leds interior, wet okole seat covers, black burlwood interior bezels, WK Eibach springs,WK Bilstein shock/struts, 22's on toyo proxes stII 265/40/22, 3000k 55w HID fogs, SRT rear sway bar, kicker audio upgrade, SRT roof rails
Reply With Quote
  #9  
Old 07-24-2010, 01:20 PM
Denny boy's Avatar
Member
 
Join Date: Jun 2009
Location: Shoreview, MN
Posts: 605
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2498
Denny boy is a jewel in the rough
Re: amp problem

i unplugged all the speaker wires and rca's still did it.

haha thanks for your help, i think hes just gunna but a differnet one. and send the old one back. it has a waranty.
__________________

__________________
Dakota County Technical College
Entry level GM Tech
Cataclysmic Perverter
Searching for a new jeep to me, gotta get back in the jeep game.
If you don't stand behind our troops, PLEASE feel free to stand in front of them.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LONG ISLAND MEET&GREET&TRAIL RIDE (Riverhead) JeepGuy026 NorthEast 494 08-28-2010 08:49 AM
What do you suggest? Simple subwoofer box & amp to stock MyGig??? White WK Swagga Audio, Video, Navigation & Electronic Modifications 112 01-15-2010 11:21 AM
Kicker Amp (77KICK18AB) & Boston Acoustics oem speakers Joe in PA Audio, Video, Navigation & Electronic Modifications 16 11-23-2009 11:00 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community