Go Back   Jeep Garage - Jeep Forum > Modifications & Enhancements > Audio, Video, Navigation & Electronic Modifications

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-20-2013, 04:12 PM
New Member
 
Join Date: Nov 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
voxanboxer is on a distinguished road
Backup Lamps out after backup cam install

2006 Grand Cherokee Laredo 4x4 3.7V6
So I installed a backup cam. I spent 3 days meticulously putting this thing in. I tested six times throughout the process and the camera worked fine: put it in Reverse and the image appears on the screen. I even mounted and adjusted the camera. Everything worked fine. I was finished and put all the panels back in the car. While i was testing the lights to make sure nothing was out my daughter noticed the backup lamps came on for a second and immediately went out.

Now, I no longer have backup lights and I don't get a video feed trigger (so no power).

I researched my butt off trying to figure what happened. I searched for a fuse for the lamps but there isn't one besides the main lamp fuse, but all of the other rear lights work. So I thought it might be in the transmission.

I took it to the dealer and paid $100 to diagnose the problem. They said it is the Front Control Module, but only the part that deals with the back up lamps. They also said there is no fuse for the FCM. I now have to pay $650 to replace the entire FCM. I can't believe a fuse doesn't protect the FCM!

Does this sound right? A tiny backup camera can blow PART of a computer? This camera can't draw much power.

And.... YES I hooked it up right. I even had the dealer check it to see if I caused the problem by hooking it up wrong. They said everything looked good.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
backup lamps problem tassiecj6 Troubleshooting/Problems 3 02-25-2013 06:28 PM
Help me With Backup Cam! DAVY27 Audio/Visual/Navigation 2 04-16-2012 06:35 AM
New mount on Backup Cam 2005 WK Grand Cherokee - WK 2 09-04-2011 10:50 PM
backup cam? katie0010 Audio, Video, Navigation & Electronic Modifications 2 06-25-2011 05:54 PM
Backup CAM Phatchris Grand Cherokee - WK 13 02-02-2010 12:11 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community