Go Back   Jeep Garage - Jeep Forum > Modifications & Enhancements > Audio, Video, Navigation & Electronic Modifications

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-12-2013, 05:46 AM
Member
 
Join Date: Mar 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 914
Overland Neil is on a distinguished road
Dead Battery after fitting aftermarket stereo !!!

Just fitted a Pioneer AVH P4400 using a Scosche S3-1. I have an Ipod connected to it and also a reverse camera. When left overnight the battery completely drains,not even enough power to unlock the doors. Has anyone experienced this before or know what the problem could be.
__________________

__________________
Reply With Quote
  #2  
Old 01-12-2013, 07:28 PM
Member
My Jeep: 2007 4.7L WK
 
Join Date: Oct 2012
Location: OKC
Posts: 73
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 758
meistro is on a distinguished road
Re: Dead Battery after fitting aftermarket stereo !!!

do you have the remote and 12v wires switched?
__________________

__________________
Reply With Quote
  #3  
Old 01-13-2013, 06:09 AM
Member
 
Join Date: Mar 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 914
Overland Neil is on a distinguished road
Re: Dead Battery after fitting aftermarket stereo !!!

The S31 doesn't have a remote wire to connect to the stereo,i have confirmed this with Scosche. I connected the red +12v from the S31 to the stereo as per the instructions. But even after following the activation procedures the stereo stays live when the key is removed and the door opened. This is why i tapped the switched live from the cigarette lighter. So far i have tried a PAC RP4 which turned the EVIC german and now the scosche is flattening the battery. Since i have told Scosche that i'm in the UK they haven't replied to my questions. I am now considering getting the Axxess CHTO 01, whats another $100+ !!!
__________________
Reply With Quote
  #4  
Old 01-15-2013, 09:18 PM
Member
My Jeep: 2007 4.7L WK
 
Join Date: Oct 2012
Location: OKC
Posts: 73
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 758
meistro is on a distinguished road
Re: Dead Battery after fitting aftermarket stereo !!!

You might want to look into the metra harness. I dont know if you have the ability to use that or not but Im in the states and that worked well with my p4400 unit.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 WJ alarm issue after dead battery LionheartUK Troubleshooting/Problems 1 12-29-2012 07:47 PM
Random dead battery? foster Trouble Shooting/Problems/Service 14 11-04-2012 08:39 AM
Battery Dead or.. Starter?! illmortal Troubleshooting/Problems 7 07-27-2012 01:45 PM
2010 with a dead battery RiverCityOffroad Troubleshooting/Problems 14 09-23-2011 11:54 AM
Battery is dead need help ASAP on replacment CentralTexHemi Trouble Shooting/Problems/Service 18 09-02-2009 03:40 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community