Go Back   Jeep Garage - Jeep Forum > Modifications & Enhancements > Audio, Video, Navigation & Electronic Modifications

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-14-2013, 10:05 AM
ALPINEST4RS's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Mar 2010
Location: Brighton, MI
Posts: 340
Thanks: 8
Thanked 1 Time in 1 Post
Rep Power: 1928
ALPINEST4RS is on a distinguished road
Did something wrong...

I just installed a Infinity Basslink into my new jeep, but I'm running into an issue. I have the Premimum sound in my jeep aswell. I did a LOC, but I think it hooked up wrong. I hooked it up behind the radio (rear speakers). The sub volume stays consistent no matter what volume the radio is at.

Do I have to hook up my LOC between the amp and the speakers? Also, should I wire them to the front door speakers instead?? I was reading those speakers are actualy the low range speakers. Thanks in advance.
__________________

__________________
2006 Jeep Grand Cherokee WK 3.7L - SOLD (lil bro's)
2007 Jeep Grand Cherokee WK 4.7L -SOLD
2011 - Mazdaspeed3 COBB AP/CS TIP-SRI/ CPE Axle Back/ Stage 1 RMM/ Internals/ Wiseco Pistons/ Forged Rods
Reply With Quote
  #2  
Old 04-17-2013, 09:15 AM
Member
My Jeep: 2007 4.7L WK
 
Join Date: Oct 2012
Location: OKC
Posts: 73
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 733
meistro is on a distinguished road
Re: Did something wrong...

alpine i have one of those in my jeep. Did you use the line level inputs that came with basslink? or did you not get those in the box?

I had the non premium system in mine and tapped the speaker leads in the dash and ran them back.

As for hooking up to rear or front speakers the cross over in the basslink will remove the high frequencies so you really dont need to worry about that.

if you don't have the speaker level inputs (white plug on the amp) i would recommend using those instead of a LOC. i tuned mine to the stereo and never have it above half way.

Just my opinion.
__________________

__________________
Reply With Quote
  #3  
Old 04-17-2013, 09:42 AM
ALPINEST4RS's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Mar 2010
Location: Brighton, MI
Posts: 340
Thanks: 8
Thanked 1 Time in 1 Post
Rep Power: 1928
ALPINEST4RS is on a distinguished road
I found that my phase was out 180. My sub volume is still the same at all levels. I'm going to try and hook my leads out after the amp and see what happens. I think the amp is the main frame for the stereo and controls the volume. The head unit is a input to the amp. I'll report back soon.
__________________
2006 Jeep Grand Cherokee WK 3.7L - SOLD (lil bro's)
2007 Jeep Grand Cherokee WK 4.7L -SOLD
2011 - Mazdaspeed3 COBB AP/CS TIP-SRI/ CPE Axle Back/ Stage 1 RMM/ Internals/ Wiseco Pistons/ Forged Rods
Reply With Quote
  #4  
Old 04-17-2013, 02:10 PM
Member
My Jeep: 2007 4.7L WK
 
Join Date: Oct 2012
Location: OKC
Posts: 73
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 733
meistro is on a distinguished road
Re: Did something wrong...

If you are going from the amp in the back make sure that you tap the leads to the speakers instead of before. If I remember correctly the amped systems are canbus integrated and the lines going into the amp wont help you at all.
__________________
Reply With Quote
  #5  
Old 04-17-2013, 02:35 PM
WKYeti's Avatar
Member
My Jeep: 2005 4.7L WK
 
Join Date: Feb 2013
Location: Indianapolis
Posts: 76
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 625
WKYeti is on a distinguished road
Garage
You have to hook up AFTER the factory amp. I had this exact same problem. Your amp actually controls the volume, not your HU.
__________________
Reply With Quote
  #6  
Old 04-18-2013, 10:11 AM
Member
My Jeep: 2007 4.7L WK
 
Join Date: Oct 2012
Location: OKC
Posts: 73
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 733
meistro is on a distinguished road
Re: Did something wrong...

exactly what WKYETI said. After the amp is where you gotta hook them up.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there something wrong with my AC? ChiefNWA Grand Cherokee - WJ 8 05-05-2012 12:46 PM
Something wrong? ChiefNWA Troubleshooting/Problems 4 10-23-2011 06:33 AM
What's wrong? HELP Crestwood1001 Grand Cherokee - WK 11 06-20-2011 10:23 PM
thermometer wrong? THA06 Troubleshooting/Problems Discussion 1 12-11-2010 03:27 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:07 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community