Go Back   Jeep Garage - Jeep Forum > Modifications & Enhancements > Audio, Video, Navigation & Electronic Modifications

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-31-2009, 04:02 AM
Member
 
Join Date: Jun 2009
Location: Vancouver BC Canada
Posts: 404
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2446
pkang21 has a reputation beyond reputepkang21 has a reputation beyond reputepkang21 has a reputation beyond repute
license plate lights not working :(

okay i thought the bulbs were burnt out so i replaced them with LEDs
but they still dont work! so what should i do?? is there a way to fix this?


already tried the flipping the LED 180 degrees and inserting it.. still no luck.

and regretting so much that i got Eurodezign bulbs, they overheated in less than 5 min and melted a bit of my housing, but not much damage.
Are the silverstar ultras any good? no over heating?? because i noticed my OEMs were sylvania or w.e. its called.
__________________

__________________
Reply With Quote
  #2  
Old 07-31-2009, 06:50 AM
Member
 
Join Date: Jun 2009
Location: Columbus,NJ
Posts: 222
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2253
saleen032 has a reputation beyond reputesaleen032 has a reputation beyond repute
Send a message via AIM to saleen032
Re: license plate lights not working :(

check all your fuses first....it none are blown, then its time to do some wire inspections...
__________________

__________________
Reply With Quote
  #3  
Old 07-31-2009, 07:10 AM
Hitchhiking
 
Join Date: Jun 2009
Location: CT
Posts: 572
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
LO.7 has a spectacular aura about
Re: license plate lights not working :(

The eurodesign bulbs are complete garbage. They are about double the wattage as stock bulbs. I think they run 100w, which is way too much for a stock harness.

Don't waste your money on silverstar ultras, they crap out after less than a year. Spend a little extra dough and get yourself a nice HID kit.
__________________
Reply With Quote
  #4  
Old 07-31-2009, 08:42 AM
White WK Swagga's Avatar
Senior Member
My Jeep: 2009 3.7L WK
 
Join Date: May 2009
Location: East WishAN*ggaWoods, NY
Posts: 14,384
Thanks: 8
Thanked 5 Times in 5 Posts
Rep Power: 16635
White WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond repute
Re: license plate lights not working :(

Bro you have projectors.. GET XENON HID"S!!! I can't stress to you how much better the light output is going to be...
__________________
The fallen......

09 WK Limited, 3.7 w/ Nav (MYGIG) W/ ipod, Single Kicker 12" CVX sub-ZX750 amp, 20" chrome SRT reps,front & reat SRT sway bars, V-LED interior & license plate, LED cargo light, Dual LED turn bulbs, painted headlight reflector covers, 5k HID lows, 3.5k/5k fogs, K&N Drop in filter, Shorty antenna, Tinted Tails & 3rd brake light, debadged.....
Reply With Quote
  #5  
Old 07-31-2009, 08:22 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,419
Thanks: 55
Thanked 133 Times in 115 Posts
Rep Power: 542705
robpp has disabled reputation
Re: license plate lights not working :(

paul i have a spare harness for the rear handle as I bought a painted one.

that is if you find it burned a wire or got ruined somehow.
__________________
Reply With Quote
  #6  
Old 08-01-2009, 10:32 AM
Member
 
Join Date: Jun 2009
Location: Vancouver BC Canada
Posts: 404
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2446
pkang21 has a reputation beyond reputepkang21 has a reputation beyond reputepkang21 has a reputation beyond repute
Re: license plate lights not working :(

k i m gonna go get it checked.... so frustrating
yeah i'll save up for HIDs
__________________
Reply With Quote
  #7  
Old 08-02-2009, 02:27 AM
Member
 
Join Date: Jun 2009
Location: Vancouver BC Canada
Posts: 404
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2446
pkang21 has a reputation beyond reputepkang21 has a reputation beyond reputepkang21 has a reputation beyond repute
Re: license plate lights not working :(

one question tho,
arent sylvania's OEM lights? so wouldnt it be an ok xenon bulb or do they just suck badly?
and
if i do get H.I.D.s what should i look for? like main thing i have to watch out and stuff because i wanna get it locally.

---------- Post added at 12:27 AM ---------- Previous post was at 12:23 AM ----------

http://vancouver.en.craigslist.ca/pts/1256524994.html ?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
License Plate Matteo Grand Cherokee - WK 11 07-17-2009 06:21 PM
Retractable License Plate Holder TeamCherokee06 Visual Modifications 29 06-11-2009 03:59 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.