Go Back   Jeep Garage - Jeep Forum > Modifications & Enhancements > Audio, Video, Navigation & Electronic Modifications

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-27-2011, 03:48 PM
nickdemarchis's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Oct 2010
Location: Long Island NY
Posts: 154
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1427
nickdemarchis is on a distinguished road
new radio problem

aright so i took out my factory radio i bought a new pioneer single-din and i went to install it and my dumbass self touched a wire to something and it sparked.... so i deff blew a fuse because i cant get power to either my new radio or the old factory radio.... i checked every single fuse inside and under the hood switched the ones that were blown but still no power..... anyone know how to help me? or atleast tell me whats wrong with it off the top of your head.... also i went to a stereo place and the guy said i could have "major" problems anyone know what problems could arise from this?
__________________

__________________
Reply With Quote
  #2  
Old 09-07-2011, 12:16 AM
New Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
yankees42 is on a distinguished road
Re: new radio problem

i just did the same thing in my 05 limited. Did you find a way to fix the problem?
__________________

__________________
Reply With Quote
  #3  
Old 09-07-2011, 10:19 AM
nickdemarchis's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Oct 2010
Location: Long Island NY
Posts: 154
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1427
nickdemarchis is on a distinguished road
Re: new radio problem

Quote:
Originally Posted by yankees42 View Post
i just did the same thing in my 05 limited. Did you find a way to fix the problem?
i wound up blowing a fuse like the one i didnt check lol so i have power back to my old factory radio but the harness the guy gave me at bestbuy was the wrong one so i had to run switched power from the 12 volt cig lighter...tried that got power but head unit still doesnt work im going to get a new harness as soon as i can hopefully i get this fixed soon cause im tired of listening to the same cd's over and over again
__________________
Reply With Quote
  #4  
Old 09-07-2011, 12:00 PM
New Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
yankees42 is on a distinguished road
Re: new radio problem

Yeah I got the wrong wiring harness too from best buy, i ended up getting the right one from crutchfield. Do you remember what fuse was blown by any chance?
__________________
Reply With Quote
  #5  
Old 09-07-2011, 12:28 PM
SvenskaJeepGuy's Avatar
Let's Roll
My Jeep: 2006 4.7L WK
 
Join Date: Dec 2009
Location: Scranton PA
Posts: 13,068
Thanks: 137
Thanked 159 Times in 149 Posts
Rep Power: 1255206
SvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond repute
Garage
Re: new radio problem

That is why you are supposed to disconnect the battery before working on electronics
__________________
Reply With Quote
  #6  
Old 09-07-2011, 01:40 PM
JMLoughrey's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Aug 2011
Location: Farmington, CT
Posts: 520
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 72844
JMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond repute
Re: new radio problem

Do any other functions in the vehicle not work properly? Cig plug? Dome light?

What harness did you get? You should have either a Metra XSVI 6502-nav or XSVI6502. If you have anything other then those parts (or the scosche equivalent) it will not work without running an ACC lead from the Left hand cig plug. You're factory deck is turned on an off by data, not 12V.
__________________
Reply With Quote
  #7  
Old 09-08-2011, 01:33 PM
nickdemarchis's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Oct 2010
Location: Long Island NY
Posts: 154
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1427
nickdemarchis is on a distinguished road
Re: new radio problem

i dont remember what fuse i blew my bad but im planning on picking up the right harness from crutchfield cause it kills me to see my dash still taken apart about a month later
__________________
Reply With Quote
  #8  
Old 09-10-2011, 05:01 PM
New Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
yankees42 is on a distinguished road
Re: new radio problem

Yeah everything else is working in my jeep except for the cd player. I believe I checked all the fuses and they all were ok. My stock cd player and my aftermarket one will not turn on
__________________
Reply With Quote
  #9  
Old 09-12-2011, 10:16 AM
JMLoughrey's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Aug 2011
Location: Farmington, CT
Posts: 520
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 72844
JMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond repute
Re: new radio problem

Quote:
Originally Posted by yankees42 View Post
Yeah everything else is working in my jeep except for the cd player. I believe I checked all the fuses and they all were ok. My stock cd player and my aftermarket one will not turn on
Do you have constant 12v coming into the deck? If so, since the radio/aftermarket radio module are turned on with data, you may just want to grab acc at the left hand cig plug to run to your deck, simple solution to probably a bitch of a problem.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio Presets Problem jmp42 Trouble Shooting/Problems/Service 3 05-31-2011 03:46 PM
2008 Nav Radio Problem JimmyNock Grand Cherokee - WK 11 05-07-2011 04:30 PM
2003 overland radio/gps steering wheel wiring problem afpe45 Audio/Visual/Navigation 7 10-15-2010 01:38 PM
adding satellite radio and ipod/aux to RAQ radio fasteddy001 Audio, Video, Navigation & Electronic Modifications 3 02-20-2010 02:43 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:01 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community