Go Back   Jeep Garage - Jeep Forum > Modifications & Enhancements > Audio, Video, Navigation & Electronic Modifications

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-29-2010, 08:44 AM
trebliw's Avatar
Member
 
Join Date: Mar 2010
Location: The D
Posts: 304
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1903
trebliw is on a distinguished road
Angry REC problem- no sound!

Hi all,

I am having problems with my REC. All the functions work except I have ABSOLUTELY NO AUDIO. I checked the fuse for the AMP and it was fine. I removed my radio, checked all the connections, and they were all secured. I removed my negative cable and left it for 15 minutes in hopes that somehow the problem would be resolved after a good powerfail. NO SUCCESS! Does anyone know a trick to resolve this or has anyone ever run into this before? How do I test to see if it's the radio that has lost the ability push out sound or if it's the amp that is bad? Thank you very much in advance for any assistance that you can offer!

Wil
__________________

__________________
[SIGPIC][/SIGPIC]
Trebliw aka the newbie
2007 Jeep Grand Cherokee
57 Limited 4X4
Reply With Quote
  #2  
Old 09-29-2010, 11:15 AM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12321
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: REC problem- no sound!

Ok did you connect any kind of IPAC adapter to the REC? If so then you might want to reverse the connections to the IPAC try one of the cables that is not attached and replace it with the one that is attached ... kind of hard to explain but you get the point

if you dont have the IPAC check the connections one more time just to be sure. Is the head unit working? Does power show on the amp?
__________________

__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #3  
Old 09-29-2010, 12:02 PM
trebliw's Avatar
Member
 
Join Date: Mar 2010
Location: The D
Posts: 304
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1903
trebliw is on a distinguished road
Re: REC problem- no sound!

Hey BonioMario,

No IPAC, just stock. I haven't gotten a chance to take the panels off yet to check the AMP. However, everything on the HU is working. I just don't have any sound coming out of all speakers, from level 1 to level 38 no audio whatsoever. I am so frustrated... There were no tell-tale signs. Just got up for work, got in the car, and then no sound. Does the AMP drive all the audio? Meaning that if the AMP is dead then there's no audio all? Is that how it's set up? I know in my previous vehicles all my speakers were hooked up to two AMPS and if I overloaded them then I wouldn't get any sound until they were reset. Thanks for the info though! I appreciate it greatly.
__________________
[SIGPIC][/SIGPIC]
Trebliw aka the newbie
2007 Jeep Grand Cherokee
57 Limited 4X4
Reply With Quote
  #4  
Old 09-29-2010, 12:40 PM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12321
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: REC problem- no sound!

seems like you might have the BA amp to power those speakers ... the amp is located in the left rear cargo area underneath all that plastic crap ...

That is strange though, what you might want to check is the fuse i know it's a long shot but will not hurt to at least try that, and disconnect all battery, negative and positive let is sit overnight complete reset and try again see if that works at all ...
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
new sound system hafalex Audio, Video, Navigation & Electronic Modifications 13 04-16-2010 07:40 AM
My REC problems! HemiPower Grand Cherokee - WK 1 03-11-2010 04:47 PM
How good is the REC nav reciever for sound quality? bulldogger Grand Cherokee - WK 5 12-14-2009 04:21 PM
Premium Sound in 05 WK jcostri09 Audio, Video, Navigation & Electronic Modifications 10 10-16-2009 11:52 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:42 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community