Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-21-2012, 09:08 AM
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Aug 2012
Location: Kingwood, Tx
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 779
alphamag is on a distinguished road
Got 'er done

Well I finally got my tranny fluid and filters changed on my 04 WJ 4.7 2WD over a period of two days and about sixteen hours. Hey...I'm old and slow. Transmission is very smooth and no codes ( if that means anything ). I may have a small gasket leak but I may just put down cardboard until I recuperate from this first go at it. If it is in fact leaking I'll try it again. My sincere gratitude to this forum in general and to especially to Frango, cheapjeep, and stashgto for all your assistance.
__________________

__________________
Reply With Quote
  #2  
Old 10-21-2012, 09:39 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,908
Thanks: 9
Thanked 92 Times in 87 Posts
Rep Power: 525859
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Got 'er done

Did you use a prefab gasket or the RTV? I have bad experiences with the gaskets and, eventhough its a bit more work (especially to remove the RTV the next time), i only use RTV now. You could try and fasten the bolts a bit more to stop the leak, but don't overtighten them.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 10-21-2012, 12:07 PM
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Aug 2012
Location: Kingwood, Tx
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 779
alphamag is on a distinguished road
Re: Got 'er done

Thanks Frango, I used a prefab and upon further inspection it is leaking more than I thought. I tightened the bolts a small amount at the leak site. I will check again later and see...fingers crossed.
__________________
Reply With Quote
  #4  
Old 10-21-2012, 03:19 PM
stashgto's Avatar
Member
My Jeep: 2008 3.7L WK
 
Join Date: May 2012
Location: Staten Island N.Y.
Posts: 720
Thanks: 0
Thanked 18 Times in 18 Posts
Rep Power: 109986
stashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond repute
Re: Got 'er done

Sometimes old, deliberate, patient,and slow is better than young, rushed, haphazard,and quick hopefully you're leak free now.
__________________
Reply With Quote
  #5  
Old 10-21-2012, 08:52 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 1997 2.5L TJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,103
Thanks: 97
Thanked 68 Times in 64 Posts
Rep Power: 331920
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: Got 'er done

Quote:
Originally Posted by alphamag View Post
Thanks Frango, I used a prefab and upon further inspection it is leaking more than I thought. I tightened the bolts a small amount at the leak site. I will check again later and see...fingers crossed.
Best thing you can do is throw that gasket away and use a good rtv
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #6  
Old 10-21-2012, 08:57 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 1997 2.5L TJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,103
Thanks: 97
Thanked 68 Times in 64 Posts
Rep Power: 331920
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: Got 'er done

Quote:
Originally Posted by alphamag View Post
Well I finally got my tranny fluid and filters changed on my 04 WJ 4.7 2WD over a period of two days and about sixteen hours. Hey...I'm old and slow. Transmission is very smooth and no codes ( if that means anything ). I may have a small gasket leak but I may just put down cardboard until I recuperate from this first go at it. If it is in fact leaking I'll try it again. My sincere gratitude to this forum in general and to especially to Frango, cheapjeep, and stashgto for all your assistance.
I remember the first year with my ZJ when I couldn't even pick my nose right
__________________

__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community