Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-31-2012, 04:47 AM
Member
 
Join Date: Oct 2012
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 745
bicdaddy is on a distinguished road
So I just adopted my wife's 02' WJ limited

I've been working on it for the past two years replacing worn parts bit by bit. She recently got a job that requires her to travel more than I do, so she's going to be driving my Optima turbo, and I get the 11 year old jeep. Anyway, the things in great shape, but there are a few issues I'm still trying to get through to consider this thing reliable.

First there's a squeak... you know like a worn bearing. Anyway, I've replaced 3 of 4 wheel bearings, and the front driveshaft U joint... and it's still there. I'll be replacing the fourth bearing in a week or so when it's delivered. If that's not it, I'm going to guess it's a rear U joint. It's just hard to listen to the noise while driving to pin point it.

Second - the left turn blinker will sometimes just stop working. It doesn't stay that way too long, but it's dangerous and annoying. (any ideas here would be great)

Third - changed the tranny fluid at 130k (guessing it's the only time so far), and now it slips from 1-2nd when turning and accelerating.

Forth - Drivers side heated seat doesn't work... I've googled this and come up with many hits on it so hopefully I can dig into it a bit more soon (before winter if I can help it).

And my last issue is a bad airbag sensor... I'm hoping it won't be too expensive to fix.

The next few things I'll be doing (other than these repairs) is replacing the dated head unit (factory nav w/ infinity amp), and probably plasti dipping the wheels and grill.

Any input on my issues would be greatly appreciated!

Bic
__________________

__________________
Reply With Quote
  #2  
Old 10-31-2012, 09:37 AM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,805
Thanks: 37
Thanked 62 Times in 61 Posts
Rep Power: 54383
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: So I just adopted my wife's 02' WJ limited

Sounds like an 11 year old vehicle, I'm having some similar problems on my 2001. Let me know if you figure out that bearing squeak, I'm having a similar thing on mine, I tried putting it on jacks and having a friend spin the tire, but it wouldn't squeak. Must be because its not loaded like it is on the ground.

Did you change out the tranny fluid? If so did you replace the filters and make sure that the gasket was installed in the inlet and not on the end of the filter? (I'm assuming since you say its a limited that you have the V8 with 45rfe transmission). Also, was the fluid fairly clean or was there some dark or metallic particles in the old fluid?

For the left blinker, I would start checking wiring. If its intermittent like that I would tend to think there is a damaged wire somewhere.

If you search the forum for heated seat problems you should be able to find some pointers on figuring out what the problem is there.

Good luck with everything! gotta love trying to keep up an 11 year old vehicle.
__________________

__________________
Aaron

My Jeep: 2001 Grand Cherokee Limited, 245/65R17 Falken Rocky Mountain ATS, K&N drop in air filter, Bilstein HD's. De-badged, eagle-eye LED Tails & LED 3rd brake light, Addco front and rear sway bars, Superchips tuned & TM snip, interior 6k LED's, Gen3 ccfl projectors with Volt 6k HID lows, akebono brake upgrade with R1 Concepts premium rotors.
Reply With Quote
  #3  
Old 10-31-2012, 04:22 PM
Trav1s's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Apr 2012
Location: Cedar Rapids, IA
Posts: 750
Thanks: 23
Thanked 20 Times in 19 Posts
Rep Power: 1769
Trav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond repute
Garage
Re: So I just adopted my wife's 02' WJ limited

Welcome!

01grand (aka Aaron) gave you some great suggestions. I would also suggest a simple bulb change if the bulb in question as a metal base. If there is poor contact a bulb can work intermittently.

As for the wheel bearing issue, I have not dealt with that on my WJ.

Transmission - Did you use the correct fluid and a Mopar filter? If you do have the 4.7/45rfe then that is a must. My dad owns a small town service station and they use nothing but Mopar filters (there are two in the pan of the 45rfe).

The head unit is an easy swap. Get the harness adapter and antenna adapter to make it a simple plug-n-play swap. I just did this with my WJ this morning. Between the radio installation kit, wiring harness and antenna adapter I have $20 in it.

BTW-- I have an extra antenna adapter since I accidentally ordered two. It is not worth trying to return it. Let me know if you are interested.
__________________
2004 Columbia Edition WJ 4.7 HO
RB4/Moog HD Steering Stabilizer/PML trans pan 10304/ Autometer trans temp and oil pressure gauge/UpCountry springs & OME 10MM Spacers/Bilstein shocks/Rubicon Moabs/255/65r17 Cooper Discoverer AT3/Factory chrome tow hooks/Mopar hitch & a loose nut behind the wheel
Reply With Quote
  #4  
Old 10-31-2012, 08:05 PM
TJXJWJ's Avatar
The "pre" SRT 8
My Jeep: 2004 4.7 HO WJ
 
Join Date: Jun 2010
Location: Aurora, OH
Posts: 3,506
Thanks: 202
Thanked 82 Times in 70 Posts
Rep Power: 286898
TJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond repute
Garage
Re: So I just adopted my wife's 02' WJ limited

Put that stock radio up for sale on the forum here when you're done with it...believe it or not, people are always looking for the OEM nav unit.

That heated seat issue might not be so bad. A lot of times an element just breaks from being flexed over and over from it being sat on. Another option (if you haven't already) is have your dealer run the VIN. They might replace them for free since the originals were recalled. They won't get as hot as the originals from what I hear, but the dealer will replace both for free if yours haven't been replaced yet under the recall.
__________________
Tony-04 Limited HO, DkKhaki w/tan leather int. All LED lighting, 5000k Xtreme HID projs. (deambered)&fogs w/CCFL rings, tinted tails&3rd LED brake lt, fnt glass tinted to match, shawty antenna, 6 Polk speakers, K&N FIPK, FR 70mm TB, TCM#10 snip, Flashpaq'ed on 91 tune, Bilstien HD's, Addcos, polished 20" SRT reps, Hankook Ventus Evos (255-45), Weathertech mats, EBC USR rotors, EBC Greenstuff pads, Magnaflow muffler, RB1 Nav w/iPod kit, de-badged, roof rack delete.
09 Liberty KK Rocky Mountain Edition. Added Mopar Remote Start kit, Weathertech Mats, K&N drop-in.
PAST JEEPS : 99 TJ Sport, 98 XJ Sport, 06 WK Laredo
Reply With Quote
  #5  
Old 10-31-2012, 09:21 PM
Member
 
Join Date: Oct 2012
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 745
bicdaddy is on a distinguished road
Re: So I just adopted my wife's 02' WJ limited

Thanks for the replies gents! The heated seat maybe a bit more than just an element... I've checked the fuse box, but the reason I'm saying it's more is because the 12v acc right below the rocker switch doesn't work either... maybe I need to check my fuses again.

Transmission: I did use the proper fluid for the tranny, and I was careful with the new filter (I believe the gasket and o-ring are installed correctly). I have the 4.0 (not sure what the model of the tranny is) with 135k on the drivetrain.

I have another question... the transfer case fluid, to my knowledge, has never been changed. I did go to the jeep dealer and bought the right fluid, but I'm hesitating on the fluid change because I'm afraid I may develop a seal leak afterwards.
__________________
Reply With Quote
  #6  
Old 11-01-2012, 08:38 AM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,805
Thanks: 37
Thanked 62 Times in 61 Posts
Rep Power: 54383
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: So I just adopted my wife's 02' WJ limited

Ok, if you have the 4.0L engine you have the 42re tranny, which is a totally different beast than the V8 tranny. There is only one filter there and no special instructions on installation that I know of. As long as you used ATF+4 you are in good shape there.

As for the transfer case, I'm not sure which one you have but they are all similar on drain and refill. Start by pulling the fill plug (trust me on doing this first, it sucks to drain it then find out the fill plug is frozen in place). Then pull the drain, then close her up and fill it back up. Maybe flush a little fresh fluid through while its draining to make sure you get the old stuff out. Then fill it up and you are good to go! I've never had or heard of a problem with fresh fluid causing a seal leak in the transfer case.

Good luck chasing the electrical gremlin, those kind of problems are by far my least favorite to try and figure out.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
guys, my wife saw this need help dsemtff Troubleshooting/Problems 6 08-16-2012 03:24 PM
My wife Wk2 diesel limited WK2Diesel Members Rides-Showoff 6 05-07-2012 08:14 PM
Added 20" chrome Mopar wheels and Summit grille to the wife's Limited HemiHog Interior/Exterior/Visual 10 02-22-2012 05:17 AM
My Wife's getting into it too... BJB Other Rides 25 11-16-2011 04:28 AM
My Wife's 2011 Limited vs. My 2010 SRT8 SMG1 Grand Cherokee - WK2 - 20 10-04-2010 01:03 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.