Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-15-2014, 05:02 PM
Member
 
Join Date: Feb 2014
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 273
wootdiddy is on a distinguished road
Angry transmission solenoid pack problems

ok i a 2000 jeep grand cherokee 4.7 with the 45fre. i have recently had transmission troubles that lead to me having to change out the transmissionn solenoid pack and it worked great for a about a day and now it goes in and out of limp mode at random times. sometimes i start it and it will go fine and others just limp mode. i did use the white plug pack on replace ment and a new bracket that should work said it worked for 45fre or 545fre. i got my pack form quality transmission parts in tampa florida. it is a used one though it was going to be a refurb. so does anyone know what i should do?
__________________

__________________
Reply With Quote
  #2  
Old 02-15-2014, 07:30 PM
hoffmanestates's Avatar
Senior Member
 
Join Date: Nov 2011
Posts: 1,024
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2409
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
I'm having torque converter lock in issue, find a used 545rfe and slap it in.

Sent from my LG-P999 using Tapatalk 2
__________________

__________________
Reply With Quote
  #3  
Old 02-15-2014, 07:36 PM
Member
 
Join Date: Feb 2014
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 273
wootdiddy is on a distinguished road
I was a qaurt and a half low on fluid. The guy at the parts store I use told me it held 5 quarts. When its really around 6.5. I have not been on level ground to check it. So maybe that's the end of my issue. Hopefully.
__________________
Reply With Quote
  #4  
Old 02-15-2014, 07:49 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,970
Thanks: 9
Thanked 93 Times in 88 Posts
Rep Power: 525932
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: transmission solenoid pack problems

The transmission system holds 13 qts in total, but when you lower the pan you will only get around 6 qts out of it, the rest is inside the torque converter and lines.
When the transmission goes into limp mode, you should have a "check engine" light with the P0700 general transmission code. You need to get the TCM scanned to know what failure it has stored.
Best is to check the fluid level with the transmission at operating temperature. A too low level can indeed give strange behaviour.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 02-15-2014, 07:54 PM
Member
 
Join Date: Feb 2014
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 273
wootdiddy is on a distinguished road
Quote:
Originally Posted by Frango100 View Post
The transmission system holds 13 qts in total, but when you lower the pan you will only get around 6 qts out of it, the rest is inside the torque converter and lines.
When the transmission goes into limp mode, you should have a "check engine" light with the P0700 general transmission code. You need to get the TCM scanned to know what failure it has stored.
Best is to check the fluid level with the transmission at operating temperature. A too low level can indeed give strange behaviour.
Yea its not in limp mode any more but check light is on and when I tried getting it read last time it was just like this it didn't throw any codes. And I live on a pretty rough road and after hitting a lot of potholes it went into limp mode or after I was parked on a hill for awhile that's why I think it may be the fluid level.
__________________
Reply With Quote
  #6  
Old 02-15-2014, 08:00 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,970
Thanks: 9
Thanked 93 Times in 88 Posts
Rep Power: 525932
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: transmission solenoid pack problems

Yeah, top off the fluid at the max level and try again. Let us know if it solved the problem, or otherwise we see where we go from there. Did you have any failure codes before, that made you decide to change the solenoid pack?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 02-15-2014, 08:04 PM
Member
 
Join Date: Feb 2014
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 273
wootdiddy is on a distinguished road
Yeah I know it threw the general p0700 then a scan said it was the solenoid failed and it lead to the pack. Before I change the pack it would come out of limp mode at all.
__________________
Reply With Quote
  #8  
Old 02-15-2014, 08:39 PM
Member
 
Join Date: Feb 2014
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 273
wootdiddy is on a distinguished road
Just went to a gas station. About 15 miles from my house on the way there it was in limp mode on the way back it was great. Ha I'm not real happy with electric transmissions ha
__________________
Reply With Quote
  #9  
Old 02-15-2014, 09:27 PM
Member
 
Join Date: Feb 2014
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 273
wootdiddy is on a distinguished road
Should I look at input/output sensors? Also the original codes it was throwing after I changed the pack before clearing them were p0750 p1768 and p 1781
__________________
Reply With Quote
  #10  
Old 02-15-2014, 10:06 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,970
Thanks: 9
Thanked 93 Times in 88 Posts
Rep Power: 525932
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: transmission solenoid pack problems

Did you fill the transmission already and it still goes into limp mode?
The P0750 code was indeed pointing towards the solenoid block, since this code is for the L/R solenoid (low/reverse). The P1786 is the pressure switch for the L/R clutch, which probably was caused by the failing L/R solenoid.
The P1768 is a " Transmission control relay off" code. This is a normal code when the TCM switches the transmission in limp mode. The TCM just removes the power to the relay.
If you still have the problem, then you should start with checking the fault codes again, before changing any more parts.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #11  
Old 02-15-2014, 10:15 PM
Member
 
Join Date: Feb 2014
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 273
wootdiddy is on a distinguished road
Yea going to get it scanned again tommorow if it acts up hopefully I can catch whatever it is. Really weird that it won't show codes when running properly but engine light is on. It may have been there scan tool.
__________________
Reply With Quote
  #12  
Old 02-15-2014, 10:16 PM
Member
 
Join Date: Feb 2014
Posts: 43
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 273
wootdiddy is on a distinguished road
Yes that was after I topped it off I'm going to check fluid levels again.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission problems Nhoc6131 2014+ Cherokee-KL 38 04-25-2014 08:38 PM
Transmission Problems Knutter Grand Cherokee - WK 0 12-08-2013 02:29 AM
Transmission problems: Please help! ashenmorality Trouble Shooting/Problems/Service 9 07-09-2013 01:37 PM
Transmission problems Christine.Bachtell Troubleshooting/Problems 6 06-30-2013 08:42 PM
Red Eagle Power Pack - Transmission Rebuild 555ctsv Grand Cherokee - WK 11 01-21-2010 04:52 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community