Go Back   Jeep Garage - Jeep Forum > Modifications & Enhancements > Visual Modifications

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-27-2011, 05:56 AM
Geevis's Avatar
Member
My Jeep: 2006 3.7L WK
 
Join Date: Apr 2010
Location: CT
Posts: 532
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 2101
Geevis is a jewel in the rough
HID Failure

Does anyone know what would cause my passenger side low beam and fog light HIDs to both go out at the same time?

Last night I noticed that they were both out, but it was too dark to poke around under the hood to take a look.. This morning I tried turning them on again before work and the low beam fired up, but the fog is still out..

Could this be some kind of issue with the relays (which I have on both low's and fogs), or more of an issue of a loose ground?

Thanks for any light you can shed on this issue (no pun intended).
__________________

__________________
Reply With Quote
  #2  
Old 04-27-2011, 09:40 AM
CPT2010's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: New Orleans
Posts: 1,198
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2792
CPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond repute
Re: HID Failure

Sometimes your ballast is bad. happened to me. i think a short happened and torched my low beam ballast.
as far as the fogs. when i had them on the relay they would go out. when they werent on a relay they were fine.

just remember if you run it without a relay you have to switch the ballast the other way on the bulb(switches polarity) positive would be negative and vice versa
__________________

__________________
2005 WK 5.7 Limited / AFE CAI / Powerstick exhaust / predator tuned / Gloss black viper rims / Tinted tails / 6K lows and fogs / SRT8 front bumper / custom side rails ;) / 5% tint all around / Custom stereo / pioneer 4300dvd / neon accent lighting / Green/white halo's

Coming soon- 180 thermostat./ or a jeep srt8

Reply With Quote
  #3  
Old 04-27-2011, 09:44 AM
B.P.O.D's Avatar
RockNrolla/JG Founder

My Jeep: 2008 3.7L WK
 
Join Date: May 2009
Location: Bergen County, NJ / Bushkill, PA
Posts: 14,644
Thanks: 3
Thanked 9 Times in 8 Posts
Rep Power: 16648
B.P.O.D has disabled reputation
Send a message via AIM to B.P.O.D
Re: HID Failure

could be ballast,bulb, ground,fuse in relay... def try checking fuse in relay first,swapping bulbs second,then ballasts,ground
__________________
Irfan "Showing off is the fool's idea of glory."
can you beat me in a fight??? http://dreamps.mybrute.com
member of Black, Tri-State, 6 cylinder club 08 Brilliant Black Laredo (JG 3.7L Squad)- k+n 63-1545,magnaflow 10436,mygig(ren), HID's 6k lows, 6k+3k fogs,dual turn leds,led brows,v-led interior leds, cargo led strip, reverse hids, 92 led brake lights, tinted tails,custom powder coated mesh grill, srt sways, 15% tinted windows,illuminated visors,shorty antenna, HH Class III, cargo liner, thule snowboard rack,kayak rack, bike rack

Future mods - color matched side mirrors, black srt reps

My 1-step correction writeup

How To - LED BROW

Reply With Quote
  #4  
Old 04-27-2011, 09:49 AM
Geevis's Avatar
Member
My Jeep: 2006 3.7L WK
 
Join Date: Apr 2010
Location: CT
Posts: 532
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 2101
Geevis is a jewel in the rough
Re: HID Failure

Thanks guys.. I'm going to take a closer look this evening, but I think it must be a loose ground on the passenger side, bc my low beam fired up this morning after it wasn't working last night, and the fog still did not turn on.. I'll try that first and then see if I can swap out the relays from the other side to see if they work then.
__________________

2006 Jeep Grand Cherokee 3.7l V6 - Sold
Reply With Quote
  #5  
Old 04-27-2011, 09:56 AM
B.P.O.D's Avatar
RockNrolla/JG Founder

My Jeep: 2008 3.7L WK
 
Join Date: May 2009
Location: Bergen County, NJ / Bushkill, PA
Posts: 14,644
Thanks: 3
Thanked 9 Times in 8 Posts
Rep Power: 16648
B.P.O.D has disabled reputation
Send a message via AIM to B.P.O.D
Re: HID Failure

yeah bro hopefully its just that. no reason to buy new kits yet!
__________________
Irfan "Showing off is the fool's idea of glory."
can you beat me in a fight??? http://dreamps.mybrute.com
member of Black, Tri-State, 6 cylinder club 08 Brilliant Black Laredo (JG 3.7L Squad)- k+n 63-1545,magnaflow 10436,mygig(ren), HID's 6k lows, 6k+3k fogs,dual turn leds,led brows,v-led interior leds, cargo led strip, reverse hids, 92 led brake lights, tinted tails,custom powder coated mesh grill, srt sways, 15% tinted windows,illuminated visors,shorty antenna, HH Class III, cargo liner, thule snowboard rack,kayak rack, bike rack

Future mods - color matched side mirrors, black srt reps

My 1-step correction writeup

How To - LED BROW

Reply With Quote
  #6  
Old 04-27-2011, 10:53 AM
White Chocolate's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2009
Location: Saskatoon, Saskatchewan, Canada
Posts: 8,336
Thanks: 8
Thanked 8 Times in 8 Posts
Rep Power: 0
White Chocolate is an unknown quantity at this point
Re: HID Failure

Sounds like a ground issue. Are both grounds located at the same spot?
__________________
Reply With Quote
  #7  
Old 04-27-2011, 01:04 PM
Premium Member
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2010
Location: Edmonton Alberta
Posts: 119
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1796
dcjeepgc is on a distinguished road
Re: HID Failure

95% of the problems with HIDs are either the ground or the relays!
__________________
2005 Deep Beryl Green WK 5.7L Hemi: QD II/ SRT8 shifter, petals, roof rails, wheels, grille, rear Brembo calipers, rear sway bar and springs/ body color mirror covers/ Xtreme HID 4300 Dims and Fogs/ Cabin Filteration Kit/ shorty antenna/ SC Flashpaq 91 tune/ full LED interior and partial exterior/ BWoody 4" CAI/Stillen headlight covers/ partial de-badging/ My GIG w Lockpick/ 22Elite leather console cover. Mods to come in the Spring: WK bilsteins, SRT springs, Bwoody end links and Brembo calipers for the front.
Reply With Quote
  #8  
Old 04-27-2011, 01:08 PM
SvenskaJeepGuy's Avatar
Let's Roll
My Jeep: 2005 4.7L WK
 
Join Date: Dec 2009
Location: Scranton PA
Posts: 13,088
Thanks: 140
Thanked 163 Times in 153 Posts
Rep Power: 1255329
SvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond repute
Garage
Re: HID Failure

where did you put your grounds?
__________________
Reply With Quote
  #9  
Old 04-27-2011, 01:31 PM
Geevis's Avatar
Member
My Jeep: 2006 3.7L WK
 
Join Date: Apr 2010
Location: CT
Posts: 532
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 2101
Geevis is a jewel in the rough
Re: HID Failure

Quote:
Originally Posted by White Chocolate View Post
Sounds like a ground issue. Are both grounds located at the same spot?
I have both grounds going to the same spot on the inner fender. I'm thinking they became loose, bc the low beam worked this morning after not working last night.. I'll take a closer look after work if I have some time.

Quote:
Originally Posted by dcjeepgc View Post
95% of the problems with HIDs are either the ground or the relays!
I know, I'm almost positive my issue is either relay or ground related. They've lasted over 2 years w/o any issues, so I was surprised last night to say the least.

Quote:
Originally Posted by SvenskaJeepGuy View Post
where did you put your grounds?
Inner fender on both sides.. I'm going to re-tighten the passenger side tonight and see if that works.

Thanks for all of the help!!!
__________________

2006 Jeep Grand Cherokee 3.7l V6 - Sold
Reply With Quote
  #10  
Old 04-27-2011, 01:45 PM
B.P.O.D's Avatar
RockNrolla/JG Founder

My Jeep: 2008 3.7L WK
 
Join Date: May 2009
Location: Bergen County, NJ / Bushkill, PA
Posts: 14,644
Thanks: 3
Thanked 9 Times in 8 Posts
Rep Power: 16648
B.P.O.D has disabled reputation
Send a message via AIM to B.P.O.D
Re: HID Failure

let us know!
__________________
Irfan "Showing off is the fool's idea of glory."
can you beat me in a fight??? http://dreamps.mybrute.com
member of Black, Tri-State, 6 cylinder club 08 Brilliant Black Laredo (JG 3.7L Squad)- k+n 63-1545,magnaflow 10436,mygig(ren), HID's 6k lows, 6k+3k fogs,dual turn leds,led brows,v-led interior leds, cargo led strip, reverse hids, 92 led brake lights, tinted tails,custom powder coated mesh grill, srt sways, 15% tinted windows,illuminated visors,shorty antenna, HH Class III, cargo liner, thule snowboard rack,kayak rack, bike rack

Future mods - color matched side mirrors, black srt reps

My 1-step correction writeup

How To - LED BROW

Reply With Quote
  #11  
Old 04-27-2011, 04:45 PM
Geevis's Avatar
Member
My Jeep: 2006 3.7L WK
 
Join Date: Apr 2010
Location: CT
Posts: 532
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 2101
Geevis is a jewel in the rough
Re: HID Failure

Ok, so I took a closer look when I got home tonight and I think it's my passenger side fog light ballast. When I powered them on I heard the drivers side ignite, but not the passenger side.

But that still doesn't explain why my passenger side low beam wouldn't work last night. It has ignited and worked every time I tried them today.

In any event I will start off by purchasing a new ballast and then go from there.
__________________

2006 Jeep Grand Cherokee 3.7l V6 - Sold
Reply With Quote
  #12  
Old 04-27-2011, 05:24 PM
White Chocolate's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2009
Location: Saskatoon, Saskatchewan, Canada
Posts: 8,336
Thanks: 8
Thanked 8 Times in 8 Posts
Rep Power: 0
White Chocolate is an unknown quantity at this point
Re: HID Failure

Quote:
Originally Posted by Geevis View Post
Ok, so I took a closer look when I got home tonight and I think it's my passenger side fog light ballast. When I powered them on I heard the drivers side ignite, but not the passenger side.

But that still doesn't explain why my passenger side low beam wouldn't work last night. It has ignited and worked every time I tried them today.

In any event I will start off by purchasing a new ballast and then go from there.
Check your fuses on the relay man, I had this happen, over time water moisture corrodes the fuse/ I switched my fuses and I was good to go. If thats not the issue check the actual relay box, where the switch is. I also had an issue where so much moisture got stuck in the relay box that the switch wouldnt move anymore due to a severe amount of rust inside.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Win Module Failure Steve52 Trouble Shooting/Problems/Service 16 01-26-2013 07:38 AM
Sirius h/w failure Rosewood Audio/Visual/Navigation 4 08-07-2012 08:40 AM
HID low beams = tail light failure?? rdrice28 Grand Cherokee - WK 12 04-15-2010 11:23 PM
Transmission/Radiator failure WJ_Jeep Grand Cherokee - WK 12 12-26-2009 09:44 AM
HIDs early failure/rant heehawbus Visual Modifications 22 06-23-2009 05:19 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community