Go Back   Jeep Garage - Jeep Forum > Modifications & Enhancements > Visual Modifications

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 01-11-2010, 11:13 PM
White Chocolate's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2009
Location: Saskatoon, Saskatchewan, Canada
Posts: 8,336
Thanks: 8
Thanked 8 Times in 8 Posts
Rep Power: 0
White Chocolate is an unknown quantity at this point
Re: XenonDepot Help!

well, we'll have to see what happens, if i get everything working im gunna seal everything with electrical tape, and cover the ballasts with some type of protection.
__________________

__________________
Reply With Quote
  #26  
Old 01-11-2010, 11:13 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,261
Thanks: 868
Thanked 981 Times in 693 Posts
Rep Power: 7717900
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: XenonDepot Help!

the kits are waterproof......sounds like a ground to me
__________________

__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #27  
Old 01-11-2010, 11:16 PM
White Chocolate's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2009
Location: Saskatoon, Saskatchewan, Canada
Posts: 8,336
Thanks: 8
Thanked 8 Times in 8 Posts
Rep Power: 0
White Chocolate is an unknown quantity at this point
Re: XenonDepot Help!

blahhh, scott I did everything right tho like last time, connections all to factory ground, what shud i do scott? what wud u suggest, im out of thoughts man
__________________
Reply With Quote
  #28  
Old 01-11-2010, 11:27 PM
SvenskaJeepGuy's Avatar
Let's Roll
My Jeep: 2005 4.7L WK
 
Join Date: Dec 2009
Location: Scranton PA
Posts: 13,091
Thanks: 140
Thanked 163 Times in 153 Posts
Rep Power: 1255385
SvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond repute
Garage
Re: XenonDepot Help!

i think once you sand the grounds and reattach everything you should be golden
__________________
Reply With Quote
  #29  
Old 01-11-2010, 11:48 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,261
Thanks: 868
Thanked 981 Times in 693 Posts
Rep Power: 7717900
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: XenonDepot Help!

if your sure on the grounds and checked all connections.....wait and see what Steve says
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #30  
Old 01-12-2010, 12:47 AM
White Chocolate's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2009
Location: Saskatoon, Saskatchewan, Canada
Posts: 8,336
Thanks: 8
Thanked 8 Times in 8 Posts
Rep Power: 0
White Chocolate is an unknown quantity at this point
Re: XenonDepot Help!

Yeah I'm hoping its my grounds, but I honestly feel like its the ballast, ive checked everything, tried putting different bulbs in, i just dont know what it is
__________________
Reply With Quote
  #31  
Old 01-12-2010, 07:19 AM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: St. Petersburg, FL
Posts: 2,196
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 4212
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
Re: XenonDepot Help!

How old is the kit? I'd hope it has at least like a one year warranty on it or something.
__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
  #32  
Old 01-12-2010, 10:02 AM
White WK Swagga's Avatar
Senior Member
My Jeep: 2009 3.7L WK
 
Join Date: May 2009
Location: East WishAN*ggaWoods, NY
Posts: 14,384
Thanks: 8
Thanked 5 Times in 5 Posts
Rep Power: 16568
White WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond repute
Re: XenonDepot Help!

I would say
1 - ground,
2 - There's no relay for fogs so I would look at conections. Maybe swap conections with the low HID ballast if it's close enough to see if it is the ballast thats bad...
__________________
The fallen......

09 WK Limited, 3.7 w/ Nav (MYGIG) W/ ipod, Single Kicker 12" CVX sub-ZX750 amp, 20" chrome SRT reps,front & reat SRT sway bars, V-LED interior & license plate, LED cargo light, Dual LED turn bulbs, painted headlight reflector covers, 5k HID lows, 3.5k/5k fogs, K&N Drop in filter, Shorty antenna, Tinted Tails & 3rd brake light, debadged.....
Reply With Quote
  #33  
Old 01-13-2010, 08:54 PM
White Chocolate's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2009
Location: Saskatoon, Saskatchewan, Canada
Posts: 8,336
Thanks: 8
Thanked 8 Times in 8 Posts
Rep Power: 0
White Chocolate is an unknown quantity at this point
Re: XenonDepot Help!

Alright guys, so I went to start the Jeep this morning, I got nothing once again. The fog light is out on me again. So tonight, me and my old man decided to work on it, pulled it in the garage (light was off), turned the Jeep off, checked all the grounds, sanded down the factory grounds, reconnected the grounds, checked all the wiring for the fog light, everything was ok, started the vehicle, lights turn on, turn the lights off then turn then back on, they aren't working again, So we flicker back and forth, and sometimes they turn on, somethings they turned off, well then god damnit the light stays on (this is a pain in the ass because then I can't troubleshoot).....

sooooo... I tested to check power to the ballast, yes I have power, and yes I have power after the ballast also, so I said **** this, I switched the drivers light bulb to the passenger and the passenger to the drivers, therefore, if anything happens again, I can determine if its the ballast or the bulb.

Hoping it stays proper, but I have a feeling something is gunna happen in the next couple days, Anyone else got any other ideas?
__________________
Reply With Quote
  #34  
Old 01-13-2010, 09:14 PM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: St. Petersburg, FL
Posts: 2,196
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 4212
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
Re: XenonDepot Help!

It's bad for the ballast to flick the lights on and off a lot like that.

It sounds like there is an issue with the ballast. I'd just try and get a new one under warranty. Then if that doesn't fix it who knows.

Do you have a relay for your fogs? I don't have one on mine so the only wiring is from the factory harness to the ballast, and then the ballast to the bulb.

If you currently have a relay hooked up for your fogs, maybe try removing it?
__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
  #35  
Old 01-13-2010, 09:32 PM
White Chocolate's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2009
Location: Saskatoon, Saskatchewan, Canada
Posts: 8,336
Thanks: 8
Thanked 8 Times in 8 Posts
Rep Power: 0
White Chocolate is an unknown quantity at this point
Re: XenonDepot Help!

......
Quote:
Originally Posted by LTrainGC View Post
It's bad for the ballast to flick the lights on and off a lot like that.

Yeah man I know it is, I just had to test it, didnt do it to much.

It sounds like there is an issue with the ballast. I'd just try and get a new one under warranty. Then if that doesn't fix it who knows.

I'm hoping its just the bulb, easy fix lol.

Do you have a relay for your fogs? I don't have one on mine so the only wiring is from the factory harness to the ballast, and then the ballast to the bulb.

If you currently have a relay hooked up for your fogs, maybe try removing it?
I do have a relay, but I doubt that would be the issue, at least not what from I'd read online
__________________
Reply With Quote
  #36  
Old 01-13-2010, 09:35 PM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: St. Petersburg, FL
Posts: 2,196
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 4212
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
Re: XenonDepot Help!

The ballast should be just as easy of a fix - just disconnect and remove the old one, install and reconnect the new one.

Just for shits and giggles, I would try removing the relay on the fogs to see what happens. It's known that some WK's need it for the fogs and some don't. I have a '05 as well and don't need a relay for the fogs.
__________________

__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Volt Kit - 6K Lows XenonDepot 08Hemi Member Product Reviews 38 02-11-2012 04:06 PM
XenonDepot Xtreme HID's White Chocolate Grand Cherokee - WK 159 10-16-2009 11:04 PM
My 6000K Xenondepot D1S 08-09 HID bulbs Scottina06 Visual Modifications 21 08-20-2009 11:00 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community