15 Overland gremlins - Page 3 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 05-17-2015, 10:15 PM
Premium Member
 
Join Date: Aug 2013
Location: Boston
Posts: 1,794
Thanks: 42
Thanked 213 Times in 165 Posts
Rep Power: 76854
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: 15 Overland gremlins

My guess is a bad wiring hardness/connector.
I'd check for water in all the suspect places that have been reported, just in case.
Both compartments under seats.
Under Spare Tire etc.
Just a thought. Water can cause weird stuff to happen and some vehicles have had water issues with rear gate gasket or sunroof / AC drains not working correctly.
Most folks detect the water before any damage though.

__________________
07-24-2017 Summit 3.6L Velvet Red W/Black & Brown Int
Tires: OEM 20"/Nokian 18"
Situational awareness: Valentine One with V1Driver on IOS
Reply With Quote
Sponsored Links
Advertisement
 
  #26  
Old 05-18-2015, 11:58 PM
GoPlzGo's Avatar
formerly 14summithemi
My Jeep: 2015 6.4L SRT WK2
 
Join Date: Oct 2013
Location: Cleveland, OH
Posts: 3,239
Thanks: 362
Thanked 577 Times in 482 Posts
Rep Power: 25702
GoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond repute
With your roving gremlin scenario I wonder if you have a loose ground wire strap under hood on the fender well. They were a problem to some degree on early MY14 builds....good luck, rough luck on a new one...
__________________
'15 JGC SRT Bright White Red Vapor...Borla ATAK Cat-back w/ ceramic coated axle-back, aFe Momentum GT Pro 5R Stage-2 Intake & Billet Tech Oil Catch Can
Reply With Quote
  #27  
Old 05-19-2015, 09:06 AM
Member
My Jeep: 2015 5.7L WK2
 
Join Date: Feb 2015
Location: Bayport NY
Posts: 330
Thanks: 46
Thanked 42 Times in 37 Posts
Rep Power: 100225
Dennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond repute
Re: 15 Overland gremlins

Thanks 14 yes I have been scouring all the TSB's and any info I could find on possible causes. I went to dealer yesterday just as I parked everything stopped working so I thought they might have someone at least take a quick looksy. Nope spoke to service manager kind of a dick just blew me off and said bring it back for appt June 4. I told him windows are open and not working and it's supposed to rain. So he reluctantly walked over opened door and shook the rubber covering door wire harness. Of course nothing changed. Said will need to tear into it remove door panel possibly dash to get to BCM. Will probably need a few days to figure it out. I was not liking the sound of that I have seen the way they remove stuff at dealerships. You usually get the customary scratches broken clips and half ass assembly along with some new rattles and squeaks. So I'am desperately trying to fix this myself. I have been trying some reset tricks that I read about from the TSB's. So far today everything is good but I know it's only a matter of time. Keeping fingers crossed 😀
Reply With Quote
  #28  
Old 05-19-2015, 12:00 PM
Premium Member
 
Join Date: Aug 2013
Location: Boston
Posts: 1,794
Thanks: 42
Thanked 213 Times in 165 Posts
Rep Power: 76854
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: 15 Overland gremlins

Quote:
Originally Posted by Dennisnyc40 View Post
Thanks 14 yes I have been scouring all the TSB's and any info I could find on possible causes. I went to dealer yesterday just as I parked everything stopped working so I thought they might have someone at least take a quick looksy. Nope spoke to service manager kind of a dick just blew me off and said bring it back for appt June 4. I told him windows are open and not working and it's supposed to rain. So he reluctantly walked over opened door and shook the rubber covering door wire harness. Of course nothing changed. Said will need to tear into it remove door panel possibly dash to get to BCM. Will probably need a few days to figure it out. I was not liking the sound of that I have seen the way they remove stuff at dealerships. You usually get the customary scratches broken clips and half ass assembly along with some new rattles and squeaks. So I'am desperately trying to fix this myself. I have been trying some reset tricks that I read about from the TSB's. So far today everything is good but I know it's only a matter of time. Keeping fingers crossed ��
Remove the DASH !! June 4th !!

That tone didn't sound good at all. I would try another dealer until you find one that feels comfortable. There can be drastic differences.
Don't worry who you bought it from.

A good technician will probe and test a lot and narrow it down BEFORE "tearing" things apart. A good technician puts things back together right too.

It's good you got it to fail for them.

Since the Jeep is so highly dependent on CAN bus it could be a bad CAN bus node screwing things up.

I highly doubt it will help, but did you try a Factory Reset on the radio. There could be some safety interlock thing that is messed up.
Hold Temp Up and Down on Drivers Side. Then Scroll to Factory Reset.
You will loose ALL settings on the Radio. And it will take some time to "configure itself". Don't panic, it will sort itself out but takes time. I think it re-downloads some things over it's cell connection. This is a real long shot. But it won't hurt at all. And I do it after each firmware update and has removed some gremlins. I swear it fixed my Advanced Collision Warning system, that didn't work at ALL until I factory reset the radio.
__________________
07-24-2017 Summit 3.6L Velvet Red W/Black & Brown Int
Tires: OEM 20"/Nokian 18"
Situational awareness: Valentine One with V1Driver on IOS
Reply With Quote
  #29  
Old 05-19-2015, 01:09 PM
Member
My Jeep: 2015 5.7L WK2
 
Join Date: Feb 2015
Location: Bayport NY
Posts: 330
Thanks: 46
Thanked 42 Times in 37 Posts
Rep Power: 100225
Dennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond repute
Re: 15 Overland gremlins

Actually under the dash right now looking for things. Yea not getting a warm fuzzy feeling from dealer. Especially service manager since he wants to rip into everything. I pulled the driver side window control all was good. Did the radio reset a few times already. Also put it back and forth into shipping mode looked promising until I went for a ride and problem returned. Checked the Neg grounding straps all good. Funny part about this is that it only happens when parked once out on the road everything is good. Never a problem when driving. I think it could be a faulty BCM. As that is what controls all the electrical functions of vehicle. I'am running out of things to check. Might have to bite the bullet and bring it in to dealer. Oh and the 2 dealers closest to me will not service a vehicle not purchased from them. As they are to overloaded with there own broken Jeeps. Makes me start to second guess my Jeep purchase. 😕
Reply With Quote
  #30  
Old 05-19-2015, 01:43 PM
Member
My Jeep: 2015 5.7L WK2
 
Join Date: Feb 2015
Location: Bayport NY
Posts: 330
Thanks: 46
Thanked 42 Times in 37 Posts
Rep Power: 100225
Dennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond repute
Re: 15 Overland gremlins

Well after a little more investigation. I think I've found the gremlin. It seems to be the parking brake. Push pedal down everything stops. Release and everything works again. I can duplicate it at will. Cannot figure out why the brake would make this happen. One question if somebody could check for this for me. Does your radio go dark when you apply the parking brake. Mine does and sometimes comes back on sometimes stays off. I think I'am getting closer to my problem. Hopefully all this info will help dealer from going on a search and destroy mission. Thank you all for your help.
Reply With Quote
  #31  
Old 05-20-2015, 11:02 AM
Member
My Jeep: 2015 5.7L WK2
 
Join Date: Feb 2015
Location: Bayport NY
Posts: 330
Thanks: 46
Thanked 42 Times in 37 Posts
Rep Power: 100225
Dennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond repute
Re: 15 Overland gremlins

Well so far today not one problem. I have avoided using the parking brake and everything is working as should be. I think there must be some sort of problem with the can-bus system when applying the parking brake. The dealer should be able to check the signals when I bring it in. I would still appreciate it if someone can verify something for me. With your vehicle running and radio on push down on the parking brake and tell me what happens to your radio screen. Does it go black and come back on. Or stays black,Or no effect at all. Just trying to gather as much info as possible. Thanks for any help.


Sent from my iPad using JeepGarage
Reply With Quote
  #32  
Old 05-20-2015, 11:19 AM
GoPlzGo's Avatar
formerly 14summithemi
My Jeep: 2015 6.4L SRT WK2
 
Join Date: Oct 2013
Location: Cleveland, OH
Posts: 3,239
Thanks: 362
Thanked 577 Times in 482 Posts
Rep Power: 25702
GoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond repute
Zero effect when I did it on my '14 Summit, 11/6/13 build.
__________________
'15 JGC SRT Bright White Red Vapor...Borla ATAK Cat-back w/ ceramic coated axle-back, aFe Momentum GT Pro 5R Stage-2 Intake & Billet Tech Oil Catch Can
Reply With Quote
  #33  
Old 05-20-2015, 11:29 AM
Member
My Jeep: 2015 5.7L WK2
 
Join Date: Feb 2015
Location: Bayport NY
Posts: 330
Thanks: 46
Thanked 42 Times in 37 Posts
Rep Power: 100225
Dennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond repute
Re: 15 Overland gremlins

Thank you for your help 14 appreciate it very much. As mine goes black and sometimes comes back on sometimes it doesn't. It's very puzzling why the parking brake is the root of my electrical problems.
Reply With Quote
  #34  
Old 05-20-2015, 11:36 AM
GoPlzGo's Avatar
formerly 14summithemi
My Jeep: 2015 6.4L SRT WK2
 
Join Date: Oct 2013
Location: Cleveland, OH
Posts: 3,239
Thanks: 362
Thanked 577 Times in 482 Posts
Rep Power: 25702
GoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond reputeGoPlzGo has a reputation beyond repute
Quote:
Originally Posted by Dennisnyc40 View Post
Thank you for your help 14 appreciate it very much. As mine goes black and sometimes comes back on sometimes it doesn't. It's very puzzling why the parking brake is the root of my electrical problems.
No prob, probably a hidden connector or some other PITA thing. Had an intermittent "Keyless system unavailable" bug that rendered fobs useless. Turned out to be the keyless antenna connector not pushed in all the way. Its on top if steering column I guess in a tough to reach spot. Fixed now. Good luck.
__________________
'15 JGC SRT Bright White Red Vapor...Borla ATAK Cat-back w/ ceramic coated axle-back, aFe Momentum GT Pro 5R Stage-2 Intake & Billet Tech Oil Catch Can
Reply With Quote
  #35  
Old 05-21-2015, 05:33 PM
Premium Member
 
Join Date: Aug 2013
Location: Boston
Posts: 1,794
Thanks: 42
Thanked 213 Times in 165 Posts
Rep Power: 76854
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: 15 Overland gremlins

Quote:
Originally Posted by Dennisnyc40 View Post
Well so far today not one problem. I have avoided using the parking brake and everything is working as should be. I think there must be some sort of problem with the can-bus system when applying the parking brake. The dealer should be able to check the signals when I bring it in. I would still appreciate it if someone can verify something for me. With your vehicle running and radio on push down on the parking brake and tell me what happens to your radio screen. Does it go black and come back on. Or stays black,Or no effect at all. Just trying to gather as much info as possible. Thanks for any help.


Sent from my iPad using JeepGarage
Nice work !! narrowing it down.
I always try to do that, even though I should not have to, it's always worth going in more informed.

I've never used the Parking Break. Not once.
__________________
07-24-2017 Summit 3.6L Velvet Red W/Black & Brown Int
Tires: OEM 20"/Nokian 18"
Situational awareness: Valentine One with V1Driver on IOS
Reply With Quote
  #36  
Old 05-21-2015, 07:57 PM
Member
My Jeep: 2015 5.7L WK2
 
Join Date: Feb 2015
Location: Bayport NY
Posts: 330
Thanks: 46
Thanked 42 Times in 37 Posts
Rep Power: 100225
Dennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond reputeDennisnyc40 has a reputation beyond repute
Re: 15 Overland gremlins

Yes thanks MSW I was just about to give up on my search as I was running out of things to check. But I'am very inquisitive person I do not like to give up on finding an answer or solution to a problem. Haven't used the parking brake for 2 days now and not one problem. Now if I only had a Can-Bus analyzer I could read the BCM. Thanks again everyone for all the replies.
Reply With Quote
Reply

Tags
overland

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
05 transmission gremlins warthogdriver Troubleshooting/Problems 23 08-28-2013 04:38 PM
Guess the Gremlins are Starting BobsWK2 Trouble Shooting/Problems/Service 3 04-08-2013 07:29 PM
Electrical gremlins continue ACPRO Grand Cherokee - WK 4 10-17-2011 01:49 PM
Strange Electrical Gremlins BLACK DOG Grand Cherokee - ZJ 6 06-03-2011 06:14 AM
Bugs, gremlins, problems...laredo vs overland? cbarr Grand Cherokee - WK2 - 19 05-25-2011 03:26 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:00 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.