Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-10-2013, 10:22 AM
JeepPilot's Avatar
Member
My Jeep: 2013 3.6L WK2
 
Join Date: Mar 2012
Location: Oklahoma
Posts: 31
Thanks: 10
Thanked 0 Times in 0 Posts
Rep Power: 891
JeepPilot is on a distinguished road
Angry 2013 JGC Overland Rattle and Key would not work.

Rattle

Rattle somewhere under dash on very rough asphalt roads only......

Anyone else having this issue?

Took everything out of glove box just to be sure.

Key
Used my spare key the other day. The car said the key was damaged and would not start so I tired it manually by taking out the start/stop button and the car still would not start. I got the other key and started the car. After I returned from my 20 minute trip I tried the spare key again and this time it worked.

Took the car to dealer and they said they could find nothing wrong. I now do not trust the spare key. Anyone have this issue?

Thanks
__________________

__________________
Reply With Quote
  #2  
Old 06-03-2013, 09:58 PM
New Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Hyattsville, Maryland
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
wintersnowman is on a distinguished road
Re: 2013 JGC Overland Rattle and Key would not work.

Quote:
Originally Posted by JeepPilot View Post
Rattle

Rattle somewhere under dash on very rough asphalt roads only......

Anyone else having this issue?

Took everything out of glove box just to be sure.

Key
Used my spare key the other day. The car said the key was damaged and would not start so I tired it manually by taking out the start/stop button and the car still would not start. I got the other key and started the car. After I returned from my 20 minute trip I tried the spare key again and this time it worked.

Took the car to dealer and they said they could find nothing wrong. I now do not trust the spare key. Anyone have this issue?

Thanks
YES to the strange rattle around the steering wheel! For us, it would happen at random times at varying speeds, but mostly around 30-40mph. My 2014 Hemi Overland Grand Cherokee is at the dealer as I type this. I reported the rattling sound and they took a couple test drives and could not hear anything. In fact, the tech blamed the noise on the small maglite that I had put in the glovebox (WTF?). I told my sales person to take it for a drive and see for himself. Again, he did not hear the noise. However, I sent him youtube videos of people who had the same issue:







In the comments on one of those videos, someone said to reference this STAR Case #S1323000022. It is apparently a removal of an unused bracket in the steering console.

I'll post here any updates I hear from my dealer tomorrow.
__________________

__________________
Reply With Quote
  #3  
Old 06-07-2013, 03:47 PM
Maka7veli's Avatar
Member
 
Join Date: May 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 441
Maka7veli is on a distinguished road
Re: 2013 JGC Overland Rattle and Key would not work.

Any updates from your dealer???
__________________
Reply With Quote
  #4  
Old 06-07-2013, 04:35 PM
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Feb 2013
Posts: 61
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1007
kbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond repute
Re: 2013 JGC Overland Rattle and Key would not work.

I had a rattle/clunking sound in my dash,(2013) turned out to be the dampening cable for the glove box. Does your glove box open slowly or just drop open? If it just drops open the cable is not connected and is hanging loose. Very easy to reconnect,(just clips in) no dealer visit needed if this is your case
__________________
Reply With Quote
  #5  
Old 06-10-2013, 06:58 AM
New Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Hyattsville, Maryland
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
wintersnowman is on a distinguished road
Re: 2013 JGC Overland Rattle and Key would not work.

The dealer came to my house, dropped off a loaner and drove back my Jeep to check out the source of the noise. Turns out two techs and my salesman didn't hear the noise (like the ringing of a bicycle bell) on test drives. See this thread for more info:

2014 Overland Buzzer Sound while driving

And this STAR tech bulletin:

Jeep Garage - Jeep Forum

They told me that I did not have the bracket as described in the bulletin that was making the noise. They returned the car to me. That was last week. The noise has not come back since. It is strange because my wife and I would consistenly hear the noise when driving about 30-40mph. I think the driver from the dealer who picked up the car may have fixed it, since I did tell him what was going on and he seemed like this was not new information. That or they fixed it but didn't want to admit that something was up on a brand new Overland.

Unfortunately, more to this story. My wife is at the dealer right now because when driving this past weekend, the instrument panel went blank. All gauges were at zero and nothing- no spedometer or anything. Very scary since it happened while driving with my two-year old son. We pulled over, turned off the car, turned it back on, still nothing. Repeated the process, still nothing. We drove to my son's swim lessons. I called the dealer and warned them that we would be bringing the car right by- not very happy.

We went to the swim lesson, and came back out an hour later. Now the instrument panel was working. Still drove to the dealer. We talked to them and expressed concern about safety, the fact this is a brand new expensive car, etc. We scheduled an appt on Monday to bring it in. My guess is that when they were looking under the steering column, they must have messed with the connection for the instrument panel. Given people's problems with UConnect, I hope that is the case.

At any rate, I am asking for any updates to UConnect firmware while they check out the Jeep. We've visited the service dept. two times already in the three weeks since we bought it! All said, we still love our Jeep. Cautiously optimistic that everything is OK.

kbre- Our glove box does open slowly, so I don't think that was the source of the noise.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New 2013 JGC Overland NotEZ2Beat Members Rides-Showoff 9 11-19-2012 08:40 PM
Nav options for 2013 JGC overland summit csandelli Audio/Visual/Navigation 4 11-11-2012 10:01 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community