2014 Eco now defaults to LAST SETTING - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-16-2016, 08:09 PM
Paullee01's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Location: West Palm Beach, FL
Posts: 453
Thanks: 20
Thanked 59 Times in 46 Posts
Rep Power: 7087
Paullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond repute
2014 Eco now defaults to LAST SETTING

I brought my 2014 Jeep in last week for some warranty service and they also performed two flash updates via warranty. I just noticed yesterday that the ECO mode button now defaults to the LAST setting when restarted. If I turn the ECO off and restart the engine it stays OFF and vice versa. Does not default ON.

At first I thought the button light wasn't working so I drove it just to confirm that ECO was off and it was. Didn't up shift as fast nor go into 8th gear. Tried it a bunch of times today and it's holding last default setting when restarted!

Unfortunately on the repair order it doesn't say exactly what the flash updates were for.

Flashes performed:

1) HVAC Module - If I'm not mistaken I think this one has something to do with the climate control.
2) EPS module ??? Not sure what this is for?

__________________
Grand Cherokee Limited 3.6L, Tinted windows, Sill guards, Body molding, CXV running boards, WeatherTech window deflectors, Husky floor liners, Zeigler lifetime maxicare

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 04-16-2016, 09:11 PM
JTS97Z28's Avatar
Premium Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jan 2011
Location: Plainfield, IL
Posts: 3,762
Thanks: 84
Thanked 600 Times in 442 Posts
Rep Power: 28559
JTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond reputeJTS97Z28 has a reputation beyond repute
Re: 2014 Eco now defaults to LAST SETTING

Wow great news for the 2014 guys. Some of you will be flooring it right over to the dealer for this update
__________________
2015 Jeep Grand Cherokee High Altitude, Bright White, V6, HK audio
Reply With Quote
  #3  
Old 04-16-2016, 09:57 PM
SNUKE's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jan 2013
Location: Sydney, Aus
Posts: 3,886
Thanks: 134
Thanked 543 Times in 421 Posts
Rep Power: 7377
SNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond repute
Garage
Re: 2014 Eco now defaults to LAST SETTING

TSB 21-012-15 was supposed to fix it, but I found it did not work when I had it applied
__________________
I'm just want it for the "shorter headlamps".

MY14 GC Limited, 3.0 CRD, Lux II, Granite Crystal, 18" Wheels, Tubular Side Steps.
Could I get my avatar much larger?
Ordered: July 7 2013 Delivered Nov 25th
Reply With Quote
  #4  
Old 04-16-2016, 10:00 PM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 3,350
Thanks: 254
Thanked 556 Times in 430 Posts
Rep Power: 30279
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Quote:
Originally Posted by Paullee01 View Post
I brought my 2014 Jeep in last week for some warranty service and they also performed two flash updates via warranty. I just noticed yesterday that the ECO mode button now defaults to the LAST setting when restarted. If I turn the ECO off and restart the engine it stays OFF and vice versa. Does not default ON.

At first I thought the button light wasn't working so I drove it just to confirm that ECO was off and it was. Didn't up shift as fast nor go into 8th gear. Tried it a bunch of times today and it's holding last default setting when restarted!

Unfortunately on the repair order it doesn't say exactly what the flash updates were for.

Flashes performed:

1) HVAC Module - If I'm not mistaken I think this one has something to do with the climate control.
2) EPS module ??? Not sure what this is for?
Thats good to hear glad its working for you. hmm im current on all published software flashes for my 2014 but mine doesnt remember did they list any numbers on the flashes other than the names?
Reply With Quote
  #5  
Old 04-16-2016, 10:40 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2015
Location: Montreal, Canada
Posts: 32
Thanks: 20
Thanked 2 Times in 2 Posts
Rep Power: 15065
Pinch has a reputation beyond reputePinch has a reputation beyond reputePinch has a reputation beyond reputePinch has a reputation beyond reputePinch has a reputation beyond reputePinch has a reputation beyond reputePinch has a reputation beyond reputePinch has a reputation beyond reputePinch has a reputation beyond reputePinch has a reputation beyond reputePinch has a reputation beyond repute
Re: 2014 Eco now defaults to LAST SETTING

Very interresting indeed. Maybe they flashed something for the 2015 model by mistake if that's possible
__________________
2014 GC Overland 4x4 5.7L V8
Maximum Steel/Black, Technology Package
Reply With Quote
  #6  
Old 04-16-2016, 10:43 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2014
Location: Airdrie, Alberta
Posts: 73
Thanks: 0
Thanked 10 Times in 10 Posts
Rep Power: 1123
barak is on a distinguished road
Re: 2014 Eco now defaults to LAST SETTING

EPS is for electronic power steering , that nor the HVAC should have affected the eco mode. Not sure what else they flashed as the last uconnect update for a 2014 was from july , so nothing new there.
__________________
2014 Summit 5.7
Reply With Quote
  #7  
Old 04-17-2016, 09:48 AM
Paullee01's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Location: West Palm Beach, FL
Posts: 453
Thanks: 20
Thanked 59 Times in 46 Posts
Rep Power: 7087
Paullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond repute
Re: 2014 Eco now defaults to LAST SETTING

I made a quick video regarding ECO mode on my 2014 GC. With vehicle running (I turn off Eco mode) When I restart it stays off. It only reverts back on if it is on when vehicle is shut off. It defaults to last setting. Also attaching my work order. (flash info. is on bottom of page) Sorry it doesn't say much about them.



__________________
Grand Cherokee Limited 3.6L, Tinted windows, Sill guards, Body molding, CXV running boards, WeatherTech window deflectors, Husky floor liners, Zeigler lifetime maxicare

Reply With Quote
The Following 2 Users Say Thank You to Paullee01 For This Useful Post:
  #8  
Old 04-17-2016, 11:21 AM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 3,350
Thanks: 254
Thanked 556 Times in 430 Posts
Rep Power: 30279
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Re: 2014 Eco now defaults to LAST SETTING

so one other quick question, what is your 2014 build date? early build, late build? not sure it matters but just curious and I want to try and draw a correlation to some of the other tsbs out there for BCM and TCM which may have an impact on it. thanks
Reply With Quote
  #9  
Old 04-17-2016, 01:15 PM
Paullee01's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Location: West Palm Beach, FL
Posts: 453
Thanks: 20
Thanked 59 Times in 46 Posts
Rep Power: 7087
Paullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond repute
Re: 2014 Eco now defaults to LAST SETTING

Quote:
Originally Posted by silvermax04 View Post
so one other quick question, what is your 2014 build date? early build, late build? not sure it matters but just curious and I want to try and draw a correlation to some of the other tsbs out there for BCM and TCM which may have an impact on it. thanks

Build date 9/13
__________________
Grand Cherokee Limited 3.6L, Tinted windows, Sill guards, Body molding, CXV running boards, WeatherTech window deflectors, Husky floor liners, Zeigler lifetime maxicare

Reply With Quote
Reply

Tags
2014

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ECO mode default setting Stevm65 Trouble Shooting/Problems/Service 6 05-10-2015 03:44 PM
Restore defaults on 8.4AN jeepstrat Trouble Shooting/Problems/Service 4 03-08-2014 01:49 AM
Auto Comfort feature Always Defaults On In Cold Weather - FIX Milous Trouble Shooting/Problems/Service 5 02-15-2014 05:30 PM
Defaults for Radio and Media on 8.4AN/RA4 The Snowman Audio/Visual/Navigation 8 07-15-2013 11:19 AM
Air conditioning defaults to on, when Jeep is started? MattE Grand Cherokee - WK2 - 4 10-17-2012 02:55 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.