Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-19-2013, 08:07 AM
Member
 
Join Date: Jan 2013
Posts: 15
Thanks: 3
Thanked 0 Times in 0 Posts
Rep Power: 618
Daytonguy21 is on a distinguished road
2014 Overland Issues: Christmas Tree Cluster

So I am ~2500 miles into my 2014 Overland and have had a minor problem or two with the infotainment system freezing or randomly switching between radio and an empty aux jack, but for the most part have been moderately happy with the car.

This morning I went to start it and had probably every electronic fault indicator go off. The center cluster looked like a Christmas light show. The Rear park sense indicator, air ride suspension, ABS brakes, Check engine light, and parking brake indicator were all lit. Also, my electronic fuel calculator and rage estimator stopped working, and then on the drive in my speedometer stopped working too. Mechanically the car ran fine, just all the indicators were illuminated. <O</O

When I got to the office I turned it off and let it sit for 30 minutes while I got some work done then went out to start it and the check engine light was the only indicator still lit. I didnít drive it to see if the fuel economy or speedo worked yet. <O</O

Has anyone had a fault like this and have any clue what it could be or how to fix it? I have a service appointment scheduled to have the tech look at it, but just would like to have some idea going in.
<O</O
Thanks!<O</O
__________________

__________________
Ordered: 2014 Black on Black Overland!!! Options: CD Player (Im old school) :thumbsup:
Reply With Quote
  #2  
Old 06-19-2013, 08:20 AM
Chunderboy's Avatar
Member
 
Join Date: Apr 2013
Posts: 991
Thanks: 0
Thanked 24 Times in 17 Posts
Rep Power: 77914
Chunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond repute
Re: 2014 Overland Issues: Christmas Tree Cluster

Quote:
Originally Posted by Daytonguy21 View Post
So I am ~2500 miles into my 2014 Overland and have had a minor problem or two with the infotainment system freezing or randomly switching between radio and an empty aux jack, but for the most part have been moderately happy with the car.

This morning I went to start it and had probably every electronic fault indicator go off. The center cluster looked like a Christmas light show. The Rear park sense indicator, air ride suspension, ABS brakes, Check engine light, and parking brake indicator were all lit. Also, my electronic fuel calculator and rage estimator stopped working, and then on the drive in my speedometer stopped working too. Mechanically the car ran fine, just all the indicators were illuminated. <O</O

When I got to the office I turned it off and let it sit for 30 minutes while I got some work done then went out to start it and the check engine light was the only indicator still lit. I didnít drive it to see if the fuel economy or speedo worked yet. <O</O

Has anyone had a fault like this and have any clue what it could be or how to fix it? I have a service appointment scheduled to have the tech look at it, but just would like to have some idea going in.
<O</O
Thanks!<O</O
http://www.jeepgarage.org/f73/2014-j...ing-61339.html

Here is the link to a similar issue
__________________

__________________
Reply With Quote
The Following User Says Thank You to Chunderboy For This Useful Post:
  #3  
Old 06-19-2013, 08:39 AM
Member
 
Join Date: Jan 2013
Posts: 15
Thanks: 3
Thanked 0 Times in 0 Posts
Rep Power: 618
Daytonguy21 is on a distinguished road
Re: 2014 Overland Issues: Christmas Tree Cluster

Thanks Chunderboy, sounds like this is a fairly widespread problem with the 14's.
__________________
Ordered: 2014 Black on Black Overland!!! Options: CD Player (Im old school) :thumbsup:
Reply With Quote
  #4  
Old 06-19-2013, 09:31 AM
Chunderboy's Avatar
Member
 
Join Date: Apr 2013
Posts: 991
Thanks: 0
Thanked 24 Times in 17 Posts
Rep Power: 77914
Chunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond repute
Re: 2014 Overland Issues: Christmas Tree Cluster

Quote:
Originally Posted by Daytonguy21 View Post
Thanks Chunderboy, sounds like this is a fairly widespread problem with the 14's.
Unfortunately, that seems to be the case. For the life of me, I can't understand how this fairly new technology (for Jeep that is) wasn't really put the paces and just thrown in there haphazardly. Times like these, I am glad to have my 2013...
__________________
Reply With Quote
  #5  
Old 06-19-2013, 09:37 AM
BobsWK2's Avatar
Premium Member
 
Join Date: Aug 2010
Posts: 1,528
Thanks: 3
Thanked 23 Times in 21 Posts
Rep Power: 49554
BobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond repute
Re: 2014 Overland Issues: Christmas Tree Cluster

I see nothing posted in your post.
__________________
2014 Summit 4X4, V8
Reply With Quote
  #6  
Old 06-19-2013, 08:01 PM
eljeffe505's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Albuquerque
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 522
eljeffe505 is on a distinguished road
Join the club... 2 drink minimum.
__________________
_____________________
2009 Wrangler Rubicon Unlimited
2014 Grand Cherokee Overland
Reply With Quote
  #7  
Old 06-19-2013, 09:07 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,063
Thanks: 311
Thanked 321 Times in 283 Posts
Rep Power: 1801530
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Overland Issues: Christmas Tree Cluster

Quote:
Originally Posted by eljeffe505 View Post
Join the club... 2 drink minimum.
Highlight the "invisible text" to read it. Depending on what color scheme you are using, the OP's text is the same as the background. Highlighting the text changes the color.



.
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #8  
Old 06-20-2013, 08:37 AM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,523
Thanks: 0
Thanked 23 Times in 20 Posts
Rep Power: 80125
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: 2014 Overland Issues: Christmas Tree Cluster

See the previous threads. In many caes some of the codes relate to high or low voltage and loose ground wires are found under the hood or on the battery.

The '14s with the 8.4 do seem more sucessible to ground faults and spikes that earlier but may be due to the power distribution rather than the electronics themselves.

In other words a problem on the assembly line and not anything in the vehicle design.

I do know that if a new '14 was purchased I would personally check all grounds and codes before it ever left the lot & I would consider adding power conditioning (big capacitor) to the circuit.
Reply With Quote
  #9  
Old 06-20-2013, 08:43 AM
Chunderboy's Avatar
Member
 
Join Date: Apr 2013
Posts: 991
Thanks: 0
Thanked 24 Times in 17 Posts
Rep Power: 77914
Chunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond repute
Re: 2014 Overland Issues: Christmas Tree Cluster

Quote:
Originally Posted by padgett View Post
See the previous threads. In many caes some of the codes relate to high or low voltage and loose ground wires are found under the hood or on the battery.

The '14s with the 8.4 do seem more sucessible to ground faults and spikes that earlier but may be due to the power distribution rather than the electronics themselves.

In other words a problem on the assembly line and not anything in the vehicle design.

I do know that if a new '14 was purchased I would personally check all grounds and codes before it ever left the lot & I would consider adding power conditioning (big capacitor) to the circuit.
For all the new 14 buyers, is there a list somewhere of all the grounds that should be checked?
__________________
Reply With Quote
  #10  
Old 06-20-2013, 09:48 AM
AAAA's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jan 2011
Location: Upstate NY
Posts: 2,610
Thanks: 20
Thanked 43 Times in 39 Posts
Rep Power: 1543376
AAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond repute
Re: 2014 Overland Issues: Christmas Tree Cluster

Thanks Bill. Good to know.
__________________
Limited- Michelin LTX M/S 2's, chrome fog bezels, front and t. c. skid plates, Bosch Icon blades, Husky X-Act Contour slush mats, MOPAR cargo mat.
(Avatar- http://www.ussslater.org/)
Reply With Quote
  #11  
Old 06-20-2013, 10:27 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,063
Thanks: 311
Thanked 321 Times in 283 Posts
Rep Power: 1801530
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: 2014 Overland Issues: Christmas Tree Cluster

Quote:
Originally Posted by Chunderboy View Post
For all the new 14 buyers, is there a list somewhere of all the grounds that should be checked?
As far as I know there was only one specific ground point that was found to be problematic. It was a ground strap going to the right front frame rail. There was a star report issued, so I'd be pretty sure that it was taken care of pretty quickly on the assembly line.

It has been blamed for all sorts of woes. I checked mine when I got my Jeep in March and it was tight. When I went in with a problem, Jeep told the dealer to clean up that ground, even though it was tight. When I went back with the same problem Jeep told the dealer to change the PCM. No more problem. Since a lot of problems with 14's are intermittent, it's an easy thing to point to.

A couple of us also found loose negative battery terminals.


---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #12  
Old 06-20-2013, 03:22 PM
amc2002's Avatar
Member
My Jeep: 2002 4.0L TJ
 
Join Date: Apr 2013
Location: Long Island, NY
Posts: 519
Thanks: 0
Thanked 12 Times in 12 Posts
Rep Power: 236973
amc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond repute
Re: 2014 Overland Issues: Christmas Tree Cluster

Quote:
Originally Posted by Daytonguy21 View Post
--snip-- Also, my electronic fuel calculator and rage estimator stopped working, and then on the drive in my speedometer stopped working too. --snip--
When I was having issues with my GC, my rage estimator said 999999. I actually think it was working correctly.



On a more serious note, in my case and a couple others, yes it was the negative battery strap that was the issue.

I WOULD NOT DRIVE ONE MORE MILE before I checked these grounds (mentioned above by bill_de) myself. In my case, it fried quite a lot on the car. Good luck, and let us know how you make out.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Jeep Overland - Dash lit up like a christmas tree, speedometer not working abarbs30 Trouble Shooting/Problems/Service 204 08-19-2014 11:17 AM
2014 overland in a tree! demontweak Grand Cherokee - WK2 - 36 07-20-2013 07:02 PM
How to tie down a Christmas tree? Echo22 Tech Tips/DIY/How To 40 12-12-2011 02:45 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:29 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community