Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-21-2014, 11:51 AM
Member
 
Join Date: May 2014
Posts: 16
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 125
brian.addy is on a distinguished road
8.4 Head Unit problem

Hey all, almost took delivery of a special order 2014 3.6L 4X4 Overland blk on blk with adv pkg and rear entertainment. On the test drive before I signed the paperwork, the radio all of a sudden started rolling through the inputs (aux,fm,am,cd,etc) without even touching the screen. My sales guy tried to play it on it needed a new software flash, but the build date was 6/5/14 and has the most recent version. They are trying to figure out if the entire head unit needs replacing or not!

Anyone else had these issues? Coming from a long line of problem free foreign cars My confidence level in this thing is plummeting.
I expect much better from a $51k vehicle. Am I overreacting?
__________________

__________________
Using Tapatalk
Reply With Quote
  #2  
Old 06-21-2014, 01:57 PM
Northland's Avatar
I go where my Jeep goes.
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2012
Posts: 432
Thanks: 15
Thanked 27 Times in 23 Posts
Rep Power: 1508
Northland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond repute
Re: 8.4 Head Unit problem

Try hard resetting it - hold both the cold and hot temp buttons on driver's side down at the same time until the diagnostic menu comes up; scroll down to the reset option.
__________________

__________________
Ordered 2/04/13, Built and Status KZ (Plant Release) on 2/19/13, delivered 2/28/13: 2014 Limited 4x4 in Bright White with Lt. Frost Beige interior; Hemi V8; ORA II; RA4 UConnect.
So far: 20% tint all around; black BT oil catch can; Jeep slush and cargo mats; Blackvue DR500GW-HD dashcam; DropStops; XtremeDigital 4300K low beam HIDs; 5000K LED fog lights; Airaid CAI with SynthaMax dry filter. And now rollin' with UConnect 14.25.5!!
Reply With Quote
  #3  
Old 06-22-2014, 12:00 AM
Member
My Jeep: 2014 WK2
 
Join Date: Apr 2014
Location: Northern California
Posts: 80
Thanks: 3
Thanked 2 Times in 2 Posts
Rep Power: 301
major2000 has a reputation beyond reputemajor2000 has a reputation beyond reputemajor2000 has a reputation beyond reputemajor2000 has a reputation beyond reputemajor2000 has a reputation beyond repute
Re: 8.4 Head Unit problem

Quote:
Originally Posted by brian.addy View Post
Hey all, almost took delivery of a special order 2014 3.6L 4X4 Overland blk on blk with adv pkg and rear entertainment. On the test drive before I signed the paperwork, the radio all of a sudden started rolling through the inputs (aux,fm,am,cd,etc) without even touching the screen. My sales guy tried to play it on it needed a new software flash, but the build date was 6/5/14 and has the most recent version. They are trying to figure out if the entire head unit needs replacing or not!

Anyone else had these issues? Coming from a long line of problem free foreign cars My confidence level in this thing is plummeting.
I expect much better from a $51k vehicle. Am I overreacting?
I'd say you're going to have to expect more problems than an average Toyota or Honda. That's unfortunately Jeep's reputation and in my experience with my two month old JGC, the reality. I wish it weren't true.
__________________
Reply With Quote
  #4  
Old 06-22-2014, 08:26 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,098
Thanks: 209
Thanked 151 Times in 123 Posts
Rep Power: 89507
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: 8.4 Head Unit problem

Probably not what's causing your problem, but the center button on the back of the right side of the steering wheel scrolls through the inputs. I've inadvertently put my finger on it while driving, and what you're saying happens.
Let us know what you find out.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
The Following User Says Thank You to jacko15 For This Useful Post:
  #5  
Old 06-22-2014, 12:22 PM
Paullee01's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Location: West Palm Beach, FL
Posts: 135
Thanks: 0
Thanked 10 Times in 6 Posts
Rep Power: 524
Paullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond reputePaullee01 has a reputation beyond repute
Re: 8.4 Head Unit problem

When I did the latest update mine would scroll through all the stations. Then I went to the media and played music via the flash drive. It would scroll through all my songs. The next time I restarted it worked fine. Hasn't done it since. Very odd....
__________________
2014 Grand Cherokee Limited 3.6L, Tinted windows, Sill guards, Body molding, CXV running boards, Mud flaps, WeatherTech window deflectors, Zeigler lifetime maxcare

Reply With Quote
  #6  
Old 06-23-2014, 07:15 AM
SnoFire's Avatar
The Negotiator
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: Wisconsin
Posts: 4,867
Thanks: 55
Thanked 135 Times in 114 Posts
Rep Power: 390005
SnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond repute
Garage
Re: 8.4 Head Unit problem

Just because the vehicle is a recent build doesn't exactly mean it has the latest software version. Can you confirm what version is on it?


Sent from my iPhone using JeepGarage
__________________
2014 GC Limited V6 LuxII/Tow/RA4 Max Steel/Blk Michelin LTX M/S2

Reply With Quote
  #7  
Old 06-23-2014, 07:38 AM
Member
 
Join Date: May 2014
Posts: 16
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 125
brian.addy is on a distinguished road
Re: 8.4 Head Unit problem

Don't know the version # because they've had it since we were supposed to take delivery on Friday. They have to hook up to some computer based online system today for them to know whether to try another flash or replace the whole thing. If it has to be replaced I'm looking at end of week before I see it again.
__________________
Using Tapatalk
Reply With Quote
  #8  
Old 06-23-2014, 10:50 AM
Member
 
Join Date: May 2014
Posts: 16
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 125
brian.addy is on a distinguished road
Re: 8.4 Head Unit problem

Turns out it's the switch on the back of the steering wheel that was intermittently sticking without being touched. We'll see tomorrow if that fixes her up.
__________________

__________________
Using Tapatalk
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MyGIG Head unit on a 2001 WJ Grand Cherokee BigZé Audio/Visual/Navigation 5 04-13-2010 04:14 PM
Looking at replacing my head unit Relwarc Audio, Video, Navigation & Electronic Modifications 6 07-08-2009 05:57 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community