Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 03-21-2014, 10:28 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 928
Thanks: 0
Thanked 42 Times in 33 Posts
Rep Power: 3540
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: Advice

Quote:
Originally Posted by pensfan414 View Post

Yes I have, but it seems they are placing all the responsibility on the dealer. Of course, the dealer is clueless. So i have no idea what to do.
I had many issues with the Jeep dealerships in my area, most recently asking to have TSBs implemented. When I called Chrysler Customer Care and received a case number, I got them to recommend a dealership in my area for me...they even called the dealership ahead of time warning them I'd be coming.

Everything went smooth after that.
__________________

__________________
My V6 Overland transmission shifts like crap!
Reply With Quote
  #14  
Old 03-21-2014, 10:30 AM
pensfan414's Avatar
Premium Member
 
Join Date: Nov 2013
Posts: 110
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 457
pensfan414 is on a distinguished road
Quote:
Originally Posted by GCLimited View Post
I had many issues with the Jeep dealerships in my area, most recently asking to have TSBs implemented. When I called Chrysler Customer Care and received a case number, I got them to recommend a dealership in my area for me...they even called the dealership ahead of time warning them I'd be coming. Everything went smooth after that.
Perhaps I will try that. I do have a case number and everything, thanks for the info.
__________________

__________________
2000 Cherokee
2014 GC Overland
Reply With Quote
  #15  
Old 03-21-2014, 01:21 PM
pensfan414's Avatar
Premium Member
 
Join Date: Nov 2013
Posts: 110
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 457
pensfan414 is on a distinguished road
Quote:
Originally Posted by Rexlion View Post
My only advice is the same as zhenya's: try a different dealer. Or "lose it". Your choice. If you always do what you've always done, you'll always get what you've always gotten.
Um....what? Thanks for the helpful response.
__________________
2000 Cherokee
2014 GC Overland
Reply With Quote
  #16  
Old 03-21-2014, 02:52 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 2,513
Thanks: 38
Thanked 90 Times in 83 Posts
Rep Power: 43989
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Advice

Quote:
Originally Posted by macsesso View Post
Had that the other day on my 2014 limited. Dealer cleared the code tested it and said everything was ok. Hope its not the same problem as yours. Sorry I cant give any advice. My dealer is 5 minutes from my house so I will just keep taking it back if it keeps happening.
Have you folks had the recall to tighten up the alternator ground yet?

I haven't gotten a round tuit in having the upflash done, but I had the goofy MIL and evap sensor a couple times. The tech was used to "jeep cable tightening standards" and tightened up all the heavy cables just as a matter of course and it hasn't come back since.

Isn't there also a failure mode in the purge system that can trigger this, where it actually is a bad part?
__________________
Reply With Quote
  #17  
Old 03-21-2014, 05:10 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Location: Laurel, Md
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 389
crazyeddie is on a distinguished road
Re: Advice

Quote:
Originally Posted by macsesso View Post
Had that the other day on my 2014 limited. Dealer cleared the code tested it and said everything was ok. Hope its not the same problem as yours. Sorry I cant give any advice. My dealer is 5 minutes from my house so I will just keep taking it back if it keeps happening.

DITTO, haven't seen the CEL in a week now. My dealer is also 5 minutes away--ce
__________________
Reply With Quote
  #18  
Old 03-21-2014, 05:45 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Dec 2013
Posts: 22
Thanks: 0
Thanked 2 Times in 1 Post
Rep Power: 333
macsesso is on a distinguished road
Re: Advice

Quote:
Originally Posted by bill_de View Post
True. It appears to me to be 2 blades that get pushed aside by the nozzle. It's the reason Jeep supplies a funnel in case you need to add gas from a can. The funnel neck is long enough to open the the passage.


---
Although in 50 years of driving I have never had to use a gas can, where is the funnel?
__________________
Reply With Quote
  #19  
Old 04-15-2014, 05:01 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Location: Laurel, Md
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 389
crazyeddie is on a distinguished road
Re: Advice

Quote:
Originally Posted by crazyeddie View Post
DITTO, haven't seen the CEL in a week now. My dealer is also 5 minutes away--ce
After a month the CEL light is back on. Same "Evaporative System, Small leak detected code. Goes in to the dealer on Monday 04/21 hopefully for diagnostics and correction of the problem. Cars runs great and no other problems. We Shall See--CE
__________________
Reply With Quote
  #20  
Old 04-15-2014, 05:03 PM
pensfan414's Avatar
Premium Member
 
Join Date: Nov 2013
Posts: 110
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 457
pensfan414 is on a distinguished road
Re: Advice

To update, my dealer replaced the evap canister to see if that would fix the CEL. Been replaced for a few weeks now with no return of CEL, yet. Fingers crossed...


Sent from my iPhone using JeepGarage
__________________
2000 Cherokee
2014 GC Overland
Reply With Quote
  #21  
Old 04-22-2014, 06:05 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Location: Laurel, Md
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 389
crazyeddie is on a distinguished road
Re: Advice

Quote:
Originally Posted by crazyeddie View Post
After a month the CEL light is back on. Same "Evaporative System, Small leak detected code. Goes in to the dealer on Monday 04/21 hopefully for diagnostics and correction of the problem. Cars runs great and no other problems. We Shall See--CE

Follow up, after 8 hours at the dealer today, they have nothing. All they told me on the phone was what we already knew. They will talk with Chrysler tomorrow to see if they have any direction. This, so far is a very predictable outcome. More to follow. This is my first Chrysler product since 1966, with all those transmission problems I couldn't possibly buy one. Now after 6 very reliable Ford products where I never knew the names at the service department, looks like I will be on a first name basis with these guys at the Jeep dealer. They get an "A" so far for trying--CE
__________________
Reply With Quote
  #22  
Old 04-24-2014, 09:37 AM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Location: Laurel, Md
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 389
crazyeddie is on a distinguished road
Re: Advice

Quote:
Originally Posted by crazyeddie View Post
Follow up, after 8 hours at the dealer today, they have nothing. All they told me on the phone was what we already knew. They will talk with Chrysler tomorrow to see if they have any direction. This, so far is a very predictable outcome. More to follow. This is my first Chrysler product since 1966, with all those transmission problems I couldn't possibly buy one. Now after 6 very reliable Ford products where I never knew the names at the service department, looks like I will be on a first name basis with these guys at the Jeep dealer. They get an "A" so far for trying--CE
After two complete days at the dealer, picked up my GC this morning. According to the ticket "Vacuum tested evap purge solenoid, pressurized emissions system(twice) and soaked down emissions system with soapy water in effort to locate a vacuum leak and found no leaks at this time. Conferred with technical assistance and replaced the evaporative system integrity module(esim) switch(possibly sticking internally at times) in effort to address trouble code."
On the way home the damn "phone requires service" dreaded screen appeared. Apparently the radio upgrade did not fix this from a couple months ago. I DON'T KNOW.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Advice Hazemonster Grand Cherokee - WK2 - 10 02-04-2014 04:05 PM
A little advice guitartate Grand Cherokee - WK2 - 7 11-14-2012 10:06 PM
need advice please! ! HEMI05 Grand Cherokee - WK 7 05-14-2012 11:29 AM
265/70/R17 or 285/65/R17 on a WK??...Please need some advice JeepPeru Wheels and Tires 1 04-25-2012 03:24 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community