Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #49  
Old 05-06-2013, 04:10 PM
not_too_shabby's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2013
Location: Portland, OR
Posts: 395
Thanks: 1
Thanked 8 Times in 8 Posts
Rep Power: 911
not_too_shabby has a brilliant future
Re: Anyone else not having problems?

So far so good here. I did a thorough inspection of the paint after I washed it and no defects. Alignment of the door and tailgate looked fine to me. Just got it 2 days ago and drove it about 150 miles so far.
__________________

__________________
2014 Grand Cherokee Overland 4x4 V6
Maximum Steel
Download my App - iLeaseMyCar Pro Auto Loan and Lease Calculator for iPhone or iPad
Reply With Quote
  #50  
Old 05-06-2013, 09:07 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2011
Posts: 161
Thanks: 1
Thanked 4 Times in 4 Posts
Rep Power: 1718
jerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond reputejerryw1000 has a reputation beyond repute
Re: Anyone else not having problems?

We've got about 650 miles on our 2014 and so far the only problem we've had is that the NAV froze up ONCE the day we picked it up while I was zooming the map in and out, about 2 miles after we left the dealer's lot. Since then I have routed, zoomed, etc. and no more problems. I even finally figured out how to marry the key FOBs to the memory seat positions after I received the full set of owner's manuals.
__________________

__________________
2011 Grand Cherokee Laredo X 4x4 V6
2014 Grand Cherokee Limited 4x2 V6
Reply With Quote
  #51  
Old 05-07-2013, 06:02 AM
Member
 
Join Date: Apr 2012
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 875
Sobrut911 is on a distinguished road
Re: Anyone else not having problems?

No issues with 29800 miles on my 2012 Overland w/ hemi.
__________________
Reply With Quote
  #52  
Old 05-07-2013, 02:38 PM
not_too_shabby's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2013
Location: Portland, OR
Posts: 395
Thanks: 1
Thanked 8 Times in 8 Posts
Rep Power: 911
not_too_shabby has a brilliant future
Re: Anyone else not having problems?

Well, I take that back. This afternoon my outside temp gauge is stuck at 53 degrees when it is probably 70 outside and the 8.4N screen locked up after browsing the uconnect apps. Oddly both things happened right after I registered the uconnect.
__________________
2014 Grand Cherokee Overland 4x4 V6
Maximum Steel
Download my App - iLeaseMyCar Pro Auto Loan and Lease Calculator for iPhone or iPad
Reply With Quote
  #53  
Old 05-07-2013, 04:25 PM
torifile's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2013
Posts: 633
Thanks: 27
Thanked 13 Times in 9 Posts
Rep Power: 1316908
torifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond repute
Re: Anyone else not having problems?

I blame sprint and their shitty service for all the uconnect problems.
__________________
Current: 2014 Overland. V8. 4x4. Black on black.
SOLD! 2010 BMW 335d.
Reply With Quote
  #54  
Old 05-07-2013, 05:59 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2012
Location: Somersworth, NH
Posts: 85
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 921
Jakkall is on a distinguished road
Garage
Re: Anyone else not having problems?

No issues whatsoever . 1200 miles so far . Last weekend me and my wife drove the car to Long Island ( from somersworth nh) . That was her first long trip and everything was fine . V8 purring like a beast when stepping on the gas
Max mpg was 21 average was 20 . I've reset the mpg counter in front of the house in nh . Hit quite a bit of trafic on our way back but still average didn't drop below 20.
Unconnect was fine . Never caused any issue. I did the registration first day I got the car 26 of April .
__________________
Reply With Quote
  #55  
Old 05-07-2013, 07:18 PM
Member
 
Join Date: Mar 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1273
oe542bob has a reputation beyond reputeoe542bob has a reputation beyond reputeoe542bob has a reputation beyond reputeoe542bob has a reputation beyond reputeoe542bob has a reputation beyond reputeoe542bob has a reputation beyond reputeoe542bob has a reputation beyond reputeoe542bob has a reputation beyond reputeoe542bob has a reputation beyond reputeoe542bob has a reputation beyond reputeoe542bob has a reputation beyond repute
Re: Anyone else not having problems?

Ok. Let me jump in here too. Just traded our 2011 Summit on a 2014 Summit. Both with the V-6. Excellent engine and that's why we reordered our new one with the same. Wife's car, but I usually do the driving when we go together. The 2011 had 38,000 miles when traded and was due for new tires by the end of summer. One of the best vehicles I've ever owned/driven. No issues ever, except the front doors didn't want to stay open very well. Detents not strong enough. Wind blew the drivers door out of my hand and dented the door where it hit the front fender.
On the 2014, I really like the new shifter ( now that I'm use to it ) and the sport mode is a good choice for more spirited driving. Mileage is a little better too, by maybe a mpg or two, but haven't hard checked it. A couple pleasant surprises are the new back up camera and the front bumper distance sensors. The rear camera parking lines actually will show where you are headed as they curve when you turn the steering wheel. The front sensors I wasn't even aware of till we got the Summit and I thought I read every bit of info out there! I really would rather have the hard buttons for the heated/cooled seats and the heated steering wheel, but its a minor complaint. No issues with uConnect that I'm aware of. Nav seems fine. Love the bigger screen. Haven't tried USB with the phone yet, but did use Bluetooth for music streaming. No album art while streaming music. Don't care about that though.
Now the bad stuff. Both chrome roof rails were bent and scratched when delivered. Replaced by dealer. Next is yesterday while driving to work, my wife had the MIL light come on as we'll as the ETC light was flashing. So I drove it this afternoon up to drop it off at the dealer. No ETC light, but the MIL was on steady. Drove fine. Everyone was gone except the owner when we dropped it off, and she told us to park it inside. That was nice and we did put it inside the garage. Guess what! The MIL indicator light did not come on! WTF, well, it will be hooked up and scanned for codes tomorrow.
This will be straightened out I'm sure, but with only 688 miles, I would be dishonest if I said it didn't bother me. Not disappointed yet!

__________________
Reply With Quote
  #56  
Old 05-08-2013, 02:47 PM
Red G8R's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Sep 2010
Location: Whitby, Ontario, Canada
Posts: 900
Thanks: 0
Thanked 11 Times in 11 Posts
Rep Power: 2408
Red G8R has a reputation beyond reputeRed G8R has a reputation beyond reputeRed G8R has a reputation beyond reputeRed G8R has a reputation beyond reputeRed G8R has a reputation beyond repute
Re: Anyone else not having problems?

My 2011 Overland is my 4th consecutive Jeep and the best driving/finished/equipt Grand Cherokee of all.
BUT, it has also been burdened with problems (but I still LOVE it).
Problems include:
1. visor falling off
2. transmission hesitation....fixed with TSB
3. quadra-lift failure: Jan 2012..changed a valve
Jan 2013...took 5 weeks in the shop the find the leak (extreme cold, -15 C), get the parts from Detroit and fixed it....changed valve, front lines and compressor.
4. driver's door lock is sticking....haven't taken it in as yet
5. brake pedal was making a "gushing" sound...brake booster replaced, sounded worse so they kept it overnight till a new part arrived. Still not as it was.

Despite these issues, I just love how this Jeep drives and it's practicality. Of all my three vehicles, this is one I cannot do without.
__________________
Peter
2011 GC Overland, 4x4, 5.7L, Q-L, 730N, White/Beige. :thumbsup:
Reply With Quote
  #57  
Old 05-08-2013, 03:09 PM
tkoui's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: NWIndiana
Posts: 44
Thanks: 12
Thanked 1 Time in 1 Post
Rep Power: 530
tkoui is on a distinguished road
Garage
At 389 miles, I experienced my first glitch. After saving the settings for Driver #2, my speedometer/EVIC screen went black/blank. I drove it around the corner to get gas and by the time I filled up, it fixed itself. Hopefully, this isn't a sign of things to come.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems Greenman Grand Cherokee - WJ 12 02-04-2013 10:15 PM
L.E.D problems BlackN'Blue Troubleshooting/Problems 11 07-22-2012 05:24 PM
Ac problems help! flyboy Troubleshooting/Problems 6 07-10-2012 07:16 AM
Two problems I need help with . jjslips Troubleshooting/Problems 4 01-18-2012 05:38 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community