Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-25-2013, 12:20 AM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Nov 2010
Posts: 1,203
Thanks: 1
Thanked 23 Times in 23 Posts
Rep Power: 3139
jp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond repute
Anyone else not having problems?

I have about 1600 miles on my 2014 overland and really no issues yet. I could point to a couple minor things but overall it pretty good so far. After reading the posts on this forum though I keep looking for it to fall apart everytime I drive it. I had a couple rattles that seem to have gone away for now and once in a while after I start it I have to pull the thumb drive I have out and put it back in to get it play the music. So I guess I would like to hear if there are others that are trouble free so far?
__________________

__________________
Reply With Quote
  #2  
Old 04-25-2013, 03:30 AM
SnoFire's Avatar
The Negotiator
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: Wisconsin
Posts: 4,874
Thanks: 55
Thanked 135 Times in 114 Posts
Rep Power: 390043
SnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond reputeSnoFire has a reputation beyond repute
Garage
There're is another thread already like this..just do a search
__________________

__________________
2014 GC Limited V6 LuxII/Tow/RA4 Max Steel/Blk Michelin LTX M/S2

Reply With Quote
  #3  
Old 04-25-2013, 08:01 AM
Beski's Avatar
Member
 
Join Date: Mar 2013
Location: New Jersey
Posts: 144
Thanks: 0
Thanked 7 Times in 7 Posts
Rep Power: 1963
Beski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond repute
Re: Anyone else not having problems?

Quote:
Originally Posted by SnoFire View Post
There're is another thread already like this..just do a search
With 742 Threads (yes, I counted !!) about all the various Problems, Complaints & Issues with the 2014's I think we can have 2 Threads with Positive Reports !!
__________________
Reply With Quote
  #4  
Old 04-25-2013, 08:48 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,178
Thanks: 318
Thanked 346 Times in 302 Posts
Rep Power: 1801666
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: Anyone else not having problems?

Quote:
Originally Posted by Beski View Post
With 742 Threads (yes, I counted !!) about all the various Problems, Complaints & Issues with the 2014's I think we can have 2 Threads with Positive Reports !!




If this thread is only to report no problems, it may wind up having a lot of responses, at least I hope it does. But it sure will be boring.




.
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #5  
Old 04-25-2013, 08:56 AM
andyh's Avatar
Premium Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jan 2011
Location: ILM, NC
Posts: 371
Thanks: 2
Thanked 5 Times in 5 Posts
Rep Power: 2213
andyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond repute
Re: Anyone else not having problems?

This forum probably represents 0.00001% of WK2 owners.
__________________
This is my sig
Reply With Quote
  #6  
Old 04-25-2013, 09:33 AM
Beski's Avatar
Member
 
Join Date: Mar 2013
Location: New Jersey
Posts: 144
Thanks: 0
Thanked 7 Times in 7 Posts
Rep Power: 1963
Beski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond reputeBeski has a reputation beyond repute
Re: Anyone else not having problems?

Quote:
Originally Posted by andyh View Post
This forum probably represents 0.00001% of WK2 owners.
Perhaps, but this Forum should still represent some type of "sampling" of what's out there.

Just like a Gallup Poll where a small sampling "usually" represents the same opinions of a larger group. If 25% of the Jeep Garage Owners have problems, then about 25% of ALL Jeep owners should have problems.

The tough part is we only tend to hear about the Problems here and not all the Positive experiences since Happy Jeep Owners are driving too much to Post !!
__________________
Reply With Quote
  #7  
Old 04-25-2013, 09:42 AM
Sh0rtBus's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: North Texas
Posts: 391
Thanks: 0
Thanked 11 Times in 11 Posts
Rep Power: 2281
Sh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond repute
Garage
Re: Anyone else not having problems?

Enough about whether ot not this thread should exist....it does.

And so far....no issues to report with my '14 Limited 4x4. Got it right at 3 weeks ago and have put about 1300 trouble-free miles on it so far. I have noticed a couple of small paint defects, but nothing I'm going to worry about. Certainly don't want to modify the factory finish in any way.

So far, I couldn't be happier. Just detailed it for the 2nd time since I"ve had it last night. Looks better than the day I drove it home from the dealership.
__________________
2011 Jeep Wrangler Unlimited Rubicon

2014 Grand Cherokee Limited 4x4 3.6L Deep Cherry Red

Reply With Quote
  #8  
Old 04-25-2013, 10:32 AM
mfa81's Avatar
Member
 
Join Date: Apr 2013
Location: Boise, ID
Posts: 301
Thanks: 0
Thanked 8 Times in 8 Posts
Rep Power: 852
mfa81 has a reputation beyond reputemfa81 has a reputation beyond repute
Re: Anyone else not having problems?

I also haven't had any issues so far... but I'm driving it for just about a week or so! The only actual dissatisfaction is about the easy entry/exit that should be auto according to the manual and it's not!

I haven't had any issues with uconnect once I learned how to setup, or key fob or any other leak water leak or anything like that!
__________________
Reply With Quote
  #9  
Old 04-25-2013, 11:15 AM
Sh0rtBus's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: North Texas
Posts: 391
Thanks: 0
Thanked 11 Times in 11 Posts
Rep Power: 2281
Sh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond repute
Garage
Re: Anyone else not having problems?

Quote:
Originally Posted by mfa81 View Post
I also haven't had any issues so far... but I'm driving it for just about a week or so! The only actual dissatisfaction is about the easy entry/exit that should be auto according to the manual and it's not!

I haven't had any issues with uconnect once I learned how to setup, or key fob or any other leak water leak or anything like that!
You have to go into the settings menu to enable the easy entry/exit. Works fine for mine...just decided to turn it off. Seems like it would wear out the seat motor that much faster.
__________________
2011 Jeep Wrangler Unlimited Rubicon

2014 Grand Cherokee Limited 4x4 3.6L Deep Cherry Red

Reply With Quote
  #10  
Old 04-25-2013, 11:26 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,138
Thanks: 213
Thanked 156 Times in 126 Posts
Rep Power: 89577
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: Anyone else not having problems?

No problems here.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #11  
Old 04-25-2013, 11:31 AM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,537
Thanks: 0
Thanked 24 Times in 21 Posts
Rep Power: 80160
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: Anyone else not having problems?

After over a year, I have no issues that are not design related (instruments you can't see in daylight, horrendous blind spots,...). Did buy a lifetime warrenty & corrected others (tablet instrument display, back up camera...). However from a standpoint of how it was designed there have been no issues. I do monitor misfires though.

Will be surprised if I get 30,000 miles from the tires & will replace with street Michelin X's when needed.

MPG sits on 19-20 around town and better on the road which I consider very good for something this big.

So all in all I like it better every day. Just wish the wiring diagram was available to owners.
Reply With Quote
  #12  
Old 04-25-2013, 11:31 AM
Member
 
Join Date: Jan 2013
Posts: 57
Thanks: 6
Thanked 0 Times in 0 Posts
Rep Power: 682
FAST_US is on a distinguished road
Re: Anyone else not having problems?

No issues so far!
It's been flawless!
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems Greenman Grand Cherokee - WJ 12 02-04-2013 10:15 PM
L.E.D problems BlackN'Blue Troubleshooting/Problems 11 07-22-2012 05:24 PM
Ac problems help! flyboy Troubleshooting/Problems 6 07-10-2012 07:16 AM
Two problems I need help with . jjslips Troubleshooting/Problems 4 01-18-2012 05:38 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community