Anyone have this sound? - Page 3 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 04-06-2015, 10:56 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Posts: 18
Thanks: 1
Thanked 2 Times in 2 Posts
Rep Power: 1208
judal98 is on a distinguished road
Re: Anyone have this sound?

Shocks bone dry here too

Reply With Quote
Sponsored Links
Advertisement
 
  #26  
Old 04-07-2015, 09:05 AM
210hawkeye's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Oct 2013
Location: Central Wisconsin
Posts: 124
Thanks: 0
Thanked 8 Times in 8 Posts
Rep Power: 1315
210hawkeye is on a distinguished road
Garage
Re: Anyone have this sound?

My 2012 Altitude had the same problem and the dealer replaced the rear shocks (they told me they didn't need to look at it and scheduled warranty repair) but the problem ended up being the bushing on the rear sway bar links. I replaced them all with new SRT sway bar and links. The dealer only charged me the difference in cost.


Sent from my iPod touch using JeepGarage
Reply With Quote
  #27  
Old 04-07-2015, 09:53 AM
Hitchhiking
 
Join Date: Aug 2014
Posts: 1,264
Thanks: 9
Thanked 196 Times in 168 Posts
Rep Power: 0
skunkd is on a distinguished road
Re: Anyone have this sound?

Quote:
Originally Posted by 210hawkeye View Post
My 2012 Altitude had the same problem and the dealer replaced the rear shocks (they told me they didn't need to look at it and scheduled warranty repair) but the problem ended up being the bushing on the rear sway bar links. I replaced them all with new SRT sway bar and links. The dealer only charged me the difference in cost.


Sent from my iPod touch using JeepGarage
Thanks for chiming in. I will ask the dealer to do the same if that is the case. I am going in for my first oil change in 500 miles so we'll see what the issue is on mine.
Reply With Quote
  #28  
Old 04-07-2015, 06:25 PM
210hawkeye's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Oct 2013
Location: Central Wisconsin
Posts: 124
Thanks: 0
Thanked 8 Times in 8 Posts
Rep Power: 1315
210hawkeye is on a distinguished road
Garage
Re: Anyone have this sound?

Is the sound all the time or only after a cold start? If it is a cold start issue it could be a the exhaust fitting is lose. Once it warms up the sound usually hoes away.


Sent from my iPod touch using JeepGarage
Reply With Quote
  #29  
Old 04-08-2015, 02:22 AM
Member
 
Join Date: Jul 2013
Posts: 34
Thanks: 0
Thanked 8 Times in 6 Posts
Rep Power: 1317
JTaylor is on a distinguished road
Re: Anyone have this sound?

All the time. Temperature or a recent startup has no impact on the sound and feel coming through the steering wheel and gas pedal.


Sent from my iPhone using JeepGarage
Reply With Quote
  #30  
Old 04-08-2015, 09:47 AM
Hitchhiking
 
Join Date: Aug 2014
Posts: 1,264
Thanks: 9
Thanked 196 Times in 168 Posts
Rep Power: 0
skunkd is on a distinguished road
Anyone have this sound?

U feel it in the steering wheel and gas pedal? That's ****ed up ours is just a noise.

Our gas pedal is drive by wire you can't feel anything through it...

Sent from my iPhone using JeepGarage
Reply With Quote
  #31  
Old 04-08-2015, 10:58 AM
Member
 
Join Date: Jul 2013
Posts: 34
Thanks: 0
Thanked 8 Times in 6 Posts
Rep Power: 1317
JTaylor is on a distinguished road
Re: Anyone have this sound?

Well I think those are my non cushioned contact points with the Jeep(my body being in the seat). But when I hear the noise, I do feel a very faint jiggling looseness coming through the steering wheel and pedal. And it's only when driving over minor road surface imperfections at slower speeds (less than 30mph or so).

Of course, it could be my mind playing tricks on me. :-). It feels just like you would expect something causing a sound like that to feel, so maybe it's just in my head. It's a very slight sensation coming through.


Sent from my iPhone using JeepGarage
Reply With Quote
  #32  
Old 04-15-2015, 11:49 AM
Oblivion's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Mar 2015
Location: South Riding
Posts: 110
Thanks: 75
Thanked 15 Times in 9 Posts
Rep Power: 16402
Oblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond repute
Re: Anyone have this sound?

Quote:
Originally Posted by 210hawkeye View Post
My 2012 Altitude had the same problem and the dealer replaced the rear shocks (they told me they didn't need to look at it and scheduled warranty repair) but the problem ended up being the bushing on the rear sway bar links. I replaced them all with new SRT sway bar and links. The dealer only charged me the difference in cost.


Sent from my iPod touch using JeepGarage
its been a week, did the problem return?

I have the same problem on my 2012 Laredo. Dealership found nothing (so they say). Although they did admit to hear it after i complained.

My guesses are:
1) bushing on sway bars as stated here
2) shocks' end caps see TBS 17-002-14 (i think)
3) i just got a recall letter on something inside my gas tank that needs to be removed and replaced with same item on the outside. I will post here my findings after the same dealership gets the part. This recall is TOTALLY INTEGRATED POWER MODULE (TIPM) CONTAINS AN INTERNAL FUEL PUMP RELAY THAT COULD OPERATE INTERMITTENTLY OR FAIL WITHOUT WARNING

if that recalled item would make that sound, i dont know. can some one pitch in on this?
Reply With Quote
  #33  
Old 04-15-2015, 01:16 PM
Hitchhiking
 
Join Date: Mar 2015
Posts: 113
Thanks: 4
Thanked 8 Times in 6 Posts
Rep Power: 0
2014wk2 is on a distinguished road
Re: Anyone have this sound?

I had a similar sounding issue on my 14.

Took to many times to get it figured out and Chrysler didn't seem concerned one bit.

First time I was told I was crazy and it was normal. I told them I was bringing it back in a week.

Next time they said it was the shock, but had to order. Two weeks later shock replaced no different

Next time. Basically told to deal with it by Chrysler customer service rep or whatever they call themselves. Told them they were buying it back then. Told me to bring it back in

Next time they had it for 3 days but figured out it was a loose bolt somewhere on the shock mount??? I'm not sure how that was missed if they changed the shock.


PITA and neither the dealer or Chrysler seemed concerned that a suspension component came from the factory lose.

It's the straw that broke the camels back and why I'll sadly never own another Chrysler or Jeep vehicle.
Reply With Quote
  #34  
Old 04-23-2015, 10:21 PM
Oblivion's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Mar 2015
Location: South Riding
Posts: 110
Thanks: 75
Thanked 15 Times in 9 Posts
Rep Power: 16402
Oblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond repute
Re: Anyone have this sound?

Just came from dealership. Test your JGC by sliding sunroof shade back. I have single pane sunroof 2012 WK2. Noise was inaudible or muffled most of the time. They have called for jeep star engineer to take over. I will report on what they find. So for now, at least in my case it doesn't seem issue is with shocks. I was very surprise for this finding as the noise was clearly from the back! but with the shade rolled back it seems something is getting pushed and not moving over bumps.


Sent from my iPhone using JeepGarage
Reply With Quote
  #35  
Old 05-13-2015, 07:08 PM
Oblivion's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Mar 2015
Location: South Riding
Posts: 110
Thanks: 75
Thanked 15 Times in 9 Posts
Rep Power: 16402
Oblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond reputeOblivion has a reputation beyond repute
Re: Anyone have this sound?

I know what I said is strange. But has anyone tested it!????


Sent from my iPhone using JeepGarage
Reply With Quote
  #36  
Old 05-13-2015, 10:02 PM
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Apr 2015
Location: Brooklyn, NY
Posts: 7
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 663
GX628 is on a distinguished road
Re: Anyone have this sound?

Did you get it fixed?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Do you have to have UConnect to have GPS Dave E 2014+ Cherokee-KL 17 11-09-2015 10:29 PM
Rattle sound from rear interior, anyone else have it? stech Interior/Exterior/Visual 14 07-03-2015 08:34 AM
Im wondering do I have the BA sound system??? KillaJeep4569 Audio/Visual/Navigation 1 04-26-2015 03:35 PM
Is this the same Clunk sound you have? Sound file attached. RTArnie Trouble Shooting/Problems/Service 2 03-27-2015 08:39 PM
i have a knocking sound rom the engin IxIconvict Grand Cherokee - WJ 45 06-07-2014 08:18 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:05 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.