Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-06-2011, 09:13 PM
Curly's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Oct 2010
Posts: 81
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1476
Curly is on a distinguished road
Could I have made a mistake?

It starts snowing before lunch time and is still snowing right now. When Iím ready to leave work around 5:20 I remote start the Overland. After 15 minutes I go out and itís all warmed up, the seat is warm, the steering wheel is warm, the rear defroster has done its job and all is good with the world. That is until I drive about three miles in snow mode. I get this warning that I need ďimmediate air suspension serviceĒ and all of the sudden the Jeep starts to ride like it has no suspension whatsoever. Itís bouncing over the smallest bumps in the road like they are foot deep pot holes. The select terrain system and the air suspension have died. When you try to change the setting you get the message ďservice air suspension systemĒ (not surprising) and nothing happens. The ride is so rough I think the Jeep is going to bounce itself into pieces. Iím driving in a pretty bad snow storm so Iím not stopping no matter what the dash says. I know I should stop but Iím more than a little pissed, after all this is a brand new car. On top of the suspension going dead the automatic wipers are also going crazy. The snow and any spray from cars was pretty constant but the wipers are cycling from full speed to normal to almost never wiping (Iíd have to hit the switch to get them going again) and repeating this over and over. After driving for about three or four miles like this, everything went back to normal. The suspension started working just as it has for the past three weeks and after a while the wipers went back to working as they should. I donít think the two things are related they just happened around the same time. I would hope there is a code stored for what happened to the air suspension but doubt there is anything on the wipers so good luck getting that sorted out. So Iím wondering ďCould I have made a mistakeĒ in buying this car?
__________________

__________________
2011 Overland
Brilliant Black Crystal Pearl
Light Frost Beige Interior
5.7 HEMI
Advanced Warning/Adaptive Cruise Control
Stealth Mode - No Logo on front and no Side Moldings
[SIGPIC][/SIGPIC]
Reply With Quote
  #2  
Old 01-06-2011, 09:19 PM
Cperez's Avatar
Premium Member
My Jeep: 2011 5.7L WK2
 
Join Date: Nov 2010
Location: Bethesda, MD
Posts: 765
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2116
Cperez is just really nice
Send a message via AIM to Cperez
Re: Could I have made a mistake?

Quote:
Originally Posted by Curly View Post
I would hope there is a code stored for what happened to the air suspension but doubt there is anything on the wipers so good luck getting that sorted out. So Iím wondering ďCould I have made a mistakeĒ in buying this car?
Maybe it's pissed that you debadged it.

Seriously, please report in with whatever findings come from the dealer (assuming you're taking it in or at least calling them). As part of a rain-sensing system, the wiper behavior may have actually thrown a code. Glad you made it home ok.
__________________

__________________
2011 JGC Overland 4x4
Mineral Gray/Black ē 5.7L Hemi ē 20" wheels
430n (RHB) ē Advanced Warning & ACC Group
Sharkfin antenna ē OEM roof rack/slush & cargo mats
Purchase date: 12.28.10

Reply With Quote
  #3  
Old 01-06-2011, 09:22 PM
MSCA's Avatar
Member
 
Join Date: Jul 2010
Posts: 696
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 2183
MSCA is on a distinguished road
Re: Could I have made a mistake?

Sound like some kind of weird electrical glitch.

On the other hand, more than a few people mentioned that the air suspension could be problematic. I'm NOT saying that's the case....because most people haven't reported any problems with it, but I'm sure that doesn't make you feel any better right now.
__________________
Reply With Quote
  #4  
Old 01-06-2011, 09:33 PM
Curly's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Oct 2010
Posts: 81
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1476
Curly is on a distinguished road
Re: Could I have made a mistake?

Quote:
Originally Posted by Cperez View Post
Maybe it's pissed that you debadged it.
That's what I was thinking.

I probably won't get it to the dealer until next week (I have a full day at work tomorrow), hope it has no other problems until then. Iíll report back then.
__________________
2011 Overland
Brilliant Black Crystal Pearl
Light Frost Beige Interior
5.7 HEMI
Advanced Warning/Adaptive Cruise Control
Stealth Mode - No Logo on front and no Side Moldings
[SIGPIC][/SIGPIC]
Reply With Quote
  #5  
Old 01-06-2011, 10:52 PM
Bmwister's Avatar
Member
 
Join Date: Oct 2010
Posts: 543
Thanks: 11
Thanked 13 Times in 9 Posts
Rep Power: 1995
Bmwister has a reputation beyond reputeBmwister has a reputation beyond reputeBmwister has a reputation beyond reputeBmwister has a reputation beyond repute
Re: Could I have made a mistake?

Curly, check all your fuses to ensure they're all snugly in place. I believe the transfer case, QL and the wipers have a common fuse that is not listed as such on the fuse table, but I recall someone talking (not on a forum, literally speaking I mean) about their QL at a party New Years Eve and how they simultaneously had a wiper problem too when they got a warning like you did. All I remember was their fuse cover was open & damp and that was the fix. It's worth a look anyway, right?
__________________
An expert is one who knows more and more about less and less until he knows absolutely everything about nothing.
---
2011 Jeep Grand Cherokee 4x4 Ltd
Silver, Hemi, 20" wheels, minimal doodads.
1st Jeep!
Reply With Quote
  #6  
Old 01-06-2011, 11:45 PM
MeanDean's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Sep 2010
Location: WA
Posts: 166
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 1589
MeanDean is on a distinguished road
Re: Could I have made a mistake?

Quote:
Originally Posted by Curly View Post
So I’m wondering “Could I have made a mistake” in buying this car?
IMO, it's probably a glitch that can be easily fixed. Honestly, this could be a problem that a $60K BMW or Mercedes that could experience. Why are you so eager to blame the Jeep before even giving your service department a chance to fix the problem? I would understand (a little) if this was a recurring problem or if there were others that had the same problem that went unresolved, but this doesn't seem to be the case. You are experiencing an isolated incident and you need to take your Jeep to the dealer.

If you just wanted to vent, well, that's fine. But did you make a mistake buying the GC? I don't think so.

Let us all know how it goes after you take your car to the dealer. Until then, I don't think it's fair to bash what I think is a very fine vehicle.

BTW, mine is perfect and I wouldn't trade it for a X5, ML350, LR4, Q7, et al.
__________________
2011 WK2 Overland 4x4 w/ QD II, 5.7 Hemi, 730N, Off-road Adventure II, Blackberry
Reply With Quote
  #7  
Old 01-07-2011, 12:10 AM
Curly's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Oct 2010
Posts: 81
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1476
Curly is on a distinguished road
Re: Could I have made a mistake?

Quote:
Originally Posted by Bmwister View Post
Curly, check all your fuses to ensure they're all snugly in place. I believe the transfer case, QL and the wipers have a common fuse that is not listed as such on the fuse table, but I recall someone talking (not on a forum, literally speaking I mean) about their QL at a party New Years Eve and how they simultaneously had a wiper problem too when they got a warning like you did. All I remember was their fuse cover was open & damp and that was the fix. It's worth a look anyway, right?
Thanks for the tip Bmwister, I'll check this out. That's whats great about this forum, more real information than you could find anyplace else.
__________________
2011 Overland
Brilliant Black Crystal Pearl
Light Frost Beige Interior
5.7 HEMI
Advanced Warning/Adaptive Cruise Control
Stealth Mode - No Logo on front and no Side Moldings
[SIGPIC][/SIGPIC]
Reply With Quote
  #8  
Old 01-07-2011, 12:30 AM
Curly's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Oct 2010
Posts: 81
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1476
Curly is on a distinguished road
Re: Could I have made a mistake?

Quote:
Originally Posted by MeanDean View Post
IMO, it's probably a glitch that can be easily fixed. Honestly, this could be a problem that a $60K BMW or Mercedes that could experience. Why are you so eager to blame the Jeep before even giving your service department a chance to fix the problem? I would understand (a little) if this was a recurring problem or if there were others that had the same problem that went unresolved, but this doesn't seem to be the case. You are experiencing an isolated incident and you need to take your Jeep to the dealer.

If you just wanted to vent, well, that's fine. But did you make a mistake buying the GC? I don't think so.

Let us all know how it goes after you take your car to the dealer. Until then, I don't think it's fair to bash what I think is a very fine vehicle.

BTW, mine is perfect and I wouldn't trade it for a X5, ML350, LR4, Q7, et al.
I hear you MeanDean, I too love the Grand Cherokee. I am doing some venting, but at the same time I'm not going to say itís ok to have what I would say is a major problem with a major system in a three week old car even if it is isolated. I hope it's something simple that I will never have to think about again. I wouldn't trade the Grand for any of the rides you listed, after-all; I could have bought any of them in the first place but chose the Grand.
__________________
2011 Overland
Brilliant Black Crystal Pearl
Light Frost Beige Interior
5.7 HEMI
Advanced Warning/Adaptive Cruise Control
Stealth Mode - No Logo on front and no Side Moldings
[SIGPIC][/SIGPIC]
Reply With Quote
  #9  
Old 01-07-2011, 03:09 AM
OneCent's Avatar
Premium Member
 
Join Date: Sep 2010
Location: Switzerland
Posts: 134
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1534
OneCent is on a distinguished road
Re: Could I have made a mistake?

Hmm, i dont like it when things only sometimes work. They should work or break. It gives me a bad feeling when things like you had happens.

I hope the error codes are in the memory and that the dealer can fix the problem.
__________________
Reply With Quote
  #10  
Old 01-07-2011, 03:46 AM
Knightrider03m's Avatar
Everyday I'm shuffling
My Jeep: 2012 3.0L
 
Join Date: May 2009
Location: In the mud now
Posts: 6,128
Thanks: 13
Thanked 18 Times in 18 Posts
Rep Power: 323322
Knightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond reputeKnightrider03m has a reputation beyond repute
Send a message via AIM to Knightrider03m
Re: Could I have made a mistake?

Did you have 4WD when all of this was going on?
__________________
-Marcus-
2012 Ford Escape XLT 3.0L V6 AWD White Suede
Current mods: 6000K HID low/hi beams; Passport 9500ix; Garmin NUVI50 5% Tint; Tinted Tails; Duel Exhaust; Debadge
Future mods: Lowing kit; Engine Tune; Black wheels; Monotone Paint Job
Reply With Quote
  #11  
Old 01-07-2011, 07:10 AM
MSCA's Avatar
Member
 
Join Date: Jul 2010
Posts: 696
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 2183
MSCA is on a distinguished road
Re: Could I have made a mistake?

Quote:
Originally Posted by OneCent View Post
Hmm, i dont like it when things only sometimes work. They should work or break. It gives me a bad feeling when things like you had happens.
That's why electrical glitches are such a pain in the ass....sometimes things work fine and other times things go wacky. Mechanical issues are so much easier because those problems don't usually come and go. Something is either broken or it's not.

The good news is that a mechanic who specializes in electrical systems can usually find electrical gremlins wherever they're hiding.
__________________
Reply With Quote
  #12  
Old 01-07-2011, 08:49 AM
rdalcanto's Avatar
Member
 
Join Date: Sep 2010
Location: Salt Lake City
Posts: 622
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2059
rdalcanto has a reputation beyond reputerdalcanto has a reputation beyond repute
Re: Could I have made a mistake?

Did you open the door and look at your ride height when it was riding so rough? Was it all the way down? I know that you said it eventually fixed itself, but did you try re-starting the car to see if that would fix it?
__________________

__________________
2011 WK2
Overland 4x4 Hemi with Off-Road II
Mineral Gray, Saddle Interior
Tech Package, Rear DVD
Ordered September 18th, 2010
Delivered 1/14/11
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I think someones made a mistake?? RK vs. RRO hella_wk Off Road Modifications 8 12-13-2010 10:49 PM
Before I make a mistake - someone chime in! Chris Grand Cherokee - WK 10 01-31-2010 06:46 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:17 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community