Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 -

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-08-2013, 11:46 AM
New Member
My Jeep: 2013 5.7L WK2
 
Join Date: Aug 2013
Location: Atlanta
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
2013JGC is on a distinguished road
Garage
ECO Mode problems with 5.7L

This is my first Post! I purchased a 2013 JGC about 6 months ago. Since then, I've noticed a definite hesitation, or shuddering, when accelerating at really any speed. I took it to the dealership, and they found no fault. The service manager did say that they are waiting for a computer update to address the issue. She also advised me to try altering fuel grades between fill-ups, from regular to premium. Has anyone else had this issue? And is there any other suggestions for me to try? And when is this "update" going to be issued? Thanks for your input!!
__________________

__________________
Reply With Quote
  #2  
Old 08-08-2013, 12:09 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 861 Times in 470 Posts
Rep Power: 1927153
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: ECO Mode problems with 5.7L

Quote:
Originally Posted by 2013JGC View Post
This is my first Post! I purchased a 2013 JGC about 6 months ago. Since then, I've noticed a definite hesitation, or shuddering, when accelerating at really any speed. I took it to the dealership, and they found no fault. The service manager did say that they are waiting for a computer update to address the issue. She also advised me to try altering fuel grades between fill-ups, from regular to premium. Has anyone else had this issue? And is there any other suggestions for me to try? And when is this "update" going to be issued? Thanks for your input!!
Welcome to JeepGarage!!

Yes this is a known issue for regular fuel, there is a Case on this and the software is Due next month.

You know if you have this issue if the problem is most felt under light acceleration on on slight grade in 4th or 5th gear... feels like a fish bite on a fishing pole.

Edit: It has nothing to do with ECO mode BTW, It will do this just as bad with that disabled.
__________________

__________________
Reply With Quote
  #3  
Old 08-08-2013, 12:11 PM
bumpinjeep's Avatar
Member
 
Join Date: Jul 2013
Posts: 152
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 690
bumpinjeep is on a distinguished road
Re: ECO Mode problems with 5.7L

Quote:
Originally Posted by Willx View Post
Welcome to JeepGarage!!

Yes this is a known issue for regular fuel, there is a Case on this and the software is Due next month.

You know if you have this issue if the problem is most felt under light acceleration on on slight grade in 4th or 5th gear... feels like a fish bite on a fishing pole.

Edit: It has nothing to do with ECO mode BTW, It will do this just as bad with that disabled.
Nice, glad its something that is being addressed.
__________________
2014 Grand Cherokee LTD
1997 Grand Cherokee Laredo - Lifted, ARB'd, Mud Terrains, ETC
2007 Nissan 350Z - Volks TAs, coilovers, carbon fiber kitted, yada yada yada
Reply With Quote
  #4  
Old 08-08-2013, 12:40 PM
New Member
My Jeep: 2013 5.7L WK2
 
Join Date: Aug 2013
Location: Atlanta
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
2013JGC is on a distinguished road
Garage
Re: ECO Mode problems with 5.7L

Thanks for the reply! I will try using premium in my next fill up and see if that makes a difference. I hadn't really noticed the "fishing pole tug" LOL, in any other gear mainly because I usually leave it in D. Nice analogy BTW!!
But that's exactly what it feels like! Nice to know someone validates what I am experiencing and I'm NOT Going nutz!
Looking forward to the update. Do you know if that is something covered under the warranty? And will I need to ask for this update or will I be contacted by Jeep?
__________________
Reply With Quote
  #5  
Old 08-08-2013, 12:44 PM
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Jun 2013
Location: Space coast florida
Posts: 31
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 578
scostuart is on a distinguished road
Re: ECO Mode problems with 5.7L

Had the TSB computer reflash done on my '13 Laredo X hemi, at dealer last this week. Immediately noticed the shudder gone. Much smoother through gear changes.
__________________
Reply With Quote
  #6  
Old 08-08-2013, 12:47 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 861 Times in 470 Posts
Rep Power: 1927153
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Premium fuel improves the issue but does not make it disappear.

The update is still tentative for September so there is a possibility it could get delayed. You will not likely be contacted unless you dealer is really good at following up. It will be covered under warranty as long as you have the complaint I described but only while the vehicle is in factory warranty.

You can always check back here, we (certainly I) will be discussing it when it is released. It effects 2011-2013 with your engine.
__________________
Reply With Quote
  #7  
Old 08-08-2013, 12:47 PM
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Jun 2013
Location: Space coast florida
Posts: 31
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 578
scostuart is on a distinguished road
Re: ECO Mode problems with 5.7L

Print out a copy of the TSB and take it to dealer. I believe the reflash was issued end of july 2013 so some dealers will have no clue what you are talking about.
__________________
Reply With Quote
  #8  
Old 08-08-2013, 12:49 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 861 Times in 470 Posts
Rep Power: 1927153
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by scostuart View Post
Had the TSB computer reflash done on my '13 Laredo X hemi, at dealer last this week. Immediately noticed the shudder gone. Much smoother through gear changes.
Different problem... you got a TCM update that affected shift patterns. The hesitation is different.

Mind you the shift update is also likely important to know about for the OP. Milous posted that at wjjeeps.com (wk2jeeps.com)... an excellent resource for TSB tracking!
__________________
Reply With Quote
  #9  
Old 08-08-2013, 01:08 PM
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Jun 2013
Location: Space coast florida
Posts: 31
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 578
scostuart is on a distinguished road
Re: ECO Mode problems with 5.7L

Yep. That was it......and Milous has an outstanding website.

Kudos to him for his work!
__________________
Reply With Quote
  #10  
Old 08-20-2013, 02:24 PM
Member
 
Join Date: May 2013
Posts: 11
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 630
rtm038 has a reputation beyond reputertm038 has a reputation beyond repute
Re: ECO Mode problems with 5.7L

Quote:
Originally Posted by Willx View Post
Welcome to JeepGarage!!

Yes this is a known issue for regular fuel, there is a Case on this and the software is Due next month.

You know if you have this issue if the problem is most felt under light acceleration on on slight grade in 4th or 5th gear... feels like a fish bite on a fishing pole.

Edit: It has nothing to do with ECO mode BTW, It will do this just as bad with that disabled.
My '13 does the same thing. Brought it to the dealer 3 weeks ago and they didn't notice the issue. Guess I'll have to wait until the update comes out and bring it to their attention.
__________________
Reply With Quote
  #11  
Old 08-20-2013, 02:36 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 861 Times in 470 Posts
Rep Power: 1927153
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by rtm038 View Post

My '13 does the same thing. Brought it to the dealer 3 weeks ago and they didn't notice the issue. Guess I'll have to wait until the update comes out and bring it to their attention.
We will post the info when it becomes available
__________________
Reply With Quote
  #12  
Old 08-20-2013, 02:46 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Aug 2013
Location: Annapolis, MD
Posts: 185
Thanks: 6
Thanked 0 Times in 0 Posts
Rep Power: 696
760hacker is on a distinguished road
Re: ECO Mode problems with 5.7L

So there are no mentions of this on the 2014 with the 5.7 but i have noticed a similar behavior. is there also an update forthcoming that is for the 2014?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
V8 eco mode vs V6 sport mode dtrvm Engine Performance/Intakes/Exhausts 8 08-13-2013 12:50 AM
Eco mode JonBed Grand Cherokee - WK2 - 1 05-21-2013 09:15 AM
eco mode of 4x4 ONU1974 Grand Cherokee - WK2 - 12 03-28-2013 05:51 PM
ECO mode jeepinusa Engine Performance/Intakes/Exhausts 2 03-19-2012 11:46 AM
5.7 Eco Mode kaww2 Engine Performance/Intakes/Exhausts 26 07-19-2011 03:37 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.